PDA

View Full Version : My browser no longer allows "view-source"?


NardoPolo
03-31-2004, 06:47 AM
When browsing a website with my browser at work (MS Internet Explorer, v. 5.00), if I choose the View pull-down menu and then choose Source, nothing happens.

Same if I right-click on the page and choose View Source. Nothing happens.

The selections aren't grayed out, they just don't work any longer.

With the exception: If I'm browsing a HTML file on the hard drive or on the local network, then View-Source works fine.

Is this perhaps some "added security" that our I.T. department added? Or maybe a known bug that was fixed since v.5.00? Or perhaps the result of some setting that I unwittingly changed?

Any ideas?

:confused:

fezpp
03-31-2004, 07:05 AM
I've seen this behaviour (very inconsistently) in the past. I think it is an IE bug but no-one has ever been able to confirm this. I've found reloading the page in a new browser window often sorts it out.

zuma
03-31-2004, 07:26 AM
I've been running into this for a long time now. Somewhere along the line I found a "fix" which makes "view source" work again.. at least for a while. Deleting temporary internet files seems to make it work properly again.

tools-internet options-delete files.

I'd be curious if someone knew the reason for this behavior, and if there is a more permanent fix out there.

Number
03-31-2004, 08:56 AM
zuma's suggestion should fix it. According to Microsoft (http://support.microsoft.com/default.aspx?scid=kb;en-us;306907) this is just an eccentricity of IE.

aahala
03-31-2004, 10:19 AM
I don't know if there's permanent solution. Your computer just seems to run out of space.

I've noticed a similar issue using Notepad alone, which I use to make webpages. Even a small file, edited and saved many times under the same file name in one session can led to not being able to proceed further. Notepad I think is supposed to handle 75-100K files, but I've locked things up with 35K. So I have to turned things off and start up again.

NardoPolo
03-31-2004, 05:32 PM
Many thanks to Zuma et al. Things are working like a charm now. :cool:

Mangetout
03-31-2004, 05:43 PM
I'd be curious if someone knew the reason for this behavior, and if there is a more permanent fix out there.I think the more permanent fix is called IE6.

fighting ignorant
03-31-2004, 06:37 PM
Nope, still happens from time to time in IE6. And that is the official fix - delete your temporary internet files.

The permanent fix is called Firefox, the browser (http://www.mozilla.org/products/firefox/) :-)

rowrrbazzle
03-31-2004, 08:00 PM
I use IE6 (Win98) and the only place this happens (that I've tried, anyway) is the SDMB. Deleting the temp files didn't work.

sigSEGV
03-31-2004, 10:47 PM
Are you viewing an HTTPS page? IE has an option to "do not cache secure pages" that will cause this to happen.

Mangetout
04-01-2004, 02:59 AM
Hmmm... odd; my impression was that IE5 was really buggy, 5.5 less so and 6 was pretty stable, but I moved to IE6 at the same time as moving from Win98 to XP, which might be significant.

Blornx
04-01-2004, 02:46 PM
Nope, still happens from time to time in IE6. And that is the official fix - delete your temporary internet files.

The permanent fix is called Firefox, the browser (http://www.mozilla.org/products/firefox/) :-)

Firefox fixes many things, but unfortunately saving you from having to delete your cache every so often is not one of them. It's still in beta form.