PDA

View Full Version : Why don't I have access to this folder?


bouv
05-13-2005, 12:41 PM
OK, so I did a virus scan overnight, and a few appeared! :eek:

It's in the documents and settings folder, under the user 'bouv.' I looked at the directory and files, and I can just delete them, they aren't any infected system files or anything. But I can't get into the bouv directory, I get an error saying access denied. But...I AM user bouv, I have administrtative powers! Why can't I explore the directory? Ahhh...think I found the reason. I reinstalled windows in this HD a while back and did not reformat beforehand. And when i made user 'bouv' on this Windows install, I called it 'Bouv' with a capitol B and therefore instead of overwriting that directory, it made it's own...but called it bouv.MCBOUV :confused: Where did that MCBOUV come from? While I have used that as a handle and screenname here and there (well, not here, but there) I never called my account that, so where did it come from? There's also a BOUV~1~MCB folder, what's that?

Anyhoo, all I need to now is this:

is there any way to explore that folder's content, or even just delete it outright? (i would rather explore it, as there are some pictures in there I thought I lost but apparanty must still be in there.) I mean...if the anitivirus can scan the folder, surely there must be a way I can explore it too, right?

ZipperJJ
05-13-2005, 12:58 PM
Can you log in as Administrator? Not as bouv-user-with-admin-powers, but the actual Administrator account.

When you installed windows it would have asked you to put in an Administrator password at some point in the setup wizard.

If you are using the XP User Switching screen (where you get pretty icons representing all your users), i think you hit CTRL+ALT+DEL to bring up a login box where you can type "Administrator" as the username and your password.

There's a couple of other ways to log in (depending on your current login scheme) but I'll be honest and say I don't know off the top of my head and can't check because I can't log off at the moment.

Anyway, loggin in as Administrator might get you into that folder.

bouv
05-13-2005, 04:32 PM
Nope, didn't work.

Odds are, they aren't causing any problems, since they are in a folder that can't be accessed, but still, it's the principle of the matter.

bouv
05-14-2005, 06:27 PM
Just giving a bump in te hopes someone has a solution.

Nanoda
05-14-2005, 06:49 PM
Well, logging on in Safe Mode is always worth a try, as is using a DOS command line.

bouv
05-15-2005, 05:56 PM
Nope, neither worked. I tried command prompt, command prompt in safe mode, administrator in safe mode, always access denied.

Johnny Angel
05-15-2005, 07:04 PM
I had a similar problem once that I managed to fix by booting from a floppy and deleting the directory from the DOS prompt. Maybe not having Windows running at all would make the difference.

bouv
05-16-2005, 11:18 AM
I had a similar problem once that I managed to fix by booting from a floppy and deleting the directory from the DOS prompt. Maybe not having Windows running at all would make the difference.

I'm 99% that won't work in my case. DOS uses FAT32, Win XP formats in NTFS. The DOS prompt in windows (the cmd command) is just an application under windows, I don't think it's possible to actually boot into DOS without Windows running with the NTFS file system. If I am wrong, thensomeone correct me and I will try this.

Ximenean
05-16-2005, 11:59 AM
Have you tried taking ownership of the directory? (Right-click/Properties/Security/Advanced). It's perfectly possible for an administrator not to have permissions to read a file or folder, but they can still take ownership of the file and then change the permissions.

bouv
05-16-2005, 11:55 PM
Umm...that's not an option. There is no security tab or button. And I click on the advanced button, and there's really nothing there.

I tried to unclick the read only button, but it doesn't unclick.

Ellis Dee
05-17-2005, 12:19 AM
Well, there's probably a better way to try this, but if it were me, I would try creating a whole new admin user and see if that user can access the files.

You don't get a security tab? Are you in XP, or 2000? You really should be seeing the security tab in the folder properties dialog of all the root user folders on the machine.

Instead of getting the "General, Sharing, Security, Customize" tabs, you're only getting "General, Sharing, Customize"?

The Read Only checkbox has nothing to do with permissions. It's the old DOS "read only" attriubute toggle.

arseNal
05-17-2005, 01:27 AM
I'm 99% that won't work in my case. DOS uses FAT32, Win XP formats in NTFS. The DOS prompt in windows (the cmd command) is just an application under windows, I don't think it's possible to actually boot into DOS without Windows running with the NTFS file system. If I am wrong, thensomeone correct me and I will try this.I've never used any myself, but I think there are some ways to get read-only access from a dos boot disk. www.sysinternals.com has a free utility (search for NTFSDOS). And--perhaps at the risk of stating the obvious--if you just google "ntfs dos" you'll find some other options.

As for the 'bouv.mcbouv' bit, I think that happened because when you re-installed XP, it wanted to make the user directory 'bouv' but that already existed. So, it tacked on the extension, and for the extension it would normally pick the name of the local computer or domain. Are you *sure* you never used 'mcbouv' for the computer name? I don't know about you, but I tend to name the computer once and never think about it again, so it's definitely something I could forget.

bouv
05-17-2005, 08:13 AM
I'm using XP, and none of the folders I click on anywhere have a security tab. I even logged in as administrator and still no security tab on any folder. Just 'General, Sharing, Customize.'

arseNal - Read only would be nice, but in the end I'm looking to a) get rid of the files that have the virus, and b) try and get back some documents I thought I lost (which thankfully are not in the same area as the virus.)

bouv
05-17-2005, 08:20 AM
OK, got the security tab. I had 'simple file sharing' checked in the folder options. :smack:

So what do I do now? I look at the owner, and it is listed as MCBOUV\Administrator. I switched to MCBOUV/Bouv (with a capitol B) and still could no access. Switched back to administrator, logged out and back in as Admin. and still no access. This is getting quite absurd.

And as to the MCBOUV, apparantly that is what I named the computer for filesharing.

Ellis Dee
05-17-2005, 08:36 AM
OK, got the security tab. I had 'simple file sharing' checked in the folder options. :smack:

So what do I do now?From the security tab:

- Click the Add button
- Click the Advanced button
- Click the Find Now button
- Select the user you want from the list and click OK
- Click the Check Names button (I'm anal retentive)
- Select all the checkboxes "on" for the user
- Click OK

If it's already set, try removing all the users in the "Group or user names" list first, and then do the previous steps.

Hope that helps, and I have (multiple times) found that certain user folders had their permissions corrupted, and so I had to delete all the permissions and recreate them as outlined.

bouv
05-17-2005, 08:38 AM
OK, some progress, I think. I went back in (before reading your newest post), cliekd back on Bouv, then clicked apply, and stuff happened. A windows popped up with images of fiels moving or whatnot saying it was changing permissions, and the address bar was scrolling through all the subdirectories. I had to leave for work so I won't see the result until noon-ish when I go home for lunch.

Ellis Dee
05-17-2005, 08:46 AM
OK, some progress, I think. I went back in (before reading your newest post), cliekd back on Bouv, then clicked apply, and stuff happened. A windows popped up with images of fiels moving or whatnot saying it was changing permissions, and the address bar was scrolling through all the subdirectories. I had to leave for work so I won't see the result until noon-ish when I go home for lunch.Sounds like you should be all set. Good deal.

When I upgraded one machine from 2000 to XP, I created three accounts: two limited accounts for the two users, and one admin account I only use for installing.

During this process, the "My Documents" folders for both limited accounts developed permission corruptions multiple times. Sometimes it was only a few files, sometimes it was entire trees. Very annoying.

But while I was fixing them, I saw the same dialog activity you describe, so I think you're on the right track. Don't get frustrated if it takes a couple tries.

bouv
05-17-2005, 01:46 PM
OK, so it mostly worked. I was abler to get in, and copy out all the files I wanted, but when I went to delete the rest, I still got an access denied message. Through trial and error of going in and deleting individual directories and files, I have found four or five files that will not delete (noe of them the files the virus was on, though.)

What gives? I basically get the same error. I go into the permissions area and do the same thing, but it doesn't let me change them. Once I get home, I will try restarting and trying again to see if that helps.

Ellis Dee
05-18-2005, 01:17 AM
I have found four or five files that will not delete (noe of them the files the virus was on, though.)

What gives? I basically get the same error. I go into the permissions area and do the same thing, but it doesn't let me change them. Once I get home, I will try restarting and trying again to see if that helps.This exact thing happened to me as well. Even though I'd set the entire tree's permissions, a handful of files inside that tree had somehow disconnect from the permission tree and failed to get set.

I was able to fix this by fiddling with the "Inherit permissions" checkbox in the Advanced area.

I eventually got frustrated and deleted all permissions, and then re-added only the permissions I wanted. In some cases I left the inheritance unchecked, which is generally not the best idea. If at all possible, you want everything inheriting permissions in order to lessen headaches (such as the ones you've got now) down the road.

Johnny Angel
05-25-2005, 01:58 PM
If deleting the files is still a problem, you might try something I read that recently helped me. Apparently Windows Explorer is what was blocking my ability to delete the file. You open a command line, and open the task manager. Turn off all other applications, and then use Task Manager to shut down explorer.exe. Delete the files from the DOS prompt, and then re-open explorer by clicking on the New Task icon of the Task Manager and entering 'explorer.exe.'