Reply
 
Thread Tools Display Modes
  #1  
Old 01-17-2017, 02:16 AM
PastTense PastTense is offline
Guest
 
Join Date: Jan 2013
Posts: 6,119
Google Chrome: I Want to Read But Not Download pdf files

I have started using Google Chrome. Adobe Acrobat is the default pdf viewer. I want to read but not download pdf files (unless I explicitly decide to save them). Right now it is dumping all of them into my Download folder. How do I do this? A setting somewhere? Or do I need a different pdf viewer?

Thanks.
  #2  
Old 01-17-2017, 02:50 AM
Mangetout Mangetout is offline
Charter Member
 
Join Date: May 2001
Location: England
Posts: 56,992
There's an extension discussed here that seems to do what you want (as well as some other document types)

(The file will still be downloaded though - that's technically true of any content that you view in your browser)
  #3  
Old 01-17-2017, 12:16 PM
Knowed Out Knowed Out is online now
Guest
 
Join Date: Nov 2001
Location: North Kakkalakee
Posts: 11,396
When you first download a PDF, it'll make a bottom bar with a tab. Right click on the tab and choose "Always open files of this type" and from then on, the PDFs will open.
  #4  
Old 01-17-2017, 12:57 PM
TroutMan TroutMan is online now
Guest
 
Join Date: Sep 2008
Location: Portland, OR
Posts: 3,765
Is the issue that you want to view the document in Chrome rather than Acrobat Reader? If so, you can use the extension Mangetout linked to, or use Chrome's native viewer. In the browser address bar, type chrome://plugins and enable the Chrome PDF Viewer.

However, if you don't want to download PDFs because of security concerns, you don't have a choice (other than not clicking on them). As noted, any content you view will be downloaded. Most of it goes in a cache directory instead of Downloads, but it's still being saved locally.
  #5  
Old 01-17-2017, 01:55 PM
PastTense PastTense is offline
Guest
 
Join Date: Jan 2013
Posts: 6,119
Yes. I want them downloaded into a temporary cache directory instead of being saved permanently.

In the Chrome://plugins it says Chrome PDF View is disabled by enterprise policy.

Last edited by PastTense; 01-17-2017 at 01:59 PM.
  #6  
Old 01-17-2017, 02:05 PM
Mangetout Mangetout is offline
Charter Member
 
Join Date: May 2001
Location: England
Posts: 56,992
Quote:
Originally Posted by PastTense View Post
In the Chrome://plugins it says Chrome PDF View is disabled by enterprise policy.
Is this on a work machine? If so, you might need to ask your IT department for help.
  #7  
Old 01-17-2017, 02:21 PM
PastTense PastTense is offline
Guest
 
Join Date: Jan 2013
Posts: 6,119
No, it's not a work machine. But I found the solution when I looked at the chrome://plugins

for the Adobe flash player plugin the "always allowed to run" checkbox was unchecked--so I checked it and now it works as I wished.

Thanks.
  #8  
Old 01-18-2017, 12:03 PM
BigT BigT is offline
Guest
 
Join Date: Aug 2008
Location: "Hicksville", Ark.
Posts: 33,116
Quote:
Originally Posted by PastTense View Post
No, it's not a work machine. But I found the solution when I looked at the chrome://plugins

for the Adobe flash player plugin the "always allowed to run" checkbox was unchecked--so I checked it and now it works as I wished.

Thanks.
That's weird. The built in PDF viewer (based on FoxIt Reader) is a different plugin than the Flash viewer. Maybe you were using a site that has a Flash-based PDF reader? I know I used to use a site like that.

If you run into problems in the future on a different site, I do suggest getting an addon that uses PDF.js, assuming you still can't get the built in PDF reader to work. I unfortunately do not know how you can change "enterprise policy."

Last edited by BigT; 01-18-2017 at 12:04 PM.
  #9  
Old 01-18-2017, 12:06 PM
BigT BigT is offline
Guest
 
Join Date: Aug 2008
Location: "Hicksville", Ark.
Posts: 33,116
That said, checking the Google help forums, I get this recommendation:

On advanced settings > content settings page, the last item, I had checked, “Open PDF files in the default PDF viewer application”. This is what disabled the Chrome PDF viewer. Adobe is my default PDF viewer, so the Chrome PDF viewer was disabled. When I unchecked this item, the Chrome PDF viewer was enabled again.
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:08 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.

Send questions for Cecil Adams to: cecil@chicagoreader.com

Send comments about this website to: webmaster@straightdope.com

Terms of Use / Privacy Policy

Advertise on the Straight Dope!
(Your direct line to thousands of the smartest, hippest people on the planet, plus a few total dipsticks.)

Publishers - interested in subscribing to the Straight Dope?
Write to: sdsubscriptions@chicagoreader.com.

Copyright 2017 Sun-Times Media, LLC.

 
Copyright © 2017