The Straight Dope

Go Back   Straight Dope Message Board > Main > General Questions

Reply
 
Thread Tools Display Modes
  #1  
Old 04-01-2003, 08:57 PM
Boyo Jim Boyo Jim is offline
Member
 
Join Date: Nov 2001
Location: Madison, WI
Posts: 30,871
Bad DVD (I Spy) or Bad Player? Subtitle problem

I have a new Toshiba model SD3805 DVD player , and I watched the "I Spy" DVD tonight. There are several points in the movie where actors speak in foreign languages. At that point, English subtitles appear.

The problem is, the subtitles don't go away when the foreign speaking does. The subtitles go away only when I hit the subtitle control and turn them off. Then they come on later, the next time there's a bit of some other language, and again they stay on til I switch them off.

So how do I figure out whether I have a badly designed disk (which I don't care much about since it's a rental), or a player that isn't responding to a command that's embedded in the disc to turn off the subtitles at the proper moment. Since it's a brand new player, it is a matter of some import to me.

I can't think of any other DVDs that I have to test this out. So maybe one of you has seen this movie and run across this problem, or knows of another DVD I can get hold where there subtitles should go on and off.
Reply With Quote
Advertisements  
  #2  
Old 04-01-2003, 09:32 PM
Slugworth Slugworth is offline
Guest
 
Join Date: Jul 2002
Didn't happen when I watched it, but I know older DVD players have problems with newer subtitles. One of my players refuses to display the subtitles on the DVD of 'Audition'.
Reply With Quote
  #3  
Old 04-01-2003, 09:34 PM
Slugworth Slugworth is offline
Guest
 
Join Date: Jul 2002
Didn't notice that you said your DVD player was new. Well, still, I imagine a new DVD player can have the same problems as older ones.
Reply With Quote
  #4  
Old 04-02-2003, 09:52 AM
handy handy is offline
BANNED
 
Join Date: Mar 1999
Location: Pacific Grove, Calif
Posts: 17,493
Hmmm, in this case there might be three types of subtitles:

1. english subs, selectable from a menu, for the deaf
2. english closed captions
3. english subs, not selectable from the menu, that are used to translate foreign voices to english automatically.

Seems like you are using #1, cause that one is the one that's supposed to come on when you use the SUB button on your remote.
Try to Turn off all SUBs from the main menu.
Reply With Quote
Reply



Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:11 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.

Send questions for Cecil Adams to: cecil@chicagoreader.com

Send comments about this website to: webmaster@straightdope.com

Terms of Use / Privacy Policy

Advertise on the Straight Dope!
(Your direct line to thousands of the smartest, hippest people on the planet, plus a few total dipsticks.)

Publishers - interested in subscribing to the Straight Dope?
Write to: sdsubscriptions@chicagoreader.com.

Copyright 2013 Sun-Times Media, LLC.