The Straight Dope

Go Back   Straight Dope Message Board > Main > General Questions

Reply
 
Thread Tools Display Modes
  #1  
Old 03-13-2008, 03:42 PM
Surly Chick Surly Chick is offline
Member
 
Join Date: Jul 2006
Location: Face down in the dirt.
Posts: 2,499
Browsers and Foreign Country Web Sites

Any advice on how I can stop my browser (IE) from directing me to the German web site of a company? I live in Germany but my German is nicht so gut. I'm trying to access the Cunard site but no matter how many times I type in Cunard.com, I get sent to Cunard.de. And there's no button to change the language. Any advice would be appreciated!

Yes, I am a Luddite.
Reply With Quote
Advertisements  
  #2  
Old 03-13-2008, 04:01 PM
robcaro robcaro is offline
Guest
 
Join Date: Nov 2001
Try entering: http://www.cunard.com/RegionSelect.asp
__________________
A committee is a thing which takes a week to do what one good man can do in an hour. ~Elbert Hubbard
Reply With Quote
  #3  
Old 03-13-2008, 04:09 PM
Surly Chick Surly Chick is offline
Member
 
Join Date: Jul 2006
Location: Face down in the dirt.
Posts: 2,499
Quote:
Originally Posted by robcaro
Gaaaaaaaaaaaaaaa! It lets me go to every single country except the US - I get a "HTTP 400 bad request" message. Jeez, who would think that it would be this hard to spend $4000???!
Reply With Quote
  #4  
Old 03-13-2008, 04:15 PM
robcaro robcaro is offline
Guest
 
Join Date: Nov 2001
Quote:
Originally Posted by Surly Chick
Gaaaaaaaaaaaaaaa! It lets me go to every single country except the US - I get a "HTTP 400 bad request" message. Jeez, who would think that it would be this hard to spend $4000???!
Hmmm.... that is very strange. I have no problem getting the USA page. Try to reboot and then go again. Can't help more than that... sorry.
__________________
A committee is a thing which takes a week to do what one good man can do in an hour. ~Elbert Hubbard
Reply With Quote
  #5  
Old 03-13-2008, 04:49 PM
MrSquishy MrSquishy is offline
Guest
 
Join Date: Oct 2005
Quote:
Originally Posted by Surly Chick
Gaaaaaaaaaaaaaaa! It lets me go to every single country except the US - I get a "HTTP 400 bad request" message. Jeez, who would think that it would be this hard to spend $4000???!
Interesting. It works fine for me too. The 400 error is strange too, and implies a problem on your end (not the server). Do you have any other web browsers you could try? Do you have any weird browser extensions (toolbars/spyware) installed?

You could use a web proxy like Proxify. You'll probably want to uncheck the privacy options (like "Remove all cookies" and "Remove all scripts") if you want to buy something (any kind of shopping cart type application is likely going to require the use of cookies and scripts).
Reply With Quote
  #6  
Old 03-13-2008, 06:22 PM
TheLoadedDog TheLoadedDog is online now
Guest
 
Join Date: Feb 2001
This is an annoyance for me with Google. I am automatically sent to Google Australia, which is normally a good thing as it can be quite useful, but even when I make sure the "Search Australian sites only" button is unchecked, it seems to load up the first returned results with local content. Problem is, if I go to the American home site, it still seems to happen. Normally no dramas, but there are times when it is quite a hassle.
Reply With Quote
  #7  
Old 03-13-2008, 09:27 PM
ChrisBooth12 ChrisBooth12 is offline
Guest
 
Join Date: Sep 2005
there is a way, a setting somewhere i think.. try to delete all your cookies. let me try and remember.
Reply With Quote
  #8  
Old 03-14-2008, 01:30 AM
Surly Chick Surly Chick is offline
Member
 
Join Date: Jul 2006
Location: Face down in the dirt.
Posts: 2,499
No go on any of the suggestions. Damn Germans. It happens with a lot of other sites (itues, E!, etc.) but I'm always able to get back to the US one with some finagling. I'll try the proxy server next but I'm gone for the next three days (unfortunately not back to the US where I can access the site!).

Thanks everyone!
Reply With Quote
  #9  
Old 03-14-2008, 01:52 AM
Princhester Princhester is offline
Charter Member
 
Join Date: Jan 2001
Location: Brisbane, Australia
Posts: 11,278
Quote:
Originally Posted by TheLoadedDog
This is an annoyance for me with Google. I am automatically sent to Google Australia, which is normally a good thing as it can be quite useful, but even when I make sure the "Search Australian sites only" button is unchecked, it seems to load up the first returned results with local content. Problem is, if I go to the American home site, it still seems to happen. Normally no dramas, but there are times when it is quite a hassle.
The url you are looking for is www.google.com/ncr

I assume the ncr stands for no country redirect.

Don't mention it
Reply With Quote
  #10  
Old 03-14-2008, 03:22 AM
Mops Mops is offline
Member
 
Join Date: Dec 2002
Location: Germany
Posts: 2,421
The Cunard thing would be a boneheaded redirect on the server side, probably based on your IP.

FWIW I also get redirected from http://cunard.com to http://cunard.de (accessing from a German IP address), and I cannot readily find a link to the English language site.

But the UK site http://cunard.co.uk/ does not redirect for me.
Reply With Quote
  #11  
Old 03-14-2008, 07:09 AM
TheLoadedDog TheLoadedDog is online now
Guest
 
Join Date: Feb 2001
Quote:
Originally Posted by Princhester
The url you are looking for is www.google.com/ncr

I assume the ncr stands for no country redirect.

Don't mention it
Thanks, but...

It doesn't help. I just tested it out by typing in the generic search "taxi", and the second hit was for Taxis Combined in Sydney. Four of the ten first page results were Australian. I might have to go and take a sledgehammer to my cookies, but I can't see that working for long either.
Reply With Quote
  #12  
Old 03-14-2008, 08:38 AM
Baron Greenback Baron Greenback is offline
Guest
 
Join Date: Jul 2006
Quote:
Originally Posted by TheLoadedDog
Thanks, but...
Are you logged into your Google account eg for Gmail or something? Try logging out, and then search via the ncr link.
Reply With Quote
  #13  
Old 03-14-2008, 08:43 AM
TheLoadedDog TheLoadedDog is online now
Guest
 
Join Date: Feb 2001
Quote:
Originally Posted by Struan
Are you logged into your Google account eg for Gmail or something? Try logging out, and then search via the ncr link.
Aaaaaah.

(Having a "D'oh!" moment here)

That might be the ticket. Thanks.
Reply With Quote
  #14  
Old 03-14-2008, 03:46 PM
Baraqiyal Baraqiyal is offline
Guest
 
Join Date: Feb 2000
You could try going through a proxy. Google "free proxy", and try to find one that doesn't load you down with ads.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:43 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.

Send questions for Cecil Adams to: cecil@chicagoreader.com

Send comments about this website to: webmaster@straightdope.com

Terms of Use / Privacy Policy

Advertise on the Straight Dope!
(Your direct line to thousands of the smartest, hippest people on the planet, plus a few total dipsticks.)

Publishers - interested in subscribing to the Straight Dope?
Write to: sdsubscriptions@chicagoreader.com.

Copyright 2013 Sun-Times Media, LLC.