The Straight Dope

Go Back   Straight Dope Message Board > Main > General Questions

Reply
 
Thread Tools Display Modes
  #1  
Old 08-21-2008, 04:14 AM
Cicero Cicero is offline
Member
 
Join Date: Apr 2001
Location: Australia
Posts: 8,476
Text comes out in capitals- without Caps Lock- keyboard?

Having a problem with the text on this computer. It will start coming out in capitals without having Caps Lock turned on (the Caps Lock light isn't lit and I have added a sound to alert me if the button is inadvertently hit).

Is this just the keyboard? It doesn't worry me buying a new one and they are extremely cheap. However, it would still go against the grain buying one if that isn't the problem.

(I am a typist who needs to look at the keys so it is a real pain to look up and find a screen full of capitals).
Reply With Quote
Advertisements  
  #2  
Old 08-21-2008, 07:15 AM
Hakuna Matata Hakuna Matata is offline
Charter Member
 
Join Date: Mar 2002
Location: here below that poster
Posts: 1,532
Is it one of the Microsoft curved keyboards? If so, I know some combination of key strokes puts it into some weird mode that types ALL CAPS but it also gives you one of these > instead of a .

I finally got rid of my keyboard because it drove me crazy. I could never remember the combination of keys that undid it--usually just pounded on the keyboard until it cleared up! Probably not the recommended method!

good luck
Reply With Quote
  #3  
Old 08-21-2008, 07:24 AM
Turek Turek is offline
Charter Member
 
Join Date: Jan 2003
Location: Inara's shuttle
Posts: 3,268
Go into the Accessibility Options control panel. You probably have Sticky Keys turned on, so that if you hold down the shift key, it locks it into All Caps mode. You can turn off this feature.... kind of.

Apparently, even if you DON'T have Sticky Keys turned on, I've found that in XP, this feature can still become activated. From what I've read googling, it's so someone handicapped can use your computer even though you have that functionality turned off. It's extremely irritating, as I have a tendancy to let my fingers linger over the shift or ctrl keys, which will also become "sticky."

To revert to normal typing, push both shift keys.
Reply With Quote
  #4  
Old 08-21-2008, 07:30 AM
Baldwin Baldwin is offline
BANNED
 
Join Date: Jul 2001
Location: Atlanta, Georgia, USA
Posts: 6,376
Or it could be a mechanical problem -- some kind of debris causing the Shift key to physically stick. Try shaking the keyboard upside down; see if a lot of crumbs fall out. (I've had to cut back on the amount of eating over the keyboard I do by about 30-35%.)
Reply With Quote
  #5  
Old 08-21-2008, 07:40 AM
Dead Cat Dead Cat is offline
Guest
 
Join Date: Feb 2005
On my system, Sticky Keys is turned on and off by pressing the shift key 5 times in succession. However, it should bring up a dialogue box each time.
Reply With Quote
  #6  
Old 08-21-2008, 07:52 AM
Cicero Cicero is offline
Member
 
Join Date: Apr 2001
Location: Australia
Posts: 8,476
Whew- thanks - but sadly I feel the answer is no to most.

It is not a curved keyboard- it is a standard HP flat Internet keyboard.

The computer runs on Vista, not XP. However sticky keys are turned off anyway.

If I turn the keyboard upside down only flat beer drips out.

And I don't think I have ever pressed any keys 5 times in succession. Except for very obvious ones in swear words.

Thanks again for your help but THIS THING IS GOING TO BE DEEP SIXED.
Reply With Quote
  #7  
Old 08-21-2008, 07:52 AM
ivan astikov ivan astikov is offline
BANNED
 
Join Date: Jun 2008
Location: Manchestuh, UK.
Posts: 7,879
Can anyone help on this slightly related theme? If you have typed out a sentence of text, then realise you have left the Caps Lock on, is there any way of transforming the text to lower-case?
Reply With Quote
  #8  
Old 08-21-2008, 08:22 AM
Harmonious Discord Harmonious Discord is offline
Guest
 
Join Date: Apr 1999
Quote:
Originally Posted by ivan astikov
Can anyone help on this slightly related theme? If you have typed out a sentence of text, then realise you have left the Caps Lock on, is there any way of transforming the text to lower-case?
In MS Word you can highlight and do a menu option.

Format / Change Case / Sentence Case

I hope you didn't just use a font that only displays capitals.
Reply With Quote
  #9  
Old 08-21-2008, 08:42 AM
Cicero Cicero is offline
Member
 
Join Date: Apr 2001
Location: Australia
Posts: 8,476
Please feel free to hijack this thread anywhere- I learn as I read. Thanks Harmonious Discord.
Reply With Quote
  #10  
Old 08-21-2008, 08:52 AM
yoyodyne yoyodyne is offline
Charter Member
 
Join Date: Dec 2002
Posts: 2,611
Quote:
Originally Posted by Cicero
Having a problem with the text on this computer. It will start coming out in capitals without having Caps Lock turned on (the Caps Lock light isn't lit and I have added a sound to alert me if the button is inadvertently hit).

Is this just the keyboard? It doesn't worry me buying a new one and they are extremely cheap. However, it would still go against the grain buying one if that isn't the problem.

(I am a typist who needs to look at the keys so it is a real pain to look up and find a screen full of capitals).
Have you tried restarting the computer?
Reply With Quote
  #11  
Old 08-21-2008, 08:54 AM
Cicero Cicero is offline
Member
 
Join Date: Apr 2001
Location: Australia
Posts: 8,476
Quote:
Originally Posted by yoyodyne
Have you tried restarting the computer?
It has been happening for about a fortnight and the computer has been restarted a few times- umm quite a few
Reply With Quote
  #12  
Old 08-21-2008, 09:21 AM
KneadToKnow KneadToKnow is offline
Voodoo Adult (Slight Return)
Charter Member
 
Join Date: Jul 2000
Location: Charlotte, NC, USA
Posts: 23,145
Quote:
Originally Posted by Harmonious Discord
In MS Word you can highlight and do a menu option.

Format / Change Case / Sentence Case

I hope you didn't just use a font that only displays capitals.
The keyboard shortcut for this is shift+F3. It will toggle through available case options for what you have selected. One letter, for instance will go back and forth between upper case and lower case, a whole word will toggle between initial capital > all upper > all lower. A sentence with punctuation at the end will toggle all upper > all lower > sentence case (first word initial cap, none others). A sentence with no punctuation will go all upper > all lower > title case (all words initial caps).

It's fun.
Reply With Quote
  #13  
Old 08-21-2008, 10:16 AM
Johnny L.A. Johnny L.A. is offline
Charter Member
 
Join Date: Jan 2000
Location: NoWA
Posts: 47,385
I have a problem with my work computer sometimes. (It's a PC. I haven't had many problems with the Mac.) In Excel I'll have the caps lock on. Sometimes out of habit I'll hit the Shift key when I start typing a word. At the second letter Excel changes the lower-case first letter and makes it upper-case, and the subsequent letters and changes them to lower-case. Only the caps lock is still on. When I type anything else in any other program cape is lower-case and lower-case is caps. It's very annoying. The only way I've found to fix it is to go into Excel with caps lock off (so it's typing in caps) and use Shift to start a word etc. Then it toggles back to normal.
Reply With Quote
  #14  
Old 08-21-2008, 11:10 AM
Noelq Noelq is offline
Charter Member
 
Join Date: Nov 2000
Location: Sacramento, CA
Posts: 705
1. When your problem happens, open up the Notepad utility on your computer. Its the little no-frills typing program.

2. Type in Notepad.

3. If the text in Notepad is capitalized, then its an issue with your keyboard, or a function found in the keyboard setup. If the text in Notepad is NOT capitalized, then its an issue with Excel.

4. If its an Excel issue, you need to look into the styles you have under the program. There is a specific font that always displays in all capital letters. Perhaps you've turned it on.
Reply With Quote
  #15  
Old 08-21-2008, 12:16 PM
JustThinkin' JustThinkin' is offline
Guest
 
Join Date: Nov 2007
Check your font. Some fonts are all caps. Word has an option in the font dialog window to use all caps or small caps.
Reply With Quote
  #16  
Old 08-21-2008, 03:49 PM
Cicero Cicero is offline
Member
 
Join Date: Apr 2001
Location: Australia
Posts: 8,476
We seem to have a few questions going at once here. If the previous two answers (and I don't think they do) relate to my query, unfortunately the answer is that the suggestions won't work- or my problem is different. I haven't used Excel, and it is an interim problem. That is half the line of Text will be in caps.

I am tending to think keyboard as the spacebar is not workingat times also- or not properly.
Reply With Quote
  #17  
Old 08-21-2008, 06:47 PM
Toaster Toaster is offline
Guest
 
Join Date: Jan 2001
Quote:
Originally Posted by Cicero
If I turn the keyboard upside down only flat beer drips out.

...Really? That can mess up keyboards right dandy. More than crumbs, for sure. (Liquid, that is.)
Reply With Quote
  #18  
Old 08-21-2008, 07:02 PM
Cicero Cicero is offline
Member
 
Join Date: Apr 2001
Location: Australia
Posts: 8,476
Quote:
Originally Posted by Toaster
...Really? That can mess up keyboards right dandy. More than crumbs, for sure. (Liquid, that is.)
I was only kidding. I don't waste beer.
Reply With Quote
  #19  
Old 08-22-2008, 06:15 PM
Johnny L.A. Johnny L.A. is offline
Charter Member
 
Join Date: Jan 2000
Location: NoWA
Posts: 47,385
Quote:
Originally Posted by Noelq
1. When your problem happens, open up the Notepad utility on your computer. Its the little no-frills typing program.

2. Type in Notepad.

3. If the text in Notepad is capitalized, then its an issue with your keyboard, or a function found in the keyboard setup. If the text in Notepad is NOT capitalized, then its an issue with Excel.

4. If its an Excel issue, you need to look into the styles you have under the program. There is a specific font that always displays in all capital letters. Perhaps you've turned it on.
Was this for me, or for the OP?

Just did some stuff in Excel. Accidentally toggled the caps by:
  • Having Caps Lock on
  • Typing the first character with Shift+character
  • Typing subsequent characters without Shift
The string should have looked like this: sTRING IN THE CELL. But Excell automatically changed it to String in the cell.

I didn't type in Notepad, but I did get into Internet Explorer and started typing an email with Caps Lock OFF. Letters were in caps. So Excel did some sort of global change in Windows. (See the list above. I did that again to get my keys back to normal.)

I'm only curious why it does this. I have a solution.
Reply With Quote
  #20  
Old 01-23-2013, 08:11 PM
Van1999 Van1999 is offline
Guest
 
Join Date: Jan 2013
Reverse Capslock Key function

This method works in Windows 7.
Ensure the capslock key is off before starting
Control Panel > Change keyboards or other input methods > Keyboards and Languages tab > Change keyboards > Advanced Key Settings tab
Change setting to use shift key to turn off Caps Lock and then click ok. Go back to the same window and turn it back to use caps lock button.
Reply With Quote
  #21  
Old 01-23-2013, 08:32 PM
Cicero Cicero is offline
Member
 
Join Date: Apr 2001
Location: Australia
Posts: 8,476
Ummm- this thread is almost 5 years old.

Heavens, I didn't even realise I started it. lets just say that keyboard is no longer in the land of the living.

Last edited by Cicero; 01-23-2013 at 08:35 PM..
Reply With Quote
  #22  
Old 01-23-2013, 08:51 PM
Alley Dweller Alley Dweller is online now
Guest
 
Join Date: Feb 2011
Quote:
Originally Posted by Cicero View Post
Ummm- this thread is almost 5 years old.

Heavens, I didn't even realise I started it. lets just say that keyboard is no longer in the land of the living.
So did replacing the keyboard fix the problem?

We've been waiting for you to report back.
Reply With Quote
  #23  
Old 01-23-2013, 09:01 PM
Cicero Cicero is offline
Member
 
Join Date: Apr 2001
Location: Australia
Posts: 8,476
I gave up typing instead and that fixed the problem.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 07:53 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.

Send questions for Cecil Adams to: cecil@chicagoreader.com

Send comments about this website to: webmaster@straightdope.com

Terms of Use / Privacy Policy

Advertise on the Straight Dope!
(Your direct line to thousands of the smartest, hippest people on the planet, plus a few total dipsticks.)

Publishers - interested in subscribing to the Straight Dope?
Write to: sdsubscriptions@chicagoreader.com.

Copyright 2013 Sun-Times Media, LLC.