The Straight Dope

Go Back   Straight Dope Message Board > Main > General Questions

Reply
 
Thread Tools Display Modes
  #1  
Old 03-14-2010, 03:55 PM
Spectre of Pithecanthropus Spectre of Pithecanthropus is offline
Charter Member
Charter Member
 
Join Date: Aug 1999
Location: Marmite Free Sector
Posts: 17,670
"Wireless capability on this computer is turned off". No, t'isn't!

I've had this notebook for about fourteen months, and I reset it to factory condition--due to a different problem--at the beginning of the year. All things considered, it's been a good computer, but lately I've been experiencing a frustrating issue. I've also seen this happen with other computers so I know there must be a lot of people with similar experiences.

So what is the problem? It's that the internal wireless adapter goes on the blink, sporadically. I haven't nailed down exactly when, but it may tend to happen after I've used the computer away from home and logged into a different wireless network. On these occasions, after bringing the computer home and trying to use it, the wireless connectivity works fine for about five minutes, and then the connection goes down.

Always, in this situation, the system loses ALL ability to see ANY routers in range. Normally, when I open the "Connect or Disconnect" window, I'll see not only my home network, but about a dozen others belonging to people elsewhere in the building. But invariably when I experience these outages, there's nothing. This makes it difficult and frustrating to google for solutions, because 99% start with, "1. Power cycle the gateway". Why would I even be looking at my own gateway or router, when I can't see ANY access points at all? The issue is obviously something in the computer.

After fiddling around with the diagnostics for quite some time, eventually--and I do stress the word eventually--reach a point where the system issues the message in the title. Finally, at this point, there's a button I can click to fix the issue; I do it, and then everything works again. But even though the system says that wireless capability is turned off, the physical switch to enable wireless is in the correct position, and the LED indicator says that wireless is turned on. Triple confirmation comes from the function keys, which also indicate that wireless is turned on.

Is there any way I can avoid this, or if not, how do I turn on internal wireless capability from a command prompt? What typed command at the prompt equals "click on <<Turn On Wireless Capability>>"?
Reply With Quote
Advertisements  
  #2  
Old 03-14-2010, 04:17 PM
Lobsang Lobsang is offline
Member
 
Join Date: Mar 2002
Location: Douglas, Isle of Man
Posts: 18,213
Have you checked that the "allow this device to be turned off to save power" option is turned off?

ETA: I don't have a wireless computer in front of me to enable me to find where that option is, but I think it's in the properties of the wireless adapter within windows' device manager settings page.

Last edited by Lobsang; 03-14-2010 at 04:18 PM..
Reply With Quote
  #3  
Old 03-14-2010, 07:17 PM
Spectre of Pithecanthropus Spectre of Pithecanthropus is offline
Charter Member
Charter Member
 
Join Date: Aug 1999
Location: Marmite Free Sector
Posts: 17,670
Quote:
Originally Posted by Lobsang View Post
Have you checked that the "allow this device to be turned off to save power" option is turned off?

ETA: I don't have a wireless computer in front of me to enable me to find where that option is, but I think it's in the properties of the wireless adapter within windows' device manager settings page.
Thanks for responding. Your memory served you correctly and I did find the option to which you refer in Device Manager. Both wireless adapters--and I don't know why there are two--had the automatic powerdown enabled, so I changed it. If this works for me I might be able fix my wife's computer as well.

On the other hand, if this root cause is correct, it sounds like there's something which either prevents the wireless adapter(s) from powering up on wake, or changing the allowed dormancy period to almost nothing.
Reply With Quote
  #4  
Old 03-14-2010, 08:14 PM
t-bonham@scc.net t-bonham@scc.net is offline
Guest
 
Join Date: Mar 2003
No idea what causes it, but sometimes I have seen it fixed by this:
1. go in and actually do 'turn off wireless connectivity for this computer'.
2. after waiting a minute or so, turn it back on again.
Reply With Quote
  #5  
Old 03-14-2010, 09:36 PM
Spectre of Pithecanthropus Spectre of Pithecanthropus is offline
Charter Member
Charter Member
 
Join Date: Aug 1999
Location: Marmite Free Sector
Posts: 17,670
Quote:
Originally Posted by t-bonham@scc.net View Post
No idea what causes it, but sometimes I have seen it fixed by this:
1. go in and actually do 'turn off wireless connectivity for this computer'.
2. after waiting a minute or so, turn it back on again.
Do you mean, set the physical switch on the machine to disable wireless, and then set it back to enable, after a minute?

Believe me, any workaround that doesn't entail rebooting the computer will be welcome.
Reply With Quote
  #6  
Old 03-14-2010, 10:05 PM
t-bonham@scc.net t-bonham@scc.net is offline
Guest
 
Join Date: Mar 2003
Quote:
Originally Posted by Spectre of Pithecanthropus View Post
Do you mean, set the physical switch on the machine to disable wireless, and then set it back to enable, after a minute?

Believe me, any workaround that doesn't entail rebooting the computer will be welcome.
On the ones I've seen this, it was a software setting, not a physical switch, that did the trick.
Reply With Quote
  #7  
Old 03-14-2010, 10:11 PM
Lobsang Lobsang is offline
Member
 
Join Date: Mar 2002
Location: Douglas, Isle of Man
Posts: 18,213
Quote:
Originally Posted by Spectre of Pithecanthropus View Post
Thanks for responding. Your memory served you correctly and I did find the option to which you refer in Device Manager. Both wireless adapters--and I don't know why there are two--had the automatic powerdown enabled, so I changed it. If this works for me I might be able fix my wife's computer as well.

On the other hand, if this root cause is correct, it sounds like there's something which either prevents the wireless adapter(s) from powering up on wake, or changing the allowed dormancy period to almost nothing.
Maybe the fact that you are seeing two of them is related to the problem. If you are still having the problem after trying the other things suggested in this thread (and you are willing to take a risk) then you could try removing all drivers, then reboot windows and allow it to 'find' the device again....

... chances are it'll have the required drivers built in, but if not, you might need to plug the computer into your router with an ethernet cable to allow it internet access to look for the drivers online.
Reply With Quote
  #8  
Old 03-14-2010, 10:54 PM
Spectre of Pithecanthropus Spectre of Pithecanthropus is offline
Charter Member
Charter Member
 
Join Date: Aug 1999
Location: Marmite Free Sector
Posts: 17,670
Quote:
Originally Posted by t-bonham@scc.net View Post
On the ones I've seen this, it was a software setting, not a physical switch, that did the trick.
So it would seem. The problem is that I don't know how to get at that software switch, unless the diagnostic tool presents the button to turn it on. I don't recall the exact sequence of events, but IIRC I had to reboot the system in order to have the diagnostic tool give me that option.
Reply With Quote
  #9  
Old 03-15-2010, 04:43 PM
Spectre of Pithecanthropus Spectre of Pithecanthropus is offline
Charter Member
Charter Member
 
Join Date: Aug 1999
Location: Marmite Free Sector
Posts: 17,670
Quote:
Originally Posted by Lobsang View Post
Have you checked that the "allow this device to be turned off to save power" option is turned off?
I've disabled this feature, and so far it's working.

The other network adapter I mentioned is just the Ethernet port, so it does belong there.
Reply With Quote
  #10  
Old 03-16-2010, 04:12 AM
si_blakely si_blakely is offline
Guest
 
Join Date: Jul 2002
Do you know what sort of wireless card you have? There is a common Intel based wireless adapter that can have problems of this sort. I had massive problems with my wifes Acer laptop, first ditching Vista for Ubuntu (because at least in Linux you can unload/reload the kernel module) and then eventually disabling the onboard wireless and installing a different (broadcom) one via the miniPCI slot.

Current Linux kernels have an updated module for the intel wireless, and it works really well. I have no idea about XP/Vista/Windows 7. I think that the wireless card firmware locks up the card, and Windows takes a long time to realise that the card is not responding. Once it does, you can reset the driver. However, there seems to be no way to do this manually. I hope your PowerSave setting helps, though.

Si
Reply With Quote
Reply



Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:13 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.

Send questions for Cecil Adams to: cecil@chicagoreader.com

Send comments about this website to: webmaster@straightdope.com

Terms of Use / Privacy Policy

Advertise on the Straight Dope!
(Your direct line to thousands of the smartest, hippest people on the planet, plus a few total dipsticks.)

Publishers - interested in subscribing to the Straight Dope?
Write to: sdsubscriptions@chicagoreader.com.

Copyright 2013 Sun-Times Media, LLC.