View Full Version : Why does my iPod open as a disk drive instead of starting iTunes?

02-27-2010, 02:18 PM
Why does my iPod open as a disk drive instead of starting iTunes? If I close the disk drive explorer window and start iTunes manually with the iPod plugged in, and look at its Options, there is a check next to "Open iTunes when this iPod is attached", and no check next to "Enable disk use". Shouldn't this make it open iTunes, and not look like a disk drive?

02-27-2010, 05:49 PM
Interesting that you should ask, given that there're some folks over in GD complaining that it doesn't do that.

02-27-2010, 07:01 PM
Should we trade? Or are they debating whether they like it or not?

Or should we all just jump into the Pit?

02-27-2010, 08:33 PM
Interesting that you should ask, given that there're some folks over in GD complaining that it doesn't do that.

Their argument is not that it doesn't open as a disk drive, but that you can't add music that way. (Or, if you can, it still requires you to have installed iTunes.

As to answering the question in the OP: try switching the settings, shut down iTunes, unplug the iPod, and waita few seconds. Plug it back in, start iTunes, and switch it back to the setting you want.

If that doesn't work, make sure you have all your music saved outside the iPod, and reset it to factory defaults. If you need to get the music off the iPod first,

02-27-2010, 09:09 PM
...copy the all the files on the ipod, including the hidden ones like iPod_Control. (Your music is actually in iPod_Control\Music) Make sure you have it where you can see hidden folders when you do this, as Apple went out of their way to hide the files from you. I don't know if you can restore all the files, but you'll have them if you can. Mainly, the files you want are in the subfolders of iPod_Control\Music. They all have funny names, but iTunes will still know the track information.

If you hadn't guessed, you put the music back on the iPod by dragging the music files back in. IF any of those tracks were already in iTunes, you'll have some duplicates. Removing them can be a pain. On windows, you'd probably want to use Easy Duplicate File Finder (http://www.easyduplicatefinder.com/), while there's a specific Applescript (http://dougscripts.com/itunes/itinfo/dupin.php) that will work on the Mac.

Yeah, that's a lot of hassle. Maybe it wouldn't be worth it. Hopefully the first option above will help.

(sorry about using two posts: I posted the reply when I shouldn't have, and didn't finish in time to edit.)

02-28-2010, 03:08 PM
BigT, thanks very much for this. Now the iPod is starting iTunes and not Windows Explorer - though it switched back before I actually did as you suggest. First it was working right, then it was screwing up, and now it is working right again. So, I don't know where the problem was, but I think I will wait and see.

I did, however, save your every last word against the time this starts misbehaving again.

There is an interesting point, here. Decades ago they taught us about computers that it was in their nature to be deterministic and practically perfectly error-free, so that if you did what you were supposed to, your probability of getting a proper result was practically 100%. The urging was that, since it takes days to try something (take your cards to the computer center, fill out a form, hand the shoebox to the people behind the window, and come back on Wednesday to see if you got a fanfold result), you should be quite sure you had no mistakes before you tried anything.

Now, we accept as a matter of routine that computer behavior will be quite variable and unpredictable. I think a typical session of using a computer now will include at least one event that appears to contradict the documentation and that all savvy users will agree is probably too difficult to ever figure out or attribute to a specific cause.

Maybe my iPod is misbehaving. Or, liklier, it is my PC that is doing something wrong, because it is a PC, and it won't ever be right, not ever, not even once. Never. Because it is a PC.

Anyway, thanks!