View Single Post
  #4  
Old 01-30-2020, 02:45 PM
Doug K. is offline
Guest
 
Join Date: Jul 1999
Location: Hutchinson, KS
Posts: 4,125
Quote:
Originally Posted by Skywatcher View Post
That's just the minimum requirement. Works fine on my Win 10 box.
On the store page it says :
Quote:
Notice: This product is not compatible with macOS 10.15 Catalina. Click here for more information.
10.15 was released in the fall. Clicking 'there' reveals that it's a 32 bit app and will only work with an older OS.