Reply
 
Thread Tools Display Modes
  #1  
Old 09-21-2019, 01:09 AM
Aspidistra is online now
Member
 
Join Date: Feb 2001
Location: Melbourne, Australia
Posts: 5,603

O Board, Y U no remember me?


These two things have been happening to me on the boards for the last three or four days. I keep looking to see if someone else has noticed the second and is complaining about it, but maybe it's just me?

1) Boards are marked 'Not Secure' in chrome. HTTPS certificate expired perhaps?
2) I'm constantly being logged out. Time was I could hit the 'remember me' button and I'd stay logged in forever. Now it seems to be timing me out about every hour (or so)

What's changed?

ETA: In a fit of supreme irony, the board logged me out while I was posting this...
__________________
Science created the modern world. Politics is doing its best to destroy it.

Last edited by Aspidistra; 09-21-2019 at 01:09 AM.
  #2  
Old 09-21-2019, 01:53 AM
harmonicamoon is offline
Guest
 
Join Date: Sep 2012
Location: Yucatan, Mexico
Posts: 3,043
And you paid your dues.

It ain't right!
  #3  
Old 09-21-2019, 02:21 AM
Beckdawrek's Avatar
Beckdawrek is offline
Member
 
Join Date: Aug 2017
Location: So.Ark ?
Posts: 17,917
I'll give you a reference.
  #4  
Old 09-21-2019, 04:29 AM
Aspidistra is online now
Member
 
Join Date: Feb 2001
Location: Melbourne, Australia
Posts: 5,603
That's very brave of you. Foolishly brave, even...
__________________
Science created the modern world. Politics is doing its best to destroy it.
  #5  
Old 09-21-2019, 06:18 AM
Enola Gay is offline
Guest
 
Join Date: Dec 2007
Location: California
Posts: 2,555
Use firefox; chrome sucks.
  #6  
Old 09-21-2019, 07:50 AM
Aspidistra is online now
Member
 
Join Date: Feb 2001
Location: Melbourne, Australia
Posts: 5,603
What's the difference?

(Sidenote - right now my little 'secure' padlock is back in action, and I didn't get logged out while I was AFK a few hours. So either the hamsters have been hard at work, or it's one of these observer-effect things...)
__________________
Science created the modern world. Politics is doing its best to destroy it.
  #7  
Old 09-21-2019, 08:31 AM
HurricaneDitka is offline
Guest
 
Join Date: Aug 2012
Posts: 14,571
I've been logged out frequently too. That may just be TPTB giving me a subtle hint.
  #8  
Old 09-21-2019, 08:45 AM
Thudlow Boink's Avatar
Thudlow Boink is offline
Charter Member
 
Join Date: May 2000
Location: Lincoln, IL
Posts: 27,584
Quote:
Originally Posted by Enola Gay View Post
Use firefox; chrome sucks.
I typically use Chrome and have never gotten logged out of the SDMB.

It does say "not secure"—something about the SDMB using the old http instead of https protocol?
  #9  
Old 09-21-2019, 08:46 AM
susan's Avatar
susan is offline
Guest
 
Join Date: Jul 2002
Location: Coastal USA
Posts: 9,605
I'm having neither of these issues in Chrome, FWIW.
  #10  
Old 09-21-2019, 09:09 AM
Max S. is offline
Guest
 
Join Date: Aug 2017
Location: Florida, USA
Posts: 1,550
Quote:
Originally Posted by Aspidistra View Post
1) Boards are marked 'Not Secure' in chrome. HTTPS certificate expired perhaps?
I'm running Mozilla Firefox but I don't have any of these problems. The certificate is good until January 10, 2020. I booted up Google Chrome to test, and noticed that entering "boards.straightdope.com" does not automatically use the HTTPS protocol. Explicitly typing "https://boards.straightdope.com" resolved that issue.

I recommend you make a bookmark for "https://boards.straightdope.com". That way if you begin to type, it will auto-fill the full HTTPS URL.

~Max
  #11  
Old 09-21-2019, 09:15 AM
Thudlow Boink's Avatar
Thudlow Boink is offline
Charter Member
 
Join Date: May 2000
Location: Lincoln, IL
Posts: 27,584
Quote:
Originally Posted by Max S. View Post
entering "boards.straightdope.com" does not automatically use the HTTPS protocol. Explicitly typing "https://boards.straightdope.com" resolved that issue.

I recommend you make a bookmark for "https://boards.straightdope.com".
Ah, that makes sense.

But how much does it matter?
  #12  
Old 09-21-2019, 09:31 AM
engineer_comp_geek's Avatar
engineer_comp_geek is offline
Robot Mod in Beta Testing
Moderator
 
Join Date: Mar 2001
Location: Pennsylvania
Posts: 25,025
Make sure your bookmarks (or whatever gets you here) has the https at the front of it. Using boards.straightdope.com alone might not be enough, depending on your browser.

The typical symptoms of using http instead of https are frequently getting logged out and having the theme switch back to the default but often-hated Sultanstheme.
  #13  
Old 09-21-2019, 09:52 AM
Max S. is offline
Guest
 
Join Date: Aug 2017
Location: Florida, USA
Posts: 1,550
Quote:
Originally Posted by Thudlow Boink View Post
Ah, that makes sense.

But how much does it matter?
For one, it's the difference between sending a password over an encrypted or unencrypted channel. Plus the other symptoms engineer_comp_geek mentioned.

~Max
  #14  
Old 09-21-2019, 11:44 AM
Duckster's Avatar
Duckster is offline
Charter Member
 
Join Date: Aug 2001
Posts: 14,659
Quote:
Originally Posted by Enola Gay View Post
Use firefox; chrome sucks.

Yes. Chrome has turned into a spyware repository.


https://www.washingtonpost.com/techn...s-time-switch/
  #15  
Old 09-21-2019, 12:54 PM
Skywatcher's Avatar
Skywatcher is offline
Charter Member
 
Join Date: Mar 1999
Location: Somewhere in the Potomac
Posts: 35,061
Quote:
Originally Posted by Duckster View Post
Yes. Chrome has turned into a spyware repository.


https://www.washingtonpost.com/techn...s-time-switch/
Meh. AdBlock Plus and no surfing via phone.
  #16  
Old 09-21-2019, 01:42 PM
Chefguy's Avatar
Chefguy is offline
Charter Member
 
Join Date: Jun 2003
Location: Portlandia
Posts: 42,425
Quote:
Originally Posted by Skywatcher View Post
Meh. AdBlock Plus and no surfing via phone.
And a pay wall.
  #17  
Old 09-21-2019, 02:46 PM
Skywatcher's Avatar
Skywatcher is offline
Charter Member
 
Join Date: Mar 1999
Location: Somewhere in the Potomac
Posts: 35,061
Sometimes I hit a pay wall, sometimes I don't.

My previous post was in reference to this:
Quote:
Look in the upper right corner of your Chrome browser. See a picture or a name in the circle? If so, you’re logged in to the browser, and Google might be tapping into your Web activity to target ads. Don’t recall signing in? I didn’t, either. Chrome recently started doing that automatically when you use Gmail.

Chrome is even sneakier on your phone. If you use Android, Chrome sends Google your location every time you conduct a search. (If you turn off location sharing it still sends your coordinates out, just with less accuracy.)
  #18  
Old 09-21-2019, 04:03 PM
Aspidistra is online now
Member
 
Join Date: Feb 2001
Location: Melbourne, Australia
Posts: 5,603
The way I get to the boards is by typing 'boa' and then it's the first link. I probably never specified which protocol in my life, and Chrome is curiously reluctant to divulge this information to me, but I did finally twist its arm enough to admit that - yes, that method is defaulting to https. Also, the current tab has been continuously open in my browser for about a month, so I don't think that was the problem! But the auto-logout has stopped at the exact same time that my machine has decided the dope's certificate IS right after all, so that's indicative of...something.

I don't give too much of a crap about the Borg targetting ads at me, and they're welcome to deduce I'm a lefty mature-age-student who's interested in science and music, for what good they can get out of it. Also ... lazy
__________________
Science created the modern world. Politics is doing its best to destroy it.
  #19  
Old 09-21-2019, 04:11 PM
harmonicamoon is offline
Guest
 
Join Date: Sep 2012
Location: Yucatan, Mexico
Posts: 3,043
Quote:
Originally Posted by engineer_comp_geek View Post
often-hated Sultanstheme.
I have no problem with the Sultan.
  #20  
Old 09-21-2019, 04:27 PM
Melbourne is offline
Guest
 
Join Date: Nov 2009
Posts: 5,322
Quote:
Originally Posted by Thudlow Boink View Post
I typically use Chrome and have never gotten logged out of the SDMB.

It does say "not secure"—something about the SDMB using the old http instead of https protocol?
Well son-of-a-gun you're right. A while back, the SDMB forced me off of my old computer by refusing to connect with http, but it's back again.
  #21  
Old 09-21-2019, 04:52 PM
RTFirefly is offline
Charter Member
 
Join Date: Apr 1999
Location: Maryland
Posts: 39,658
Quote:
Originally Posted by harmonicamoon View Post
I have no problem with the Sultan.
The Sultan has really poor taste in themes.
  #22  
Old 09-21-2019, 06:12 PM
kopek is offline
born to be shunned
 
Join Date: Jul 2007
Location: Southwestern PA
Posts: 15,372
Quote:
Originally Posted by Enola Gay View Post
Use firefox; chrome sucks.
Even with FireFox it does this in no pattern I have been able to comprehend. Sign in and start a reply and ------ logged out. Sign in and read a couple and ----- logged out. Log in and make a post right away and I'm safe for a while. Then its all normal for a month or three or four and then back to that again.

Never got any explanation; I blame the Communists. Just for lack of anyone to blame.
  #23  
Old 09-22-2019, 03:36 PM
Aspidistra is online now
Member
 
Join Date: Feb 2001
Location: Melbourne, Australia
Posts: 5,603
Update - I figured out what I did (and reproduced it)

What I did was I followed a link from another board (which was a plain http link). So then I had both secure and insecure board links up on different tabs, because I have a tendency to leave my preferred tabs open all the time and never bother shutting down my computer.

THEN what happened was - I chose a tab to discard, and it was the original one. The http one had been happily sitting there letting me use it for browsing the board and not logging me out as long as I was logged in also with https - it was just when it was the only link up that it started booting me.

So now we know...the rest of the story.
__________________
Science created the modern world. Politics is doing its best to destroy it.
  #24  
Old 09-24-2019, 07:05 AM
Jasmine's Avatar
Jasmine is offline
Member
 
Join Date: Jul 1999
Location: Chicagoland
Posts: 2,257
Quote:
1) Boards are marked 'Not Secure' in chrome. HTTPS certificate expired perhaps?
Chrome, to me at least, is the most "paranoid" browser there is. Even our own district web site is marked as "not secure". LOL

I think that, pretty much, every browser has its quirks, but I like Firefox.
__________________
"The greatest obstacle to discovery is not ignorance -- it is the illusion of knowledge."
--Daniel J Boorstin
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 07:17 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

Send questions for Cecil Adams to: cecil@straightdope.com

Send comments about this website to: webmaster@straightdope.com

Terms of Use / Privacy Policy

Advertise on the Straight Dope!
(Your direct line to thousands of the smartest, hippest people on the planet, plus a few total dipsticks.)

Copyright © 2019 STM Reader, LLC.

 
Copyright © 2017