# how common is the "defaulttext+customtexthere@somehost.com" email format?

**URL:** <https://boards.straightdope.com/t/how-common-is-the-defaulttext-customtexthere-somehost-com-email-format/561274>\
**Category:** Factual Questions\
**Created:** [November 19, 2010, 11:05pm UTC](https://boards.straightdope.com/t/how-common-is-the-defaulttext-customtexthere-somehost-com-email-format/561274 "2010-11-19T23:05:35Z")\
**Posts on this page:** 14\
**Page:** 1

<div class="post-metadata">

**Author:** ![Lobsang](https://sea3.discourse-cdn.com/straightdope/user_avatar/boards.straightdope.com/lobsang/32/4067_2.png) [@Lobsang](https://boards.straightdope.com/u/Lobsang)\
**Post date:** [November 19, 2010, 11:05pm UTC](https://boards.straightdope.com/t/how-common-is-the-defaulttext-customtexthere-somehost-com-email-format/561274/1 "2010-11-19T23:05:35Z")

</div>

Specifically, the ability to add any text you want preceded by a plus sign between the username and @ part of an email.

I was pleasantly impressed/surprised when I recently discovered that this could be done with Google Mail. It meant you could supply websites with a customized version of your address, and you would then know the source of any spam you get.

As a “wonder what will happen if” moment after discovering this, I tried the same feature on my other email address ([manx.net](http://manx.net)). It worked!

This makes me wonder how common this feature is on email services, and am I demonstrating my level of naivety by revealing that I only discovered this recently?

---

<div class="post-metadata">

**Author:** ![Nametag](https://sea3.discourse-cdn.com/straightdope/user_avatar/boards.straightdope.com/nametag/32/406_2.png) [@Nametag](https://boards.straightdope.com/u/Nametag)\
**Post date:** [November 19, 2010, 11:47pm UTC](https://boards.straightdope.com/t/how-common-is-the-defaulttext-customtexthere-somehost-com-email-format/561274/2 "2010-11-19T23:47:26Z")

</div>

From [Wikipedia](http://en.wikipedia.org/wiki/Email_address):

> [@](#):
>
> Some mail services allow a user to append a tag to their e-mail address (e.g., [joeuser+tag@example.com](mailto:joeuser+tag@example.com)). The text of tag may be used to apply filtering and to create single-use addresses. However, some mail servers violate RFC 5322, and the recommendations in RFC 3696, by refusing to send mail addressed to a user on another system merely because the local-part of the address contains the plus sign (+). On the other hand, most installations of the qmail and Courier Mail Server products support the use of a hyphen ‘-’ as a separator within the local-part, such as [joeuser-tag@example.com](mailto:joeuser-tag@example.com) or [joeuser-tag-sub-anything-else@example.com](mailto:joeuser-tag-sub-anything-else@example.com). This allows qmail through .qmail-default or .qmail-tag-sub-anything-else files to sort, filter, forward, or run an application based on the tagging system established. Disposable e-mail addresses of this form, using various separators between the base name and the tag are supported by several email services, including **Runbox (plus and hyphen), Google Mail (plus), Yahoo! Mail Plus (hyphen), Apple’s MobileMe (plus), FastMail.FM (plus and Subdomain Addressing), and MMDF (equals).** The name sub-addressing is the generic term (used for plus-addressing and hyphen-addressing) found in some IETF standards-track documents, such as RFC 5233.

So there are a few.

---

<div class="post-metadata">

**Author:** ![J\_Cubed](https://avatars.discourse-cdn.com/v4/letter/j/c6cbf5/32.png) [@J\_Cubed](https://boards.straightdope.com/u/J_Cubed)\
**Post date:** [November 19, 2010, 11:55pm UTC](https://boards.straightdope.com/t/how-common-is-the-defaulttext-customtexthere-somehost-com-email-format/561274/3 "2010-11-19T23:55:01Z")

</div>

I’ve known about this for a couple of years with gmail, but never thought about other providers doing it. I just tested this on the sendmail that ships with Solaris 10, and it works.

I have had problems submitting such an address, though. At least once, I went to actually use this for the obvious reason and the form rejected my address as invalid.

Also, in gmail, at least, you can add or subtract periods from your email address (when sending, not logging in) and it’ll still work. Like: [name@gmail.com](mailto:name@gmail.com) = [n.ame@gmail.com](mailto:n.ame@gmail.com)

---

<div class="post-metadata">

**Author:** ![Derleth](https://avatars.discourse-cdn.com/v4/letter/d/b9e5f3/32.png) [@Derleth](https://boards.straightdope.com/u/Derleth)\
**Post date:** [November 20, 2010, 10:18am UTC](https://boards.straightdope.com/t/how-common-is-the-defaulttext-customtexthere-somehost-com-email-format/561274/4 "2010-11-20T10:18:40Z")

</div>

[In case anyone cares, RFC 5322 defines what a valid email address looks like.](http://www.rfc-editor.org/rfc/rfc5322.txt) It’s technical, and it allows things that you’ll likely never see in the wild, like foo%bar@333.com and “I\ Love\ Bees”.“Don’t\ You”@[127.0.0.1]

[This is an interesting blog post on what a valid email looks like](http://www.dominicsayers.com/isemail/) which contains a list of common myths and is likely a lot easier to read than the relevant RFC, as is [his BNF grammar that describes a valid email address.](http://www.dominicsayers.com/source/is_email/extras/RFC5322BNF.html) [His list of test cases shows some very interesting addresses, both valid and invalid.](http://www.dominicsayers.com/isemail/results.php)

(You can’t do this with a regex. It is actually possible to prove this mathematically.)

[Ia! Ia! Regex Fthagan!](http://www.ex-parrot.com/~pdw/Mail-RFC822-Address.html) This is an extract from a Perl module that validates email addresses. It does so by gently massaging it first, and then feeding it to Shub-Regguroth there. It mentions RFC 822, which was superseded by RFC 2822, which was superseded by RFC 5322. In short, it’s either obsolete or misnamed and it solves the problem the wrong way anyway. However, if you stare at the regex long enough, you see a cool schooner.

---

<div class="post-metadata">

**Author:** ![si\_blakely](https://avatars.discourse-cdn.com/v4/letter/s/d9b06d/32.png) [@si\_blakely](https://boards.straightdope.com/u/si_blakely)\
**Post date:** [November 20, 2010, 10:38am UTC](https://boards.straightdope.com/t/how-common-is-the-defaulttext-customtexthere-somehost-com-email-format/561274/5 "2010-11-20T10:38:09Z")

</div>

It should be noted that since the tag has to be preceded by a valid email address, all a spammer has to do is strip the tag off, and you lose the info about where the email address came from. At least, that is what I would do.

What you need to be able to do is have a tag validation system that only allows certain tags through, and all other addresses (including the plain email address) are rejected. But that would be pretty complex and involved, and breaks the applicable RFCs.

Si

---

<div class="post-metadata">

**Author:** ![njtt](https://avatars.discourse-cdn.com/v4/letter/n/ecd19e/32.png) [@njtt](https://boards.straightdope.com/u/njtt)\
**Post date:** [November 20, 2010, 10:50am UTC](https://boards.straightdope.com/t/how-common-is-the-defaulttext-customtexthere-somehost-com-email-format/561274/6 "2010-11-20T10:50:25Z")

</div>

> [@Derleth](#):
>
> This is an extract from a Perl module that validates email addresses. It does so by gently massaging it first, and then feeding it to Shub-Regguroth there.

Lovecraft knew Perl?

---

<div class="post-metadata">

**Author:** ![Schnitte](https://sea3.discourse-cdn.com/straightdope/user_avatar/boards.straightdope.com/schnitte/32/9033_2.png) [@Schnitte](https://boards.straightdope.com/u/Schnitte)\
**Post date:** [November 20, 2010, 11:35am UTC](https://boards.straightdope.com/t/how-common-is-the-defaulttext-customtexthere-somehost-com-email-format/561274/7 "2010-11-20T11:35:02Z")

</div>

> [@Lobsang](#):
>
> It meant you could supply websites with a customized version of your address, and you would then know the source of any spam you get.

I know way too little about the protocols used in the web to direct data from A to B, and I’ve never heard about that, but does the effect you describe (finding out who’S spamming your or passed on your address to spammers) really work? I would guess these addresses work like catch-alls - all mail sent to an address that has the [defaulttext+customtext@somehost.com](mailto:defaulttext+customtext@somehost.com) format will end it the mailbox of [defaulttext@somehost.com](mailto:defaulttext@somehost.com). This makes it possible for spammers who want to hide where they got the address from to simply remove the customtext and send the spam to [defaulttext@somehost.com](mailto:defaulttext@somehost.com), or to make up a new customtext to which they send the spam. Or is there a process for the owner of the mailbox to define the customtexts he’s using, with all mail sent to undefined variants bouncing?

---

<div class="post-metadata">

**Author:** ![ExcitedIdiot](https://avatars.discourse-cdn.com/v4/letter/e/ea5d25/32.png) [@ExcitedIdiot](https://boards.straightdope.com/u/ExcitedIdiot)\
**Post date:** [November 20, 2010, 4:13pm UTC](https://boards.straightdope.com/t/how-common-is-the-defaulttext-customtexthere-somehost-com-email-format/561274/8 "2010-11-20T16:13:38Z")

</div>

I’ve used this Gmail feature a lot. It unfortunate though, most places will reject an email that has a + in it.

I used it yesterday, a crappy online merchant offered me free shipping if I tell 10 friends about their site. [myname+1@gmail.com](mailto:myname+1@gmail.com), [myname+2@gmail.com](mailto:myname+2@gmail.com)… and so on.

---

<div class="post-metadata">

**Author:** ![Canadjun](https://avatars.discourse-cdn.com/v4/letter/c/76d3ee/32.png) [@Canadjun](https://boards.straightdope.com/u/Canadjun)\
**Post date:** [November 20, 2010, 4:17pm UTC](https://boards.straightdope.com/t/how-common-is-the-defaulttext-customtexthere-somehost-com-email-format/561274/9 "2010-11-20T16:17:10Z")

</div>

> [@si\_blakely](#):
>
> It should be noted that since the tag has to be preceded by a valid email address, all a spammer has to do is strip the tag off, and you lose the info about where the email address came from. At least, that is what I would do.

If you used a tag for **all** your e-mails, then you could junk any incoming e-mails that didn’t have a tag.

---

<div class="post-metadata">

**Author:** ![Lobsang](https://sea3.discourse-cdn.com/straightdope/user_avatar/boards.straightdope.com/lobsang/32/4067_2.png) [@Lobsang](https://boards.straightdope.com/u/Lobsang)\
**Post date:** [November 20, 2010, 7:27pm UTC](https://boards.straightdope.com/t/how-common-is-the-defaulttext-customtexthere-somehost-com-email-format/561274/10 "2010-11-20T19:27:28Z")

</div>

All places I’ve used the feature on so far have accepted it. I replaced my sdmb address with one containing +sdmb in it.

I quickly thought of the possibility of spammers simply removing the +customtext part, but I suspect the chance of this being carried out on automated mailshots that use acquired mail lists to be remote enough to make it worth doing.

---

<div class="post-metadata">

**Author:** ![ZipperJJ](https://sea3.discourse-cdn.com/straightdope/user_avatar/boards.straightdope.com/zipperjj/32/211_2.png) [@ZipperJJ](https://boards.straightdope.com/u/ZipperJJ)\
**Post date:** [November 21, 2010, 6:39am UTC](https://boards.straightdope.com/t/how-common-is-the-defaulttext-customtexthere-somehost-com-email-format/561274/11 "2010-11-21T06:39:06Z")

</div>

FWIW, Ipswitch’s IMail Server allows for the hyphenated address. It actually creates a new folder for the user - as in, if I send to [ZipperJJ-whatever@zipperjj.com](mailto:ZipperJJ-whatever@zipperjj.com) the mail would not be sent to the inbox but to the auto-created whatever folder.

This is handy for auto-creating spam folders for users (tell the spam software to append -spam to the TO address once an email is marked as spam, and they’ve now got a spam folder) but sort of worthless to the user unless they know to check mail in the “whatever” folder by logging in to POP using [username-whatever@domain.com](mailto:username-whatever@domain.com).

Then again, IMail is a POS.

---

<div class="post-metadata">

**Author:** ![Terry\_Kennedy](https://avatars.discourse-cdn.com/v4/letter/t/c57346/32.png) [@Terry\_Kennedy](https://boards.straightdope.com/u/Terry_Kennedy)\
**Post date:** [November 21, 2010, 9:32am UTC](https://boards.straightdope.com/t/how-common-is-the-defaulttext-customtexthere-somehost-com-email-format/561274/12 "2010-11-21T09:32:10Z")

</div>

> [@Lobsang](#):
>
> This makes me wonder how common this feature is on email services, and am I demonstrating my level of naivety by revealing that I only discovered this recently?

That’s the CMU Andrew subaddress format and it has been around for _ages_ - at least 20 years.

Even if your (receiving) system supports it, you’re going to run into problems using a subaddress on various web sites. Some email address “validators” don’t accept it, and some systems will accept it but are broken elsewhere - for example, a common problem is that “unsubscribe” links in email messages won’t work unless you change [a+b@example.com](mailto:a+b@example.com) to a%2bb@example.com (%2b is the code for the plus sign). And some systems will happily let you register with a subaddress, but won’t allow you to log in, or will be unable to send you email.

As an example, note that this site (SDMB) allows you to sign up with a subaddress, but only one of the above addresses gets auto-hotlinked as an email address. And that’s in the commercial vBulletin® software, which is very widely used.

I used to sic Ned Freed (he’s the guy who wrote or co-authored most of the modern email RFC’s [standards]) on non-conforming sites, but it really isn’t worth the bother these days. The clueless outnumber us…

Personally, I’ve given up. Since I _am_ my ISP, I’ve configured my mail server to rewrite anything that comes in as [user-something@example.com](mailto:user-something@example.com) to [user+something@example.com](mailto:user+something@example.com). That way, I can sign up with a hypen in the email address (which everything accepts), but still have my mail program treat it as subaddressed mail and filter it.

---

<div class="post-metadata">

**Author:** ![yoyodyne](https://avatars.discourse-cdn.com/v4/letter/y/a9a28c/32.png) [@yoyodyne](https://boards.straightdope.com/u/yoyodyne)\
**Post date:** [November 22, 2010, 5:42pm UTC](https://boards.straightdope.com/t/how-common-is-the-defaulttext-customtexthere-somehost-com-email-format/561274/13 "2010-11-22T17:42:07Z")

</div>

[spamgourmet](http://spamgourmet.com/) will let you do something similar. You can set a limit on the number of emails sent to an address, plus you don’t give out your real address so spammers can’t just strip the tag. I’ve used it for years.

---

<div class="post-metadata">

**Author:** ![Rasa](https://sea3.discourse-cdn.com/straightdope/user_avatar/boards.straightdope.com/rasa/32/3578_2.png) [@Rasa](https://boards.straightdope.com/u/Rasa)\
**Post date:** [November 22, 2010, 6:28pm UTC](https://boards.straightdope.com/t/how-common-is-the-defaulttext-customtexthere-somehost-com-email-format/561274/14 "2010-11-22T18:28:10Z")

</div>

> [@J\_Cubed](#):
>
> Also, in gmail, at least, you can add or subtract periods from your email address (when sending, not logging in) and it’ll still work. Like: [name@gmail.com](mailto:name@gmail.com) = [n.ame@gmail.com](mailto:n.ame@gmail.com)

RAAAARGH. I signed up with [firstname.lastname@gmail.com](mailto:firstname.lastname@gmail.com) and didn’t realize this years ago–if you send mail to [firstnamelastname@gmail.com](mailto:firstnamelastname@gmail.com) I get it as well. I get more misdirected email than mail intended for me at that address!
