# IPv4 -\> IPv6  - how will it happen?

**URL:** <https://boards.straightdope.com/t/ipv4-ipv6-how-will-it-happen/427962>\
**Category:** Factual Questions\
**Created:** [November 27, 2007, 9:20pm UTC](https://boards.straightdope.com/t/ipv4-ipv6-how-will-it-happen/427962 "2007-11-27T21:20:50Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![ticker](https://avatars.discourse-cdn.com/v4/letter/t/d07c76/32.png) [@ticker](https://boards.straightdope.com/u/ticker)\
**Post date:** [November 27, 2007, 9:20pm UTC](https://boards.straightdope.com/t/ipv4-ipv6-how-will-it-happen/427962/1 "2007-11-27T21:20:50Z")

</div>

It seems [IPv4 addresses are running out](http://news.bbc.co.uk/1/hi/technology/7068140.stm) and we will have to migrate to IPv6. I am interested in how this migration take place.

If my ISP assigned me an IPv6 address what would I need to change? Is most up-to-date software compatible? What about legacy stuff? I assume my router will need to be upgraded.

What about interoperability between v4 & v6? Could I reach a v6 address now? Could a node with a v6 address contact v4s? Could I mix v4 & v6 on my home network?

Please share any more observations on points I haven’t thought of also.

---

<div class="post-metadata">

**Author:** ![XT](https://sea3.discourse-cdn.com/straightdope/user_avatar/boards.straightdope.com/xt/32/456_2.png) [@XT](https://boards.straightdope.com/u/XT)\
**Post date:** [November 27, 2007, 9:30pm UTC](https://boards.straightdope.com/t/ipv4-ipv6-how-will-it-happen/427962/2 "2007-11-27T21:30:18Z")

</div>

Here is a fairly decent [Wiki](http://en.wikipedia.org/wiki/IPv6) article on IPv6. I’ll insert some of the highlights. I think the BBC article is a bit overblown, personally. It simply isn’t true that (to paraphrase) ‘every device that goes online needs a public IP address’. That is pretty much why NAT and RFC 1918 were invented…to allow for the private addressing and translation of addresses to public accessible IP addresses. Most companies bury the IP devices (such as email servers) behind a NAT gateway these days.

Anyway, check out the article:

> [@](#):
>
> Internet Protocol version 6 (IPv6) is a network layer for packet-switched internetworks. It is designated as the successor of IPv4, the current version of the Internet Protocol, for general use on the Internet.
> 
> The main change brought by IPv6 is a much larger address space that allows greater flexibility in assigning addresses. It was not the intention of IPv6 designers, however, to give permanent unique addresses to every individual and every computer. Rather, the extended address length eliminates the need to use network address translation to avoid address exhaustion, and also simplifies aspects of address assignment and renumbering when changing providers.
> 
> It is common to see examples that attempt to show that the IPv6 address is absurdly large. For example, IPv6 supports 2128 (about 3.4×1038) addresses, or approximately 5×1028 addresses for each of the roughly 6.5 billion people[1] alive today. In a different perspective, this is 252 addresses for every star in the known universe [1] - a million times as many addresses per star than IPv4 supported for our single planet. These examples, however, have an underlying and incorrect assumption that the goal of IPv6 is the dense assignment of unique addresses to every possible entity.
> 
> The large number of addresses allows a hierarchical allocation of addresses that may make routing and renumbering simpler. With IPv4, complex CIDR techniques were developed to make the best possible use of a restricted address space. Renumbering, when changing providers, can be a major effort with IPv4, as discussed in RFC 2071 and RFC 2072. With IPv6, however, renumbering becomes largely automatic, because the host identifiers are decoupled from the network provider identifier. Separate address spaces exist for ISPs and for hosts, which are “inefficient” in address space bits but are extremely efficient for operational issues such as changing service providers.

> [@](#):
>
> IPv4 exhaustion
> 
> Estimates as to when the pool of available IPv4 addresses will be exhausted vary widely, and should be taken with caution. In 2003, Paul Wilson (director of APNIC) stated that, based on then-current rates of deployment, the available space would last until 2023.[5] In September 2005 a report by Cisco Systems reported that the pool of available addresses would be exhausted in as little as 4 to 5 years.[6] As of November 2007, a daily updated report projected that the IANA pool of unallocated addresses would be exhausted in May 2010, with the various Regional Internet Registries using up their allocations from IANA in April 2011.[7] This report also argues that, if assigned but unused addresses were reclaimed and used to meet continuing demand, allocation of IPv4 addresses could continue until 2017.

-XT
