# What is the oldest website on the Internet?

**URL:** <https://boards.straightdope.com/t/what-is-the-oldest-website-on-the-internet/43074>\
**Category:** Factual Questions\
**Created:** [November 28, 2000, 7:56pm UTC](https://boards.straightdope.com/t/what-is-the-oldest-website-on-the-internet/43074 "2000-11-28T19:56:27Z")\
**Posts on this page:** 19\
**Page:** 2

<div class="post-metadata">

**Author:** ![Chas.E](https://avatars.discourse-cdn.com/v4/letter/c/e99b99/32.png) [@Chas.E](https://boards.straightdope.com/u/Chas.E)\
**Post date:** [November 29, 2000, 12:40am UTC](https://boards.straightdope.com/t/what-is-the-oldest-website-on-the-internet/43074/21 "2000-11-29T00:40:53Z")

</div>

I saw a video of Tim Berners-Lee demonstrating an archived version of his first website experiments. He developed it on a NextCube. It wasn’t really that interesting, it was more like the personal info web pages you saw in the early days of the web. You know, a sparse all-text page with a contact address, a few subpages of technical info on some computer stuff.

If you want to see the first web-like interface, Stanford recently published video clips on the web of a lecture by Englebart, the mouse inventor. He demonstrated the first implementation of a point and click interface with hyperlinks. Must date back to the early 1960s sometime.

---

<div class="post-metadata">

**Author:** ![Spectre\_of\_Pithecanthropus](https://sea3.discourse-cdn.com/straightdope/user_avatar/boards.straightdope.com/spectre_of_pithecanthropus/32/12343_2.png) [@Spectre\_of\_Pithecanthropus](https://boards.straightdope.com/u/Spectre_of_Pithecanthropus)\
**Post date:** [November 29, 2000, 12:53am UTC](https://boards.straightdope.com/t/what-is-the-oldest-website-on-the-internet/43074/22 "2000-11-29T00:53:49Z")

</div>

> [@](#):
>
> \*Originally posted by peace \*  
> \*\* several (12 or so) university and research computers, UCal, Upenn, the **Petagon** , among them. I cold be mistaken, though. \*\*

The Petagon—central headquarters for the defense of dogs and cats.😃

---

<div class="post-metadata">

**Author:** ![peace](https://avatars.discourse-cdn.com/v4/letter/p/c68b51/32.png) [@peace](https://boards.straightdope.com/u/peace)\
**Post date:** [November 29, 2000, 3:49am UTC](https://boards.straightdope.com/t/what-is-the-oldest-website-on-the-internet/43074/23 "2000-11-29T03:49:41Z")

</div>

Shiva, I think it was below the belt. First you obliquely aknowledged that you did not know something, then, instead of “retro-geek”, you yourself came back and made fool of yourself:  
\<\< “A little knowledge is a dangerous thing”? \>\> whoever said it implied that the danger is in the unwillingness to learn. I very vaguely remembered the story which Minkman knows by heart. I earn my living elsewhere and know about the Internet more than I know about my car, my TV and hundreds of other things I use.

Who is Javaman? Extremely witty and smart person. Such a joke! Full of subtle humor. Pentagon-type. They call it barracks humor. Cool, man!

Incidentally, the Pentagon runs the defense of the people og this country, including you. Who are you, dog or cat?

---

<div class="post-metadata">

**Author:** ![douglips](https://avatars.discourse-cdn.com/v4/letter/d/e68b1a/32.png) [@douglips](https://boards.straightdope.com/u/douglips)\
**Post date:** [November 29, 2000, 4:12am UTC](https://boards.straightdope.com/t/what-is-the-oldest-website-on-the-internet/43074/24 "2000-11-29T04:12:52Z")

</div>

> [@](#):
>
> \*Originally posted by Shiva \*  
> **HTTP, HTML and the prefix WWW in URLs (all part of what defines the Web and a Web page) are inventions circa 1990 by Tim Berners Lee and Robert Cailliau .**

I disagree that ‘www’ has anything to do with defining the web. I’m quite happy to go to [http://boards.straightdope.com](http://boards.straightdope.com) - I don’t know if TBL invented [http://www.foo.bar](http://www.foo.bar), but it is apparent that the first server was not named www but ‘info’.

---

<div class="post-metadata">

**Author:** ![OpalCat](https://avatars.discourse-cdn.com/v4/letter/o/8edcca/32.png) [@OpalCat](https://boards.straightdope.com/u/OpalCat)\
**Post date:** [November 29, 2000, 4:22am UTC](https://boards.straightdope.com/t/what-is-the-oldest-website-on-the-internet/43074/25 "2000-11-29T04:22:34Z")

</div>

Well my site has only been around since 1995. Find the Spam was around way before that though. It isn’t the oldest, but it’s old. I’d like to nominate it as a sort of honorary oldest, because I love it so much 🙂

---

<div class="post-metadata">

**Author:** ![Shiva](https://avatars.discourse-cdn.com/v4/letter/s/85e7bf/32.png) [@Shiva](https://boards.straightdope.com/u/Shiva)\
**Post date:** [November 29, 2000, 2:29pm UTC](https://boards.straightdope.com/t/what-is-the-oldest-website-on-the-internet/43074/26 "2000-11-29T14:29:25Z")

</div>

> [@](#):
>
> \*Originally posted by douglips \*  
> \*\* it is apparent that the first server was not named www but ‘info’. \*\*

If I’m not mistaken, ‘info’ would indicate a Telnet address, not a World Wide Web address.

**Where are al the geeks?** C’mon, help us out here!

**peace,** what are you smoking and where can I get some? My “little knowledge” comment was directed at _me_.

---

<div class="post-metadata">

**Author:** ![Astroboy14](https://avatars.discourse-cdn.com/v4/letter/a/df705f/32.png) [@Astroboy14](https://boards.straightdope.com/u/Astroboy14)\
**Post date:** [November 29, 2000, 2:40pm UTC](https://boards.straightdope.com/t/what-is-the-oldest-website-on-the-internet/43074/27 "2000-11-29T14:40:54Z")

</div>

Kids… I’m _NOT_ a techie… but my roommate and I were accessing the internet WAY back in 1985 via a _slow_ modem, and a Commodore 64 computer!

No web sites then, obviously, but there **were** BBS’s and msg boards…

[sub]It was cool at the time![/sub]

---

<div class="post-metadata">

**Author:** ![Enos\_Strate](https://avatars.discourse-cdn.com/v4/letter/e/aca169/32.png) [@Enos\_Strate](https://boards.straightdope.com/u/Enos_Strate)\
**Post date:** [November 29, 2000, 3:02pm UTC](https://boards.straightdope.com/t/what-is-the-oldest-website-on-the-internet/43074/28 "2000-11-29T15:02:29Z")

</div>

This is not really an answer to the OP, but the [Amazing Netscape Fishcam](http://home.netscape.com/fishcam/) claims to be the second oldest live camera site on the net (second to [The Trojan Room Coffee Machine](http://www.cl.cam.ac.uk/coffee/coffee.html) at Cambridge).

I am of the opinion that the first “website” should be considered to be the first file that used HTML and the hypertext transfer protocol to be sent over the internet. Using the criteria that the address has to contain the _www._ prefix doesn’t work for me. If I go to view a page at _[support.microsoft.com](http://support.microsoft.com)_ or _[home.netscape.com](http://home.netscape.com)_ I’m still viewing pages on the web via the internet, right?

---

<div class="post-metadata">

**Author:** ![peace](https://avatars.discourse-cdn.com/v4/letter/p/c68b51/32.png) [@peace](https://boards.straightdope.com/u/peace)\
**Post date:** [November 29, 2000, 3:05pm UTC](https://boards.straightdope.com/t/what-is-the-oldest-website-on-the-internet/43074/29 "2000-11-29T15:05:22Z")

</div>

Shiva, you self criticism was too subtle for stoned me: there was the salutation (“Peace,…”), and then three lines. But whatever…No hard feelings…Still friends… At least [http://www.friends](http://www.friends)…www=World Wide Web

---

<div class="post-metadata">

**Author:** ![Arjuna34](https://avatars.discourse-cdn.com/v4/letter/a/eb8c5e/32.png) [@Arjuna34](https://boards.straightdope.com/u/Arjuna34)\
**Post date:** [November 29, 2000, 3:15pm UTC](https://boards.straightdope.com/t/what-is-the-oldest-website-on-the-internet/43074/30 "2000-11-29T15:15:34Z")

</div>

> [@](#):
>
> \*Originally posted by Enos Strate \*  
> \*\*  
> I am of the opinion that the first “website” should be considered to be the first file that used HTML and the hypertext transfer protocol to be sent over the internet. Using the criteria that the address has to contain the _www._ prefix doesn’t work for me. If I go to view a page at _[support.microsoft.com](http://support.microsoft.com)_ or _[home.netscape.com](http://home.netscape.com)_ I’m still viewing pages on the web via the internet, right? \*\*

Yes, the presence of “www” in front of the name has no relationship to what kind of protocol is being used. It is common to use “mail” for mail servers, “www” for web servers, “ftp” for ftp servers (for example, [http://www.virginia.edu](http://www.virginia.edu), mail.virginia.edu, ftp.virginia.edu for the University of Virginia), but they can be named anything.  
Arjuna34

---

<div class="post-metadata">

**Author:** ![Dragwyr](https://sea3.discourse-cdn.com/straightdope/user_avatar/boards.straightdope.com/dragwyr/32/2855_2.png) [@Dragwyr](https://boards.straightdope.com/u/Dragwyr)\
**Post date:** [November 29, 2000, 3:26pm UTC](https://boards.straightdope.com/t/what-is-the-oldest-website-on-the-internet/43074/31 "2000-11-29T15:26:04Z")

</div>

> [@](#):
>
> \*Originally posted by sdimbert \*  
> \*\*I asked this question a while ago.
> 
> **Dragwyr** pointed me to [a site](http://www.w3.org/People/Berners-Lee/) that had the answer:"  
> \*\*

Not a very exciting answer, is it, **Uniball**?

The rest of the thread wanders, but it does get more interesting… \*\*  
[/QUOTE]

Thanks, sdimbert! I’m glad that some info I posted is still positively contributing to the good fight!

---

<div class="post-metadata">

**Author:** ![Amok](https://avatars.discourse-cdn.com/v4/letter/a/f17d59/32.png) [@Amok](https://boards.straightdope.com/u/Amok)\
**Post date:** [November 29, 2000, 4:39pm UTC](https://boards.straightdope.com/t/what-is-the-oldest-website-on-the-internet/43074/32 "2000-11-29T16:39:16Z")

</div>

> [@](#):
>
> If I’m not mistaken, ‘info’ would indicate a Telnet address, not a World Wide Web address.

It is just a convention that many (most?) webservers are named ‘www’. ‘info’ is as valid a name as anything else for a webserver. For that matter, you can name a webserver ‘mail’, ‘ftp’, or ‘gopher’, but that gets kind of confusing. A webserver is simply any machine with an active HTTP listening process on it (and persumably HTML documents to serve up once the requests come in, but that isn’t strictly necessary).

> [@](#):
>
> That said, its beyond my scope, but I would challenge someone to justify why http servers would be a necessity of an early website.

Because that’s what a webserver is, by definition. ‘web server’ and ‘http server’ are synonymous terms.

---

<div class="post-metadata">

**Author:** ![Omniscient](https://sea3.discourse-cdn.com/straightdope/user_avatar/boards.straightdope.com/omniscient/32/3290_2.png) [@Omniscient](https://boards.straightdope.com/u/Omniscient)\
**Post date:** [November 29, 2000, 5:05pm UTC](https://boards.straightdope.com/t/what-is-the-oldest-website-on-the-internet/43074/33 "2000-11-29T17:05:56Z")

</div>

Well, I’m satisfied that an **http server** , and ergo, an **http prefix** are the defining factors of a website, thanks.

As a side note, I find it suprising that DNS resolution, and obvioulsy DNS servers predate the web. I presume these somehow functioned with ftp servers, mail servers and telnet. I guess that makes sense, but I always rationalized that DNS was dependant on the TLDs which I feel confident in saying don’t predate the web. Anyone care to explain how domain name databases were organized pre-Network Solutions. Is there a such thing as pre-Network Solutions?

Kinda rare to see people differentiating between the internet and the web anymore.

---

<div class="post-metadata">

**Author:** ![Shiva](https://avatars.discourse-cdn.com/v4/letter/s/85e7bf/32.png) [@Shiva](https://boards.straightdope.com/u/Shiva)\
**Post date:** [November 29, 2000, 7:06pm UTC](https://boards.straightdope.com/t/what-is-the-oldest-website-on-the-internet/43074/34 "2000-11-29T19:06:32Z")

</div>

Ok, we’ve defined ‘website’ or ‘webpage’ as an Internet document that uses HTTP.

So what is the oldest website on the Internet? 😉

And **peace** , Peace. No hard feelings. This is an interesting thread and it’d be a shame to ruin it with flames.

---

<div class="post-metadata">

**Author:** ![Bobort](https://avatars.discourse-cdn.com/v4/letter/b/ac8455/32.png) [@Bobort](https://boards.straightdope.com/u/Bobort)\
**Post date:** [November 29, 2000, 7:29pm UTC](https://boards.straightdope.com/t/what-is-the-oldest-website-on-the-internet/43074/35 "2000-11-29T19:29:41Z")

</div>

> [@](#):
>
> \*Originally posted by Omniscient \*  
> \*\*As a side note, I find it suprising that DNS resolution, and obvioulsy DNS servers predate the web. I presume these somehow functioned with ftp servers, mail servers and telnet. I guess that makes sense, but I always rationalized that DNS was dependant on the TLDs which I feel confident in saying don’t predate the web. Anyone care to explain how domain name databases were organized pre-Network Solutions. Is there a such thing as pre-Network Solutions?
> 
> Kinda rare to see people differentiating between the internet and the web anymore. \*\*

Nope, the DNS system has been around since the early 80s. I believe the idea was first formally proposed in [RFC 819](http://www.ietf.org/rfc/rfc0819.txt) in 1982, and I think it was pretty much fully implemented by '85 or so.

Before that the internet was small enough that every system just had a hosts file with all internet hostnames and IP addresses. It was still centrally administered; you would just periodically grab the newest hosts file via ftp.

---

<div class="post-metadata">

**Author:** ![c\_goat](https://avatars.discourse-cdn.com/v4/letter/c/f4b2a3/32.png) [@c\_goat](https://boards.straightdope.com/u/c_goat)\
**Post date:** [November 29, 2000, 7:38pm UTC](https://boards.straightdope.com/t/what-is-the-oldest-website-on-the-internet/43074/36 "2000-11-29T19:38:03Z")

</div>

I thought [http://www.straightdope.com](http://www.straightdope.com) was the first. They’ve been fighting ignorance since 1973 and all…

---

<div class="post-metadata">

**Author:** ![Amok](https://avatars.discourse-cdn.com/v4/letter/a/f17d59/32.png) [@Amok](https://boards.straightdope.com/u/Amok)\
**Post date:** [November 29, 2000, 7:43pm UTC](https://boards.straightdope.com/t/what-is-the-oldest-website-on-the-internet/43074/37 "2000-11-29T19:43:25Z")

</div>

> [@](#):
>
> _Omniscient wrote:_  
> As a side note, I find it suprising that DNS resolution, and obvioulsy DNS servers predate the web. I presume these somehow functioned with ftp servers, mail servers and telnet. I guess that makes sense, but I always rationalized that DNS was dependant on the TLDs which I feel confident in saying don’t predate the web. Anyone care to explain how domain name databases were organized pre-Network Solutions. Is there a such thing as pre-Network Solutions?

Top Level Domains (TLDs) definetly predate the web.

The oldest outlines of the DNS system that I could find were [RFC 819 – Domain naming convention for Internet user applications](http://info.internet.isi.edu/in-notes/rfc/files/rfc819.txt), dated August 1, 1982, and [RFC 882 – Domain names: Concepts and facilities](http://info.internet.isi.edu/in-notes/rfc/files/rfc882.txt) and [RFC 883 – Domain names: Implementation specification](http://info.internet.isi.edu/in-notes/rfc/files/rfc883.txt), both dated November 1, 1983. I just scanned through these (they’ve all since been obseleted by RFC 1034, I believe), and they address the issue of TLDs in a general way, however they do not create the specific ones we now all know and love. I’m not sure were or when those were created ([RFC 1591 – Domain Name System Structure and Delegation](http://info.internet.isi.edu/in-notes/rfc/files/rfc1591.txt) lists them, and is dated March, 1994, well after the creation of the web, but it listed what was already used, for information purposes, rather than creating them), but they were definetly in use before CERN put up it’s first website.

This [site](http://www.isoc.org/guest/zakon/Internet/History/HIT.html), for instance, says the following happened in 1985:

> [@](#):
>
> [Symbolics.com](http://Symbolics.com) is assigned on 15 March to become the first registered domain. Other firsts: cmu.edu, purdue.edu, rice.edu, ucla.edu (April); [css.gov](http://css.gov) (June); [mitre.org](http://mitre.org), .uk (July)

As for what was done before Network Solutions (in its role as part of Internic), this also appears under 1985:

> [@](#):
>
> Information Sciences Institute (ISI) at USC is given responsibility for DNS root management by DCA, and SRI for DNS NIC registrations

DCA is the Defense Computing Agency, which was originally responsible for managing The Internet. SRI stands for Systems Research Institute; I’m not exactly sure what they did (other than handle nick registrations). Internic wasn’t created until 1993, by which time there was quite a few websites out there, I believe, since CERN’s site (info.cern.ch) went up in 1991.

---

<div class="post-metadata">

**Author:** ![Omniscient](https://sea3.discourse-cdn.com/straightdope/user_avatar/boards.straightdope.com/omniscient/32/3290_2.png) [@Omniscient](https://boards.straightdope.com/u/Omniscient)\
**Post date:** [November 29, 2000, 9:28pm UTC](https://boards.straightdope.com/t/what-is-the-oldest-website-on-the-internet/43074/38 "2000-11-29T21:28:43Z")

</div>

Well, you’d think living about 3 blocks from NCSA for 4 and half years I’d know all these things. Thanks for doing all the leg work there guys, interesting stuff. I wasn’t aware that this many aspects of the internet were developed in such a non-linear fashion.

One of these days I’ll know better than to assume, eh?

---

<div class="post-metadata">

**Author:** ![Shiva](https://avatars.discourse-cdn.com/v4/letter/s/85e7bf/32.png) [@Shiva](https://boards.straightdope.com/u/Shiva)\
**Post date:** [November 30, 2000, 2:41pm UTC](https://boards.straightdope.com/t/what-is-the-oldest-website-on-the-internet/43074/39 "2000-11-30T14:41:37Z")

</div>

I just recived an email from Pär Lannerö at [http://www.dejavu.org](http://www.dejavu.org) (NOT .com, ahem). He replied:

> [@](#):
>
> “Actually I think it was [http://info.cern.ch/](http://info.cern.ch/)”

So, yes, it did use Hypertext Transfer Protocol and no, it didn’t have _WWW_ in the URL.

[Previous page](https://boards.straightdope.com/t/what-is-the-oldest-website-on-the-internet/43074.md?page=1)
