# Where is 127.0.0.1

**URL:** <https://boards.straightdope.com/t/where-is-127-0-0-1/139758>\
**Category:** Factual Questions\
**Created:** [December 1, 2002, 8:59am UTC](https://boards.straightdope.com/t/where-is-127-0-0-1/139758 "2002-12-01T08:59:14Z")\
**Posts on this page:** 13\
**Page:** 1

<div class="post-metadata">

**Author:** ![Harmonix](https://avatars.discourse-cdn.com/v4/letter/h/3ec8ea/32.png) [@Harmonix](https://boards.straightdope.com/u/Harmonix)\
**Post date:** [December 1, 2002, 8:59am UTC](https://boards.straightdope.com/t/where-is-127-0-0-1/139758/1 "2002-12-01T08:59:14Z")

</div>

Ok, as I know it the first IP of a local network is 127.0.0.1  
so who has the ip of 127.0.0.1 on the ubernetwork of the internet?

---

<div class="post-metadata">

**Author:** ![Ell](https://avatars.discourse-cdn.com/v4/letter/e/e47774/32.png) [@Ell](https://boards.straightdope.com/u/Ell)\
**Post date:** [December 1, 2002, 9:14am UTC](https://boards.straightdope.com/t/where-is-127-0-0-1/139758/2 "2002-12-01T09:14:00Z")

</div>

You are looking at it right now.

Well technically no one on the internet has that IP address it is reserved locally.

---

<div class="post-metadata">

**Author:** ![Harmonix](https://avatars.discourse-cdn.com/v4/letter/h/3ec8ea/32.png) [@Harmonix](https://boards.straightdope.com/u/Harmonix)\
**Post date:** [December 1, 2002, 9:17am UTC](https://boards.straightdope.com/t/where-is-127-0-0-1/139758/3 "2002-12-01T09:17:23Z")

</div>

ah ok. so who has the first ip on the internet? (i’m assuming it’s 12 **8**.0.0.1

---

<div class="post-metadata">

**Author:** ![Darth\_Nader](https://avatars.discourse-cdn.com/v4/letter/d/ad7895/32.png) [@Darth\_Nader](https://boards.straightdope.com/u/Darth_Nader)\
**Post date:** [December 1, 2002, 9:18am UTC](https://boards.straightdope.com/t/where-is-127-0-0-1/139758/4 "2002-12-01T09:18:37Z")

</div>

Huh?

127.0.0.1 is you. That’s just you, at home. Offline, even. That ip dosen’t point back at you, relax…

Except on the “ubernetwork of the internet”

Hax0rz 0wn j00 there…

---

<div class="post-metadata">

**Author:** ![IGJoe](https://sea3.discourse-cdn.com/straightdope/user_avatar/boards.straightdope.com/igjoe/32/5420_2.png) [@IGJoe](https://boards.straightdope.com/u/IGJoe)\
**Post date:** [December 1, 2002, 9:28am UTC](https://boards.straightdope.com/t/where-is-127-0-0-1/139758/5 "2002-12-01T09:28:29Z")

</div>

Not sure about the _first_ IP, but this is the _last_ one:  
[http://208.55.253.99/](http://208.55.253.99/)

😛

---

<div class="post-metadata">

**Author:** ![Harmonix](https://avatars.discourse-cdn.com/v4/letter/h/3ec8ea/32.png) [@Harmonix](https://boards.straightdope.com/u/Harmonix)\
**Post date:** [December 1, 2002, 10:07am UTC](https://boards.straightdope.com/t/where-is-127-0-0-1/139758/6 "2002-12-01T10:07:55Z")

</div>

I refute thats the end of the internet in that it implies the SDMB isn’t productive. Blasphemy!

---

<div class="post-metadata">

**Author:** ![Urban\_Ranger](https://avatars.discourse-cdn.com/v4/letter/u/e9c0ed/32.png) [@Urban\_Ranger](https://boards.straightdope.com/u/Urban_Ranger)\
**Post date:** [December 1, 2002, 12:58pm UTC](https://boards.straightdope.com/t/where-is-127-0-0-1/139758/7 "2002-12-01T12:58:45Z")

</div>

> [@](#):
>
> \*Originally posted by Harmonix \*  
> ah ok. so who has the first ip on the internet? (i’m assuming it’s 12 **8**.0.0.1

I don’t know _who_ has the first IP on the Net, but I know what it is: 0.0.0.0

---

<div class="post-metadata">

**Author:** ![Urban\_Ranger](https://avatars.discourse-cdn.com/v4/letter/u/e9c0ed/32.png) [@Urban\_Ranger](https://boards.straightdope.com/u/Urban_Ranger)\
**Post date:** [December 1, 2002, 1:03pm UTC](https://boards.straightdope.com/t/where-is-127-0-0-1/139758/8 "2002-12-01T13:03:04Z")

</div>

Ooops, goofed. 0.0.0.0/8 is called Network 0 and is reserved for the default route.

---

<div class="post-metadata">

**Author:** ![engineer\_comp\_geek](https://sea3.discourse-cdn.com/straightdope/user_avatar/boards.straightdope.com/engineer_comp_geek/32/504_2.png) [@engineer\_comp\_geek](https://boards.straightdope.com/u/engineer_comp_geek)\
**Post date:** [December 1, 2002, 10:51pm UTC](https://boards.straightdope.com/t/where-is-127-0-0-1/139758/9 "2002-12-01T22:51:02Z")

</div>

There are different classes of IP addresses.

Class A: 0.1.0.0 to 126.0.0.0  
Class B: 128.0.0.0 to 191.255.0.0  
Class C: 192.0.1.0 to 233.255.255.0  
Class D: 224.0.0.0 to 239.255.255.255  
Class E: 240.0.0.0 to 247.255.255.255

For example, this computer I am on right now has an IP of 192.168.0.5 but because it’s a class C there are probably hundreds if not thousands of computers with the same address.

I started poking around doing a whois search at [http://www.arin.net/whois/](http://www.arin.net/whois/) and 0.1.0.0 and the next several addresses are all reserved. 11.0.0.0 was the first one I could get a response for.

OrgName: DoD Network Information Center  
OrgID: DNIC

NetRange: 11.0.0.0 - 11.255.255.255  
CIDR: 11.0.0.0/8  
NetName: DODIIS  
NetHandle: NET-11-0-0-0-1  
Parent:  
NetType: Direct Allocation  
Comment: DoD Intel Information Systems  
Defense Intelligence Agency  
Washington, DC 20301 US  
RegDate: 1984-01-19  
Updated: 1998-09-26

---

<div class="post-metadata">

**Author:** ![Etherman](https://avatars.discourse-cdn.com/v4/letter/e/958977/32.png) [@Etherman](https://boards.straightdope.com/u/Etherman)\
**Post date:** [December 1, 2002, 11:54pm UTC](https://boards.straightdope.com/t/where-is-127-0-0-1/139758/10 "2002-12-01T23:54:17Z")

</div>

Actually the old class A class B etc. is depreciated in favor of netmasks, i/e /8, /16, /24, etc. It gives better precision, and allows address blocks as small as 4 addresses. The lowest I could find in the IANA lists [here](http://www.iana.org/assignments/ipv4-address-space) is, oddly enough, General Electric at 3.0.0.0/8.  
And all addresses must be unique. The class A class B etc was originally how those address blocks were assigned. When they thought they would never run out of addresses they would hand out class A blocks no problem. Now you can’t get a /28 without a letter from the pope, but I digress.

According to the [IETF’s RFC](http://www.ietf.org/internet-drafts/draft-manning-dsua-08.txt)

> [@](#):
>
> The current list of special use prefixes:
> 
> ```
> 0.0.0.0/8       
> 127.0.0.0/8
> 192.0.2.0/24
> 10.0.0.0/8
> 172.16.0.0/12
> 192.168.0.0/16
> 169.254.0.0/16
> 192.175.48.0/24: RFC-1918 nameservers.
> 192.42.172.0/24: NeXT-Default:
> 192.18.0.0/15 RFC 2455 (NOT IANA, but Harvard, for BMWG)
> 192.88.99.0/24 RFC 3068
> all D/E space
> 
> ```

The reference to all D/E space would seem to show I am wrong about those being depreciated, I will look further. But the 2 documents I linked pretty much define addressing on the Internet.

---

<div class="post-metadata">

**Author:** ![Berkut](https://avatars.discourse-cdn.com/v4/letter/b/a88e57/32.png) [@Berkut](https://boards.straightdope.com/u/Berkut)\
**Post date:** [December 2, 2002, 3:17am UTC](https://boards.straightdope.com/t/where-is-127-0-0-1/139758/11 "2002-12-02T03:17:06Z")

</div>

> [@](#):
>
> \*Originally posted by engineer\_comp\_geek \*  
> \*\*For example, this computer I am on right now has an IP of 192.168.0.5 but because it’s a class C there are probably hundreds if not thousands of computers with the same address.  
> \*\*

That’s my IP address too. 🙂

---

<div class="post-metadata">

**Author:** ![ElwoodCuse](https://avatars.discourse-cdn.com/v4/letter/e/edb3f5/32.png) [@ElwoodCuse](https://boards.straightdope.com/u/ElwoodCuse)\
**Post date:** [December 2, 2002, 5:30am UTC](https://boards.straightdope.com/t/where-is-127-0-0-1/139758/12 "2002-12-02T05:30:38Z")

</div>

> [@](#):
>
> _Originally posted by Harmonix \*  
> **ah ok. so who has the first ip on the internet? (i’m assuming it’s 12**8_\*.0.0.1 \*\*

Al Gore.

Duh.

d&r

---

<div class="post-metadata">

**Author:** ![KellyM](https://avatars.discourse-cdn.com/v4/letter/k/57b2e6/32.png) [@KellyM](https://boards.straightdope.com/u/KellyM)\
**Post date:** [December 2, 2002, 6:14am UTC](https://boards.straightdope.com/t/where-is-127-0-0-1/139758/13 "2002-12-02T06:14:41Z")

</div>

A few points: The “first” assigned network was in fact 1.0.0.0/8, which (at least in November of 1977) was assigned to Bolt, Beranek and Newman (the “real” inventors of the Internet) according to [RFC 739](http://www.ietf.org/rfc/rfc739.txt). (This is the earliest version of the assigned numbers document that I can find that lists network numbers. If anyone can find an earlier one, please let me know.) This assignment, as well as virtually all the other ones in that document, has since been revoked.

The smallest IP number I’ve seen in use (or at least in my firewall logs) so far is 4.0.3.129. I have logged unauthorized accesses on my firewall from 1.1.1.200 and 1.2.3.4 but those are almost certainly forged IPs as 1.0.0.0/8 is listed as “reserved to IANA” (as is 2.0.0.0/8).

D and E space are not deprecated. D space is the “multicast” space that fills 224.x.x.x through 239.x.x.x (224/4). This address space is specifically reserved for multicast operations and is used heavily, just not over the Internet. E space is the “experimental/reserved” space that fills 240.x.x.x through 255.x.x.x (240/4). This address space has no specified use.
