A new attempt at Linux...fingers crossed.....

So I tried a few months ago, with Suse, and got fed up…
I’m trying again with Mandrake. I’ve a couple of spare 10GB partitions, FAT32, and the Mandrake 10 ISOs on download.

(I’m expecting issues with my ADSL modem, that’s what made me give up before. Alcatlel Speedtouch 330, yes I know the various sites offering simple packages, but they all screwed up. Everything else, i expect to work, because Suse picked it all up, including my odd MIDI convertor)
Anyway…any recommendations of where to get advice on Mandrake in particular, or general Linux newbie support (preety please) will be welcome

Seriously, I always google until I get the answer, so I can’t help you with that one helpful site. But, great news for you. It seems installing the packages and firmware have gotten much easier for the Alcatel Speedtouch.

Good luck. Good choice with Mandrake.

Thanks for the link!

Well, there’s good news and bad news…

Everything went fine to start with, all the default setups seemed fine, booted OK, identified my printer perfectly (something I’d been dreading), even picked up the Alcatel modem! Of course, the distro doesn’t include the firmware which is under a different licence, so I needed to boot back into windows and download it…

Ahhhhhhh…Windows won’t boot. And the Recovery console can’t recover it (it got confused by the presence of ‘non-standard’ partitionins). So I’ve just spent 7 hours doing a clean install of XP.


      • Helpful Hint: get an older, slower PC for as cheap as you can and install the Linux on that.

Where did you put the boot loader? I’ve had no problems putting it in the MBR, but sometimes I’ve been unable to boot windows after putting it elsewhere. Made the wife all kinds of annoyed.

But the whole point is having something that’ll exploit the capabilities of this box better than Windows does.

I assumed that Mandrake put it in the MBR - there definately didn’t seem to be any options available.

Er, unless you’re loading from a boot disk, the only real practical place you can put a bootloader is in the MBR. 'Cos, you see, that’s where the PC looks when it goes through the boot chain after POST. You could put a bootloader elsewhere, but it’d just sit there.

GRRRRRRRRR…I’ve had the first response from a Mandrake mailing list about my problem - and it’s the usual “just delete and forget about windows” smug comment. And that’s not an option - I need to use Windows programs, that DO NOT work in Wine.

Mini-rant over :slight_smile:

Which ones in particular? Maybe there’s an equivalent. Or else it’ll run with WineX or CrossOver.

Finale - a music notation program. There’s nothing in Linux that comes close to it, and it’s heavily dependent on TrueType fonts and non-standard mouse actions. The mailing list for it is full of people giving up attempting to use it under an emulator.

I recently installed Red Hat/Fedora Linux in dual boot with XP. During the installation process there was a moment where you were asked whether you wanted to overwrite the MBR, at which point you should answer ‘no’. If Mandrake did overwrite it without asking, that seems bad form.

There are several websites around that explain how to do dual-boot with various Linux distros. Just google for Linux dual-boot XP Mandrake.

Omigod, I’m sounding like handy!

Also, what kind of modem do you have: USB or Ethernet? I have the latter, and Fedora worked fine with it.

I’m fairly sure that there’s an issue with the Mandrake 10 installer - I tried again, choosing to put the boot loader on a floppy instead, and my MBR still got corrupted. :frowning:

When I installed Mandrake 9.2, it didn’t give me option to make a boot disk, only installing GRUB or LILO in my MBR. I was wary, but I allowed it to installed LILO, and it worked out OK.

I’m glad to see in 10 they give the option of a boot disk, although it sounds like it needs work.

Mandrake 10 is still in kind of a beta mode, isn’t it? Maybe you should use 9.2, if you have no particular compelling reason to use 10.

Problem solved - it’s a fault with the Mandrake 10 partitioner, which damages the Windows-created FAT. I found a post elsewhere from another newbie, who worked-around by booting from a different distro, creating the partitions from there, then starting the Mandrake one.