A problem with Icewind Dale- for P.C.

Not sure if this goes in G.Q. or here, so if it belongs over in G.Q., some kindly Mod will move it for me, yes? :slight_smile:

The wife loves Icewind Dale on her Windows XP machine. She used to run it. The son also ran it, and damaged the CD-ROM beyond readability. Beyond even re-polishing. So, she found a new set online. It came today. Because the last attempted install was corrupted as the machine tried reading across the scratches, something odd has happened.

She cannot Uninstall the last corrupted attempted install. I went in, did a file delete and removed as much as I could of the software packages. ( Icewind Dale I and II, and Baldur’s Gate ). She was fine with this wholesale wiping out of the games, by the by. I asked first.

Despite my attempts, the effort to install Icewind Dale I fails. The install guide says that it is a corrupted install and cannot continue. When we go to Add/Remove Programs and Remove Icewind Dale, it tells me that the Uninstall file is missing, and so the software cannot be Uninstalled.

( as a personal note, this is why I detest PC’s and Win Xp and adore my Mac. )

Any ideas on how to more thoroughly scrub out the remnants of the old corrupted Icewind Dale install, so that I can try to perform a clean new install ?


You might try opening up the registry and ripping everything out that is associated with Icewind Dale. Go to Start, Run… and at the prompt, type “regedit” (no quotes) and hit Enter. Your job would be to search for anything that is associated with Icewind Dale and its associated bits in the registry. I don’t remember who made Icewind Dale I (Black Isle?). Do Ctrl-F in the registry, search for icewind and at each hit, delete the folder in the left panel in which icewind appears. Then do F3 to keep searching until everything with icewind in it is gone from the registry. You might want to search and delete things with black isle too. When everything with icewind is gone from the registry, close the registry window, reboot, and see if you can install.

The problem is that deleting files isn’t usually enough to wipe a program from windows. The registry holds vital information about the programs. A reinstall over an improperly-done uninstall isn’t the same as a clean install in my experience because of registry remnants.

Hope this helps. Good luck, hope you get it working.

Agree with bleach with one caveat: ALWAYS back up your registry before playing with it.

Another, easier, way that might work: If System Restore is activated, try to restore your system back to a time before the program was corrupted. Check All Programs -> Accessories -> System Tools -> System Restore.

(P.S. - probably too late now, but I might have tried to archive the same games to disk before wiping out everything)

Hi, I’ve just seen both suggestions and will go to wife’s machine right now and try them out. I thank you so much, and will post back when I either come out of this smelling like a rose, or a week-old piece of halibut. :smiley:

While the above posts are good last ditch advice it’s often good to look through a CD for Setup files you can sometimes repair a bad uninstall that way. So I checked the FAQ at interplay and there is something you can try before you begin messing with the registry (or after if you couldn’t get it to work).

Just to expand a little I’ve had a few corrupted installs or bad uninstalls and I quickly learned to go into the CD (my preferred way is to right click on the CD drive and click ‘explore’ then bother with the run screen) and look around for a Setup.exe or install.exe file. You can often brute force a new install or uninstall by bypassing the normal autorun splash screen.

Very true, Darkhold. Those ideas didn’t pan out- but apparently tweaking the Registry with GREAT CARE did work out.

Wife was able to successfully re-install Icewind Dale onto her PC. My thanks to you all for some great suggestions. While it’s true I’ve solved the problem, there may be other great tweaks suggested by other Dopers. Mods, either close or leave open as you wish. I’ve solved my problem quite handily !!