All of a sudden, my PC freezes when I click on a link. Why?

Okay, here’s the deal. Last night, I’m in a chatroom when someone posts a link to a page. I click on it and the new window comes up and I try to go from there. But nothing happens. I can’t even click to get rid of it. It just stays there. Same thing happens with links in e-mails and pop up ads. What’s going on here?

Someone suggested defragging, which I’ve never done before, but things didn’t improve. I also downloaded Norton to see if I had any viruses but none were present.

The only new thing I’ve added recently was a webcam and I downloaded Yahoo Messenger but the problem didn’t manifest itself immediately. Any suggestions as to what I can do? Thanks


You can try this if you are using Internet Explorer (you didn’t say what browser/OS you have…):

After making sure the Default browser is Internet explorer try the following:

  1. Right click Start Button

  2. Click Explore to open Windows Explorer

  3. Click View from the Menubar of Windows Explorer window

  4. Click Folder Options…

  5. In the Folder Options dialog box click on File Types tab

  6. Under Registred file types: in the box, scroll through the list and click to select URL:Hypertext Transfer Protocol

7.Click Edit… button to open Edit File Type dialog box

  1. UnderActions:find a box and click Open from there

9.Click the Edit button below the Open box.

  1. Application used to perform action: box must contain the value that reads:


(Check the path to iexplore.exe to make sure that is correct)

[This can be done by using the Find -File method (Start>Find >Files or Folders> type iexplore.exe in Named: box;direct Look In to C: drive and click Find Now and verify that iexplore.exe is in C:\Program Files\Internet Explorer Folders.)
USE DDE box should be checked and in the boxes below it you should have:
DDE Message




DDE application not running




The best thing is to copy and paste the above items in blue in the appropriate areas

Sorry, I have Windows ME. I’ll try what you typed a bit later. Thanks. Boscibo!

Boscibo, I used that second method (Find File) that you wrote and I did find it in the program files/internet explorer folder. What was all that about the USE DDE box? I didn’t see anything like that. If I click on the entry after the search, I just get the home screen for, which is my default home addy. Can you help?

Also, I didn’t see anything like -nohome that you had typed for me to look for either.

OK, 1st of all your operating system is Windows ME, your browser version is ?? (If you aren’t sure, open your browser, click on ‘help’ in the menu bar, then click on ‘about Internet Explorer’ that will tell you the version number, I think this method works with 5.0 up to 6, I am not sure about lower versions). That is why it is important to know what version browser you are using, if you have an earlier version this method might not work.

2nd, you must follow all the steps completely. The ‘find files’ instructions are only for making sure the path to IE is correct - it won’t fix your problem. Start at the beginning of the instructions and follow all the steps, you need to make sure the browser is getting the correct instructions to open URLs.

This mix up can happen if anyone else using your comp. uses a different browser and made it the default - IE won’t open links correctly if it isn’t the default browser.

Good luck, I have done this procedure before and it isn’t as complicated as it sounds.

Boscibo, I am running WIN98SE and it is configured as you said by default but I am curious to know what each thing does and means.

Sailor, I got that info from someone after my sister was having problems with her PC freezing up after clicking on links sent in emails. I think it came from the Microsoft Knowledge Data Base originally. I have no clue whatsoever what it means.
It worked on her PC - those values were different, after I cahnged them back to the stuff in blue she could click on links in emails again.

Boscibo, I got as far as #3 but didn’t seen “Folder Options.” I did see just “Options” but no File Types Tab, just two things: something like CABS and INSTALL. Am I in the right place or not? Also I have IE v.6.0. Thanks again!

Boscibo: okay, I finally found folder options under the control panel and went from there…

Everything was what you said it should be EXCEPT for #10. That one was as follows:

C:\PROGRA~1\INTERN~1\iexplore.exe" -nohome

Should I change it to what you have? This is the only difference. Thanks…

The C:\PROGRA~1\INTERN~1 part of C:\PROGRA~1\INTERN~1\iexplore.exe" -nohome is just Windows’ way of shortening the file name so it’s easier to read. What you have is the same as what Boscibo wrote, just in shorthand form.

In other words

Ohhh okay, Abel. Thank you and to Boscibo for your help. :slight_smile:

I use both Netscape & IE on the same machines, so when one doesn’t cooperate, the other
often does. Sometimes I get some weird java thing that also I can’t close, so I just avoid those
areas of the web. Some web pages use java things that require a newer java handler.