Another Windows Media Question

In this thread, I asked how to remove some *.wmv files from the list in the Windows Media Player. I used this method, posted by deathawk:

Open the registry with Regedt32 (NT/2K/XP) or Regedit (Win95/98/ME).
Go to HKCU. It is important to go to CURRENT USER and not LOCAL MACHINE. WMP has settings in both. The setting you are after is in HKCU.
HKCU->Software->MediaPlayer->Player->RecentFileList. The files are listed as strings. Delete the strings.

This worked fine. Now, however, I want to delete some *.asf files, and they aren’t showing up in the directory mentioned above. What can I do?

Never mind.

But, this is strange. When I first brough up regedit, the files weren’t there. I tried refresh. No dice. I tried a little later, and they were there. Anybody know what gives?