Anyone else having problems with SDMB search function?

Yesterday and today, I’ve tried to search old threads using two keywords. Each time I get an all-white screen, with this in my browser bar:

http://boards.straightdope.com/sdmb/search.php?do=process

If I try to do another search immediately, it asks me to wait the usual time, but when I do wait, I get the same result.

Any thoughts? Thanks.

Works fine for me. That url leads to the advanced search page.

When I say works fine, I mean works the same as it always did, which may, or may not be fine. :wink:

It’s working for me.

Try clearing your browser cache.

I used the search function with then usual results in the last hour or so.

While we are on the subject is there a business reason for the 120 second wait imposed for conducting a new search?

Always, yes. You should use Google to search the board. See the sticky thread in this very forum.

Here’s a link if that’s easier:

Still no luck. Thanks anyway.

What are your search terms?

Do you have any other browsers handy? It certainly sounds like a cookie issue. Trying the search in another browser is one way to rule that in/out.

Mine’s working okay.

I don’t think the Search function has ever worked for me. Maybe once or twice years ago. But I’m like 1 or 2 for about 50.