Apple MacPro USB issues question

I tried my question over at the Apple boards, and have gotten no response, so I’ll give the Dopers I shot–I know we have a few apple experts here.

First, about my Mac:

OS X 10.6.8
2x2.66 GHz Dual-Core Intel Xeon
4 internal hard drives, ranging from 1-2 TB each

Lately, my Mac’s USB connections have been wonky. I’ve tried the front, the back, using powered hubs, using no hubs, and this is generally what happens: Whenever I try to upload data to an external harddrive or stick, I seem to lose all USB devices except the hard drive itself. (And, sometimes, the stick gives me a problem and refuses to complete the transfer, unless I unplug all USB devices immediately after initiating the transfer.) I’ve tried what in theory should be a powered hub for my other USB devices, but that doesn’t seem to have any effect on the problem. I tried resetting the PRAM, to no avail.

So far as I can tell, the problem does not occur when I pull files FROM a USB device. Nothing goes haywire if I’m transferring from an external to an internal, only vice versa. When I lose my USB devices, I can remount them by unplugging and replugging the hub (or individual USB connection) in, but (once again, so far as I can tell) only when the data transfer to the external USB drive is complete. If my computer goes to sleep before the data transfer is complete, I usually have to wake it up from a screen sharing connection on my laptop, and then I can unplug and replug to get everything working again.

I apologize that my symptoms are peppered with a lot of "usually"s and “seems.” The only thing that I can tell is consistent is the connection going when I upload to an external USB drive. And it doesn’t go immediately. It takes about a minute or so before I lose the connectivity of other USB devices (keyboard, mouse, graphics pad.)

The severity of the problem is recent (within the last three months.) Before, I would occasionally get an external drive going offline and remounting, but I assumed that was just a flaky connection. The problems occur no matter whether I use the front or the rear ports.

I should also add that running Apple Hardware test through two cycles didn’t yield any errors.

Do a clean install on one of your hard drives. Try booting from that System and see if the problem goes away. If it does, it’s a software problem - if not, you may have a bad MoBo or bad RAM. Also, it might be helpful to see if any errors are being logged in the Console.

Yeah, the logic board is what I’m worried about. I’ll buy a new hard drive and install a fresh version of the OS on that and see what happens. I also suspected bad ram, as I occasionally have programs crap out on me with seg faults and things like that (bad access, kern protection failure, something like that), but running multiple passes of memtest from single-user mode hasn’t yielded any problems.

I’ll have a look at what I have logged in console.

Ah…this is something I’ve never seen before. One of my console messages is “WARNING: corrected 11 parity error(s) in DIMM Riser A/DIMM2.” So that’s a RAM issue, I take it? Not necessarily that this has to do with my USB woes, but this could explain the odd crashes.

Oh, and this is odd. Now I have two RAM sticks reporting ECC Errors. I’ve checked them before when I was having USB and crashing issues, and they’ve always been clean. This is a very new development, so I’m not sure it has to do anything with the problems I’ve been having for the last few months.

Try each stick by itself, or ideally a stick you know to be good.

OK, I have concrete error messages that relate to the issue at hand. I just initiated a transfer of 100+ GB of data over to my external drive. As expected, in about a minute or minute and a half, the USB devices crapped out on me, except the drive. This is what I see from the console (I’m typing this from another computer, and I left the console up and running just to see if it would give me any clues):

USBF: 763270.177 AppleUSBEHCI[0exfab000]:: Found a transaction which hasn’t moved in 5 seconds on bus 0xfd, timing out!

USBF: (A bunch of ID numbers here) The IOUSBFamily is having trouble enumerating a
USB device that has been plugged in. It will keep retrying (Port 2 of Hub at )xfd3400000)

USBF: (same message as the first)

Apple Extended USB Keyboard::terminate(kIOServiceSynchronous) timeout
USB Optical Mouse::terminate(kIOServiceSynchronous) timeout

Then there’s a bunch of (I assume unrelated) mDNSResponder errors of the type “ERROR: mDNSPLatoformReadTCP-SSLReadL:-9806” and “ERROR: tcpCallback - attempt to read message length failed (-1)”. There’s four of these pairs, interspersed with one “mDNSSendDNSMEssage: write msg body failed -1/348” error in there.

Not sure what the DNS stuff is all about.

Oh, and it seems my file transfer has frozen, too. This is new.

Given that you are seeing many USB devices time out it looks like the driver has died in some way. This coupled with the RAM errors suggests that possibly there is a bad section of RAM, and that this is located somewhere that the USB device driver uses.

No matter what, you have one known problem - the RAM. There is little to no value in spending time trying to diagnose another problem until this one is addressed.

OK, I’ll try pulling all the RAM save one and see if the USB problems persist.

As I suspected, it’s not making a lick of difference. I tried 3 different RAM chips in the computer, and the USB failure continues exactly as before. The USB failures long predate any sort of RAM issues I’ve seen. I’ll run a memtest on all the RAM and see what it comes up with at any rate, but it doesn’t seem to be tied in with the USB issues, so far as I can tell.

I ran memtest on all the memory overnight, all tests, 3 times, no RAM errors and it gave the memory a clean bill of health. So shrug.

Rolling back to Tiger on a new hard drive seems to have helped a little. Jury’s still out though. A transfer to the external hard drive went without incident to the Wacom tablet, keyboard, or USB mouse connection, but my other hard drive (an unpowered WD Passport hard drive) disconnected during the process and I did get an error that said “Device unexpectedly disconnected” (or whatever it is exactly) and then it immediately remounted. Hmm…

Spoke too soon. Lost USB connectivity. Ugh.