ARK players: what am I doing wrong?

I’m trying to log in to ARK from Steam. I’ve installed the base game and the extension, and they both show up in Steam. I click on one of them, get to the big A. I click JOIN on the left and get a big long list of servers. I choose one at random. It takes me to a screen that has multiple windows, such as my achievements (0 so far), communities to join, buy this new thing, etc. And that’s it.

No “game loading” progress bar, no error messages, no indication that I’ve done something wrong. It just sits there. There’s a tiny link for “Go back to games,” and it takes me back to the big A. Join, choose a different server, get the same limbo.

I haven’t tried joining as Solo yet, which I should probably do to learn the game basics at least.

Any ideas?

Steam has been weird the last day. I tried to open FM 17 and Stellaris in offline mode and the game told me there was no license. Wtf? Go back online and the games open fine. I think Steam has been hacked.