Bizarre problem with Word crashing on one computer

On my laptop, a small number of Word files cause Word to crash (Windows gives the message “Microsoft Word has stopped working” and gives the option to close the program, and look for solution). There seems to be no discernable pattern as to the characteristics of the files that cause it. Once such a file is identified it always causes the crash. It does not crash on anyone else’s computer no matter what version of Word they are using. This leads me to believe it is not a file corruption, but there could be a subtle corruption that doesn’t show up in other configurations.

Occassionally if I open the same file on my desktop computer and make a minor edit and save it, then it will work on my laptop, but not always.

The crash occurs after the file is opened. The file content is shown, and the message in the status bar shows the number of characters in the file. As soon as the file is fully loaded, and the status bar displays the number of pages, that is the moment when the crash occurs.

I am using Word 2010 but the same thing happened in 2007. I was hoping that the upgrade would clear it up but apparently not.

The uniqueness of this problem on my computer makes me think there could even be some hardware anomaly.

This is very difficult to search for, as searches tend to lead to solutions for corrupted files. These solutions (e.g., Open and Repair) do not work.

Sounds like a font issue to me.

Do you mean that I may have a corrupted font on the machine?


Something else to try, open the file on another machine, copy and paste the entire content into a new file with a new name. See if it still does the same thing.

I’ve experienced this problem. It can be due to a file corruption at the end of a section, and occurs most often with very large files.

Do this. Open the file if possible; save it as a single file web page. If you have any small caps, double underlining, or double strike-through in the document, you’ll lose them, but you can restore those afterwards). Close Word, start it again, and then reopen the single file web page version of the file. If the problem is with the file specifically and not the Word installation or font installation, that’ll clear it up.

Pursuing the font angle, I did some analysis using a VBA macro on the document and found that it has two characters with a null font name. It turns out these are the first characters of hyperlinks. It also has fonts that are used only by a handful of characters, including “Times Roman (W1)”. I tried reinstalling all TrueType and OpenType fonts copied from another computer that does not exhibit the problem but that did not resolve it.

drachillix, I have tried your suggestion already but it did not work. I clicked CTRL-a CTRL-c then pasted into a new document and got the same behavior. I also tried doing this without

I have also tried editing the document on one machine and breaking it up into multiple parts to try to isolate the problem, and it occurs in most but not all subsections.

Try doing the Crtl-A thing again, but this time instead of doing Ctrl-C go to the Paste Options and select Keep Text Only (T). It’ll destroy your formatting, but if it resolves the problem it will narrow things down for you (ie, it’ll point to a font/formatting issue).