Board weirdness with dollar signs

This is my entire post from another thread (topic). I included dollar signs and they showed up in the preview window but disappeared when I saved/posted. Anybody know why?

ThelmaLouMember 1h

When I was a kid, gold was 35/oz. Seriously. Of course, gasoline was .20/gal. Minimum wage was $1.10. Gold mining was especially dangerous because of the dinosaurs.

ETA: I put dollar signs in front of the “35” and the “.20” --why did the bot remove them?? The dollar signs SHOW UP in the preview window, but disappear when I save.

ETA #2 test: 35 per ounce, .20 per gallon

ETA #3: I put dollar signs in ETA #2 – I thought maybe the bot didn’t like the slash. But the dollar sign was okay in “$1.10” What’s up with that?

$35.00 $0.35

It appears to need a decimal point with something in front of it, like some kind of Excel rule.

$ 35.00

$cientology. Hope that works - can’t have a message board without that spelling.

35./oz .020/gal

Imgur of post window:

Note the presence of dollar sign in the part of the post window that shows.

Escaped with backslashes:

$35./oz $.020/gal

Here is a longer sentence that uses dollar signs: $35./oz and $0.20/gal

ETA: Well, this worked.


It’s a bug, it’s taking the dollar signs to be some weird formatting, I don’t know what.

You can work around it by putting backslashes \ in front of the dollar signs.


Okay. Interesting. But in my last post, the dollar signs came out okay… I’ll keep the backslash thing in mind… or maybe just write out “dollars and cents.” :yum:

Just for my own information, should I have known what you meant by
“Escaped with backslashes”? without asking for clarification?

Sorry, that was probably a bit too technical.

I think it worked in your later post because there was other text in front of it.

FWIW, it is covered in a recent ATMB thread. That’s why I knew what your problem was as soon as I saw it.

Thanks. I never would have found that.

Testing. $25 worth of testing. – looks OK in the preview window, but I’ve noticed previews here don’t look exactly like the posts.

Maybe the problem was the slash after it? $25/per dozen.

Huh. Maybe a slash and a space? $25/ per dozen.

I didn’t put any slashes in that aren’t visible.

Discourse is weird.

$25 / per dozen?



The MathJax plugin for Discourse allows you to insert mathematical formulas.

Inline formulas are marked with a $ at the beginning and the end.

My guess is that MathJax is disabled on the SDMB, but it’s still scanning for the pair of $ signs on a line. It’s removing the $ signs, but not processing what is between them as a formula.

(I had to escape the two $ signs on the line above, or they wouldn’t display.)

Testing again:

by itself. Text with in the middle.
Text with it at the end . at the beginning and again at the end $.
Shows as normal in the preview box; and no I’m not using any escape slashes.

aha! I was beginning to think that whatever it was doesn’t affect me at all, but there it is. I think others can figure out where the dollar sign originally was in the above.

But I note that I didn’t have it show up at all when I used it with a dollar amount in multiple different arrangements – see post above, all of those $25’s.

What about this?

© stay © even if I use \ before it: test1 \ © test2 © test3 \ © test4 \ ©

It works if you escape the second bracket.