Can anyone help with a full startup disk on an iMac?!

I got the ‘startup disk almost full’ message on my iMac, was in the process of freeing up space when it froze, I turned it off and tried to restart but it won’t let me back in!

I get the start up chime, then the apple logo and progress bar which either gets stuck half way or changes to a no entry symbol.

I’ve been using time machine to back up to an external hard drive but there are some photos I recently uploaded that are very special and may not have been backed up :confused:

I don’t have the original CDs that the Mac came with and my disk drive doesn’t like to work most of the time anyway.

I tried booting it in safe mode with no success.

I was reading an old thread where someone had a similar problem and they were talked through how to delete a program like QuickTime in single user mode… is that something that would work for me?


If you can boot into single-user mode, I would delete something like:

/Library/Application\ Support/GarageBand

(assuming you don’t use Garage Band)

It has like 1.4GB of stuff in it.

Single user mode gives you a unix command line only. It would be difficult to determine what can be safely deleted. If you are not familiar with the command line I wouldn’t recommend this.

The safest option is to boot from an external HD, CD or USB stick that contains Mac OS X. Then delete the files, or if that doesn’t work, re-install Mac OS X. You can either take it in to an Apple store or service provider or buy a bootable USB which has Yosemite pre-installed.

Mac OS X 10.10 is now free, so there are people selling USB sticks on ebay with Yosemite installed. Eg see here:

If you have access to another Mac, you can use “Target Disk Mode” to look at the imac hard drive, and delete useless files.

I don’t have access to another Mac.

I’ve never used garage band before so could definitely delete that if someone could tell me the steps?

I thought I edited and added the steps, but I guess not.

Boot holding the command (apple) and “s” keys down.

Once you get to the prompt, type:

mount -uw / [return]
cd /Library [return]
cd App [then hit the tab key, and it should fill in the rest - Application\ Support] [return]
rm -rf Gar [then hit the tab key, and it should fill in the rest - GarageBand] [return]
reboot [return]

Be exceedingly careful with the rm command - you can wipe your entire drive with the wrong parameters to it. That’s why I had you walk into the correct directory.

Ok I’m on a black screen with white text but it won’t let me type anything?

Now it’s giving me a bunch of error messages… I assume I’m screwed??

hfs_mountroot failed 6
Cannot mount root errno = 19



You need to find someone with a boot DVD or (even better) a USB with Disk Warrior on it. Sounds like you have serious directory damage.


So would that be what Coremelt linked to up thread or is that something different?

Sorry, not very tech savvy, just a sahm trying to salvage precious memories!

He was just pointing to sources for bootable OS X disks.

Do you live near an Apple Store? They will look at it for free.

I recommend this, but it’s not free. It’s saved my bacon several times.

The closest store is about an hour away.

I’m in Australia, does that matter with disk warrior?

I wouldn’t think so, although it might take a while to ship it to you…

I take it you’re not near a big city?
Do a Google search for “Macintosh user’s groups Australia” - there may be one nearby, or they may be able to point you to a member that lives close by. Often, there are “power users” who are as good (if not better) than Apple at fixing these types of problems.

If you brought your machine to me, I would do the following:

  1. Mount the drive in Target Mode, and make a clone of it.
  2. Try to repair the drive with DiskWarrior.
  3. If that failed, free up enough disk space on it to re-install OS X onto of what you have.

I’m about an hour north of Sydney. I’ll do some googling and see who I can find.

Thank you so much for your help, much appreciated :slight_smile:

I notice that you are a new poster here - what brought you to the Straight Dope for a Mac problem? (Not that it’s such a bad idea - it just wouldn’t be the first place I would think of to go for help).

Anyway, welcome, and let me know if I (or anyone else here) can be of assitance.

I did a google search and the top hit was a thread on here by someone with a similar problem so I thought I’d take my chances! You were much more helpful than the Apple forums too :slight_smile:

Try this after the single user start (not forgetting to release the Command and S keys as soon as the white text appears).

At the # prompt (give it lots of time for the text to quit flowing) type fsck -fy (include the space, and the - is a hyphen). Then hit Return.

This makes the computer repair the bad files before the GUI can kick in.

When the repairs are complete, the message at the bottom should say, with luck, that the drive was modified. Under that, it would say the drive appears to be OK.

But if it does say the drive was modified, run fsck -fy again, because some problems hide other ones until the first ones were fixed. When the message at the bottom simply says that the drive appears to be OK, type reboot (lower case), hit Return and cross your fingers.

fsck = files check. -fy = force yes. Without the -fy you’d have to hit y for yes with every file fix asking if you want to do it.