Can I run this old computer game?

A friend of mine just passed me a copy of a 1995 classic game ‘1830 - Railroads and Robber Barons’.
I played the game back in the day and thoroughly enjoyed it.

But the game was designed for:

  • PC 486 DX
  • 4MB RAM with 2700K EMS
  • 11MB
  • MS-DOS v5.0
  • VGA graphics card

Now time has passed (to put it mildly!)

So can I run this game on a modern computer?
Do I need a DOS emulator?

If it helps, I have computers running Windows XP, Vista, Linux and Windows 8.

Many old games that will not run direclty on XP or newer will run in an emulator. Google this specific game and you will find one of the sites that has support info for older games - you can usually find configuration info, runtime patches, emulators etc.

DOS 5 is pretty late and was compatible with Win 3.1, WinNT and Win2000, so XP might run it directly.

Is it a DOS or Windows game? If it’s DOS, I bet it will run fine in the “dosbox” emulator. I’m using dosbox on Linux and it works well.

Looks like it’ll run fine in Dosbox.

Another vote for Dosbox. A 1995 game should run just fine under DOS, and in that case there’s a good chance Dosbox will do the job.

Thanks for all your replies - I’ll give things a try!

OK, running it directly under Windows XP didn’t work.

I’ve installed Dosbox, opened a DOS window and have the game disc in the drive.
But how do I proceed now?

Look for a setting that will make the drive appear in the virtual machine.

In DOSBox at the z: prompt type the following:

mount y: (folder where 1830 is located)

cd y:

1830So if you installed the 1830 folder right on your c: drive as c:\1830 you’d type mount y: c:\1830.

OK, I have told DOSBox that 1830 is on my C: Drive.
Now what do I type?

(Sorry if I sound confused - I don’t know any DOS commands!)

I don’t know if making DOSBox think the install disk is your C: drive was the best option: Typically, the C: drive was the hard drive, and the game will probably expect to install onto your C: drive. Make a directory somewhere and tell DOSBox that the new directory is your C: drive. Tell DOSBox your CD-ROM drive is your E: drive (which was fairly common in that era, up through Windows 95 and a bit later).

Once you get that sorted out, type ‘E:’ at the DOSBox prompt (without the quotes) and then type ‘dir’ (also without the quotes). Read what the screen shows you, and look for files like ‘install.bat’ or ‘setup.bat’ or some filename on the theme of installing or setting-up or similar. If you get a lot of output that scrolls really fast, type ‘dir/p’ (that’s forwardslash p, space not required) and hit Enter to see it a screenful at a time. If you find a filename that looks promising, type it and press Enter.

If there’s a file called ‘autorun.inf’, you’re in business: Type ‘type autorun.inf’ (with the space, without quotes) and look for a line that says ‘open=something’. Type the something and you should be good. (Autorun is a Windows thing more than a DOS thing, but a number of programs were designed to run on both OSes.)

If you really can’t figure it out, come back and bother us again. This is what we’re good at. :slight_smile:

No, I’m sorry if I confused you; I’m not the best at communicating these things some times, I don’t know if I’ll confuse things by overexplaining or underexplaining. Where exactly is your 1830 folder located? To break it down (and hopefully not confuse you more) is the 1830 folder directly under your c:\ drive as C:\1830? I only meant it as an example, but it will work fine if that’s where you put it. Before posting before I downloaded the game myself, moved it to f:\games\1830 which is where I throw all my games and it booted fine for me.

In DOSBox the command mount y: (folderpath) is telling your computer that the drive it will now know as y: is the folder (folderpath).

cd y: is just telling it to change the directory of the command prompt to y:

1830 is telling it to run the file 1830.exe, which is the file that launches the game.

So in my case I downloaded it and extracted the zip file to f:\games

mount y: f:\games\1830 is telling DOSBox that the drive it will recognise as y: is the folder f:\games\1830

cd y: is just telling it to change the directory of the command prompt to y: so you’ll see y:\ instead of z:\

1830 is telling it to run the file 1830.exe, which will launch the game.

To change to drive y: do this:


cd xxxxxxxx means change to the subfolder xxxxxxxx within the current drive and path.

cd\xxxxxxxx means change to the folder xxxxxxxx within the root directory of the current drive.

BTW this is what cd y: would do:

It seems to show the current folder (C:\Documents and Settings\User) within the specified drive (C: )

Thanks for explaining in detail - much appreciated.

The computer downloaded from the drive to c:/1830 (i.e. by default)
Once I realised that I had to type into DOSBox:

mount y: c:/1830

y: (interestingly not cd y: on my computer)


I had liftoff. :cool:

OK, I’ve played a full game of 1830 with no problems.

Thanks all! :smiley:

I do have a couple of followups:

  • how can I make the DOSBox window bigger?

  • if you try downloading DOSBox yourself, watch out for false ‘Download here’ buttons. There were at least two on the same page as the actual download and they were real time-wasters.

In the main DOSBox directory, you will find a file named dosbox.conf. If you edit this file in Notepad, it will have a number of options you can change as well as instructions for what the options mean.

Set “fullscreen=true” to put DOSBox in fullscreen mode when it starts. You’ll probably also want to add “fulldouble=false” and “fullresolution=800x600”.

You can create a custom copy of this configuration file for each DOS game you want to play. To run DOSBox with your custom file, you can type “dosbox -conf [path to custom file]”. At the end of the configuration file, you will find a section called [autoexec]; in that section, you can put the “mount” and other commands needed to automatically start the game.

:smack: I must be going senile. That would be the problem, it’s just y:, not cd y:. No idea where I pulled that cd from, it shouldn’t be there.