Can't view Secure web pages through Internet Explorer Help?

A little background: this problems started with renewing my Norton Antivirus protection for another year; and something about the install of the Norton upgrade went sour and I’ve had some problems since, including that Norton cannot complete a Live Upgrade, meaning that my virus protection is now months out of date.

Anyway, whenever I go to a secure web page I get a “The page cannot be displayed” message. Refreshing, or going back and forward again doesn’t help. This has essentially shut down all my internet transactions from my home PC. I believe I get to these pages, because on occasion I go from the secure address back to an unsecure one, and get a Security Alert notifying me that I am leaving a secure page. I haven’t even been able to communicate with a Symantec tech, as you have to go to a secure page to do it. And their only live phone service is a pay by the minute trouble shooting line. Since thet fucked up my computer in the first place, I don’t want to toss more money their way.

I would often receive the same message because I don’t use IE. :slight_smile:

In almost all of those cases, the secure web page/site is designed only for IE users and not constructed according to web standards. That you are running into difficulty with IE leads me to believe a corruption within IE and not the web pages themselves. Check your IE security settings. Norton may have accidentally corrupted the settings.

You might want to try viewing the web site using a different browser such as Mozilla or Firefox.

I’m not sure what Duckster is referring to. IE does not have a non-standard version of HTTPS, so I’m not sure how a site could “not be constructed according to web standards” and still work with it, or any other browser. Sites can be made IE specific, but this kind of thing would tend to manifest itself in other ways rather than a “Page cannot be displayed” message.

Anyway, that to one side, go to Tools / Internet Options in the IE menu bar. Click onto the “Advanced” tab and scroll down to the “Security” section. Check that you have “Use SSL 2.0” and “Use SSL 3.0” ticked. You should also have “Check for publisher’s certificate revocation” and “Check for server certificate revocation” checked for the sake of security. If “Enable Integrated Windows Authentication” is checked, try turning this off.

If there’s still no joy from doing this go to the “Content” tab and click on the “Certificates…” button. This should bring up another tabbed dialogue. Look at the “Intermediate Certification Authorities” and “Trusted Root Certification Authorities” and check that there are (numerous) entries under each.

If these certificates are missing then your browser won’t trust any site, and may, because of Norton being installed, default to simply blocking them. If you find this to be the case post back and I’ll hunt up the procedure for re-installing the trusted certificates.


A friend of mine had EXACTLY the same problem with the recent update to NIS. After a recent Liveupdate, all access to secure (https:) websites is kaput. He runs WinME, IE 5.5 & NIS 2002.

He uninstalled NIS, and his secure IE returned to normal. He tried several cycles of install / liveupdate / uninstall of NIS and it miraculously started working.

No guarantees, but you mnight want to try that method.

It is worth checking that your machine isn’t trying to connect via a proxy server (or if you must connect via a proxy, making sure that the port numbers are correct - you’d have to get the correct infor from your ISP) - in Win/IE, the proxy settings are in Tools>Internet Options>Connections>LAN Settings>Advanced

A web site not constructed to W3C standards sometimes causes problems for browsers (such as Mozilla) which are standards-compliant. As I said in my earlier post, sites constructed with IE-proprientary code have been the culprits in my experience. In this particular case, the Norton update appears to have caused a corruption in the IE settings.

There are a few secure pages I can’t access with IE. Instead of the standard error message I get a blank page. I now switch to Netscape when I run into that glitch. That may work to get you into a secure page at Symantec, your bank, etc.

Another thing to check is to see what your cipher strength is. Norton has done this a few time with me, it would modify some of the files needed for IE to support encryption. If you go to Help>About and look to the part just above the credits there should be a part that tells you the Cipher Strength. If this is any thing less than 128-bit you might have troubles accessing secure sites.

If the cipher strength is 0-bit then this MS KB article might be of some help.

Black Lizard

Black Lizard has it I believe. Chances are your IE is only running 64-bit encryption. This will cause it to fail on sites that use 128-bit.

Either that, or you are running with this dud Microsoft patch .