CD-ROM drive: No response

I have a Dell Inspiron 4100 Laptop. Lately, the computer has refused to acknowledge its own CD-ROM drive (or CD-RW drive if you prefer). I put a disk in the drive and use the Start pop-up menu to “Run,” and I get an on-screen message to insert a disk. I have even put a cleaning disk in; and “uninstalled” the drive. I can’t use my CDs. What do I do about this?

Don’t have an answer for you. Just wanted to add that I have a similar problem with a Dell 610 Latitude running XP. Usually resolved after a reboot. Never noticed an issue reading CD/DVDs, just trying to write them.

Just so I understand this correctly, the OS finds the drive alright, it’s just that it wont read the disks you put in?
So you uninstalled the drive from device manager, rebooted, and it still doesn’t work?
You could try to download the latest drivers from the manufacturers webpage, see if that helps.
Maybe the laser could be calibrated or something like that, but really, getting a new drive would probably be the easiest solution.

oh, you could also check to see that the IDE cable is properly plugged in (long shot).

IDE Cable? :confused:

I had a problem like this on my work computer once. It lasted for a year or so, then one day the computer wouldn’t start. They came and replaced the entire power source in the computer and it worked after that.

I had similar problems, I could put in a CD for about five minutes then it would stop and say there is no drive, or no disk in drive. Sometimes a reboot would work, others it wouldn’t. Never understood why just changing the power fixed it, but it did.

There’s a computer-maintenance maven in the mobile-home park where I live. He and I contacted Dell; and, to sum it up, I’m probably better off abandoning the C: drive and using my USB adapter to connect an external CD drive (which would be the F: drive now). This is likely because parts for an older laptop (Inspiron 4100 ) are harder to come by now. :frowning:

The USB route would work just fine, and you could upgrade to a DVD drive while you’re at it. Then you can watch movies on your laptop if you’re into that.

Your old CD-ROM drive isn’t be the C: drive, it’s probably D: or E:

Some software, especially games, might not like that your CD-ROM drive letter isn’t working any more. You can change the drive letter of your old CD-ROM drive something like Q:, and change the new drive letter to whatever your old one was. To do this:

-Right-click My Computer
-Pick Manage
-Double-click Storage
-Double-click Disk Management

That will bring up a list of your drives.

-Find your old CD-ROM drive (and make SURE it’s your CD-ROM drive, it will NOT be C:)
-Right-click on the white rectangle that contains your drive letter
-Pick Change Drive Letter or Paths
-Click Change
-Pick Q: or whatever off the drop-down list.
-Click Ok.

Then do the same right-click-on-drive-letter procedure for your new drive and assign it the drive letter of your old drive.

OK, it wouldn’t be C: but it wouldn’t be D: either. That’s because when I got the laptop I rescued the 1-gb hard drive from my old computer console and now use it as an exterior hard drive, with the designation E:

Whenever I would have trouble with my drive, I would restart the computer and hold the eject button during start up. However I’m thinking that probably wouldn’t work with a laptop.

Its also very possible that the CD drive has given up the ghost. Drives can be had for $30-$40 on ebay and can be easily swapped out by non technical folk. I have done several of these in my shop.

A co-worker had a very similar-sounding problem to the OP’s and she found the solution on Dell’s message boards by searching for her model number and “cd rom” or something like that. It was a software issue, but I never did get the details from her.