Cell phone camera crashes entire phone, but only when photographing certain things

I’ve got a Palm Treo Pro and the camera on it is mostly used for photographing lost gloves.

Once in a while, I’ll take a picture and when it tries to save the image, the whole phone will crash, recoverable only by pushing the littls reset button under the back cover.

But here’s the strange thing. The problem can be replicated by trying to photograph the same item again.

So I might try taking the picture, and it crashes
I reboot and try again, it crashes
I reboot, take five assorted pictures of other random things/scenes, they work
I try to take the first picture again, it crashes
and so on.

It’s happened like that on dozens of occasions now. If I compose the shot differently, it seems to work, but if I try to take essentially the same picture again, it crashes, repeatably. It’s beyond the point where I feel I can reasonably chalk it up to coincidence.

It’s storing the images in JPEG format, and the crash seems to happen at the point where it would save the file - is it possible that some kinds of pictures are inherently more problematic to compress? (I mean, in terms of their visual content, contrast, etc).

It probably has to do with the resulting file size of the one scene you’re trying to photograph.

My camera(not cell) usually saves photos at around 1.4MB but a few go as low as 1.1 or up to 1.95.

Does the camera have auto focus? A bug in that could cause repeatable crashes, and the same scene would have the same features to reliably trigger the failure. I doubt that retaking a particular photo could reliably trigger a compression bug - each photo should have enough variability that a subtle bug didn’t get triggered.

The other option is an error when generating/writing metadata into the photo - similar scenes may have similar elements (fstop, focal length, orientation etc) that could cause a repeated failure on the same scene.

Can you identify common elements in failing photos - light, vertical/horizontal features, camera orientation, faces, time of day, direction.


You’re not taking photos of bank notes, are you? :wink:

Does it have smile recognition?

As far as I know, it’s not trying to do anything clever and artificially-intelligent. It does have auto-focus, but could that be crashing it after the image has been captured? (I don’t think it writes an awful lot of metadata beyond the date and time)

I can’t think of anything in particular (that was apparent to me) that the images had in common - at least, not that isn’t also true of many that were successful - although the lighting conditions, subject and background vary a lot from one case to the next, I adopt a pretty similar composition for most of these pics, just because of what they are (linky)

You can’t photograph a fnord

I like the idea of having a camera just for photographing lost gloves.

If it’s crashing on saving, then it might be the file size or extra processing needed for compressing certain pictures. Random elements in a picture require more work to compress and make for a larger jpeg file, that might be the distinguishing factor. Try it with something simple (like a Mondrian painting) and then chaotic (like a Pollock). Stick a solitary child’s glove on a railing in the foreground if you like.

I had a Sharp plasma TV that Motorola RAZR V3’s were allergic to - if you tried to take a photo and the TV picture was anywhere in the image, the image would be corrupted when saved on the phone. This was repeatable with 3 different V3 phones.

Huh. Omron rings, definitely the most interesting thing I’ve learned this week (so far)! I knew that photocopiers have security measures embedded but wasn’t aware that these rings appear on every major currency.

My Brother in law takes photos of old boots, I had thought he was uniquely strange especially as he talks of publishing a book of the photos.

More on topic, what happens if you take the original shot with another camera and then try to take a photo of the photo? If you can recreate the fault this way then you can try it with another model of the same phone or pass it to their support team.

I had a similar problem on my Nokia 5800, though it was related to someone sending my a photo via MMS. One particular photo always crashed my phone. I ended up resolving the problem by doing a hard reset of the phone and reloading the latest firmware (which was the same one as I had before).

Updating this thread with some more research/news…

I spent many frustrating moments trying to photograph this pale blue ‘Magic’ (expanding knitted fleecy) glove in Norfolk, while staying with in-laws (the linked photo was taken using my ordinary digital camera). I could photograph this glove from a distance of more than about five feet, and I could capture it close up in movie mode, but the phone steadfastly refused to snap it close up.

I rebooted the phone four or five times, on each of three different days (each session happened to be different times of day, and under quite a varied set of lighting conditions).

I could photograph other nearby objects at any distance, including close up (I tried quite a few different objects and scenes, taking a series of photos at decreasing distance). On every single attempt to photograph the glove, from any angle at all, I took a series of pictures as I approached and once I got closer than about four feet, it would lock up when trying to capture the image, repeatably, without fail or exception.

I had the same kind of experience with a different glove today - and I think I’ve spotted a pattern. The problem seems to occur when the fabric in question has this sort of rough fleecy texture and speckled appearance - It doesn’t seem to prevent the camera capturing the image, as the image preview feature (when enabled) shows the pic - but it locks when tryting to save the image (suggesting some weirdness with the compression, metadata or file-writing itself). It makes no difference whether I tell it to save to card or internal memory.

I felt sure this must mean it’s a false positive for the Omron Rings, but I just tried photographing some paper money and pictures of the EURion constellation, and it worked fine.

Perhaps some lost gloves do not wish to be found. :eek:

Maybe it can’t be photographed. Did you try holding it up to a mirror?

You need to disengage the Michael Jackson mode. Is there a patch issued since 25 June 2009?

This whole thread reminds me of why I would never, ever trust a computerized autodoc that would"treat" what it was programmed to regard as neurochemical and neurological maladies. HIdden programs mandated by the authorities? Run the “anti-paranoia” treatment.

Have you tried disabling/tinkering with various controls on your cameraphone? Auto white balance, auto flash, auto focus, whatever may be toggled?

Yes - I’ve fiddled with the configuration, without success (there aren’t a lot of configuration options really anyway).

I’m just now printing a full-page photo of the offending glove and I’m going to try taking a photo of the photo - if I can duplicate the problem here at home under much more controlled conditions, I can start to experiment with masking off parts of the image, etc - see if I can nail down exactly where the problem is.

…well, that was a disappointment. I can reliably take a picture of the photo of the problem glove - in fact I can’t make it misbehave at all with this.

Which tends to suggest some sort of environmental problem, such as some sort of focusing problem that doesn’t prevent image capture, but fatally breaks the metadata.

Or very, very strange coincidence (but to be honest, I think I’ve reduced that possibility to a reasonable minimum in all the repetition I’ve done).

I did think it might have been loss of cellphone signal when the phone is held low to the ground, occupying the CPU somehow, but the problem still manifests with the device switched to ‘airplane mode’