Computer freezes - feels like HDD problem

I was playing SimCity 4 last night and clicked to perform a particular operation, and the machine froze; the sound suddenly went into an infinite loop on the last note of the music that had been playing, and no keys would respond. I shrugged it off as “gremlins” and rebooted. Decided it wasn’t worth the hassle to repeat the actions I’d performed on the city, so I tried HALO instead.

As the game booted up, one of the many splash screens froze, and the dramatic music that plays over the flashy video came to a stuttering grind. Basically the same error - computer just locked up while trying to walk and chew gum at the same time.

I defragged all three hard drives (the RAID-0 and the 120GB backup drive). I rebooted and underclocked my CPU. I performed a chkdsk on the RAID since it’s had problems before, but found nothing wrong. I even checked my HDD cables’ connections and arranged them a little more sensibly on my motherboard (RAID on the RAID IDE channel, 120GB on IDE1 with the CD drive, IDE2 and RAID2 empty).

Problem persists; pragmatic professional pleads: fix foul-up, free functional furniture for fun!

A few questions:

  • How many watts is your power supply?
  • What’s your CPU temp?
  • What was the hardware you modified last?

Power supply is 350W with plenty of juice on all rails. I last modified the RAM and CPU (almost a month ago). I installed all-new RAM and a 35W Athlon 2400+ XP-Mobile that I’m running at 1.6GHz (down to 1.4GHz while I stabilize the system). At 1.6GHz it runs around 43C. At 1.4GHz it runs around 41C. The system has been stable for a month, and ran SimCity 4 and HALO flawlessly for several two-to-three-hour sessions before this problem came up.

Could be flaky memory that just took a month to manifest itself.

Make sure you’re running the memory at the correct voltage setting as well. There might be a jumper that changes it on the motherboard.

If you are having problems mainly in graphics intensive applications (like a lot of games), take a look at your video card.

I had some capacitors go bad on a 3-d video card. The machine would work fine in most Windows screens, or Explorer, but would lock up in games.

There have been some known problems with a batch of capacitors that were build a couple of years ago. If that’s your problem, you should be able to get a free replacement (probably a rebuild) for the card from the manufacturer.

I’ve further isolated the problem: it occurs only when starting HALO (Sim City 4 works fine) and the problem started after Sim City 4 glitched. My pet theory at the moment is that Sim City 4 was using a graphics library when it crashed, accidentally overwrote something in that library, and HALO requires that library to start. I have uninstalled and reinstalled the game, but the problem still persists; I have not yet tried reinstalling, patching, and then running the patched version.

Since the patch claims to fix a known “crash on startup movie” bug, it’s possible that my machine has now become susceptible to this bug, somehow due to Sim City 4 being stupid. It’s further possible that patching the game will eliminate this problem.

Yeah, If you’re only having problems with one software app, then no reason to go ripping the hardware apart like we started to suggest above.

You can always reinstall and then patch it up and hope there are no more issues.