Computer Problem: CD-ROM not reading

Alright… I’ve had this machine (P3 550MHz, Mitsumi FX320 CD-ROM) for a few years now. It was fine when I first got it, but for the last two years or so my CD-ROM hasn’t worked. I know, I’m pretty lazy to not have fixed it before…

Anyway, on POST it seems to recognize the CD-ROM (FX320 shows up as the secondary slave, I believe). Once I get into Win98, I’m able to open the tray, but nothing more. Any attempts to read from a disc fail (Drive not ready error).

Does anyone have any ideas what I could do to fix this problem? I believe awhile ago I tried switching the CD-ROM over to the primary slave, but I can’t really remember for sure.

Just seems odd that I can control the drive (eject the tray), but I can’t read any data.

PS: I don’t think I’ve seen the drive activity LED come on recently…

Usually happens to me when I have set the CD Master/slave jumpers wrong.

This has worked for me in the past:

Open up your Device Manager
Click on the CDROM drive
Remove the device and OK your way back out
The computer should now see the drive as a new device and load the correct drivers

this has happend to me several times actually. waht we did was just replace the whole damn thing. so many faster speeds come out all the time u could easily end up upgradeing ur cd-rom for a decent price

You can rule out a Windows problem by creating a boot floppy through Add/Remove Programs, booting to it, and choosing to start with CD-ROM support. See if you can read from the drive in DOS. If not then you’ve got a hardware issue. Make sure the ribbon cable is oriented correctly, both on the drive and the motherboard. Try removing the Master/Slave jumper completely. Swap ribbon cables between the HD and the CD-ROM. If none of that changes anything then the drive is probably defective. Luckily they’re cheap.

The usual warnings about static electricity apply.

Welp, after fighting 'n swearing a little while, I tried putting in a DVD-ROM I had around. As far as I know the the DVD-ROM works. Now I can get the machine to boot off the Win98 CD fine, but when I try to read a disc in Windows I get “The system cannot find the device specified”. Strange.

So I go have a look in the Device Manager. What I’ve got now seems a little odd. No CD-ROM section, which I had before with the Mitsumi CD-ROM drive. Now, as well as missing that section, I also have a flag on the secondary IDE controller. Didn’t have any error flags on it before I put this drive in. Usual message in the properties ("This device is either not present…).

Anyone have any ideas for what I could try?

Or any ideas about why I can now boot off the Win98 disc (which I couldn’t before with the Mitsumi drive), but can’t find the DVD-ROM drive in Windows?

Ya know, it’s kinda sad that I’ve been coding for about 14 years (64% of my life), and can’t fix a relatively simple hardware problem.

They’re 25.00 or so on sale - get a new one. Hell, 48X CDRWs are only 50.00 or so with rebates.

With the DVD-ROM in, have you tried start/control panel/add-remove new hardware? Does it detect the drive? If not, can you try loading the drivers manually? Win98 may not have default drivers for your drive.

First boot into Safe Mode and try to remove all IDE controllers from the Device Manager. It may not let you get rid of all of the entries. Reboot and see if Windows re-adds them correctly. If you still get a yellow exclamation point on that controller then you probably need to reload the drivers that came with your motherboard. Most manufacturers make these available on their websites.

Alrighty… gonna go try out the new suggestions in a minute. Hopefully I’ll get somewhere. Either way, I’ll bbiab to let you know what happened…

Well that really sucked. I tried Add/Remove new hardware, it found the secondary ide controlller (the one with the error flag from earlier). It couldn’t find any new drivers.

Tried removing the PCI Bus Master (and both IDE controllers went with it). When I rebooted, after the whole loading process instead of getting a windows desktop or login dialog, the screen was all blue with a little grey block on it. Not good.

Tried booting into safe mode, going back to normal mode, etc. After screwing with this for about half an hour, I got Windows booting normally again.

So, I’m back where I was before. Guess I’ll go a driver hunt, see if maybe there’s new drivers out for the IDE controllers…

Thanks all for the help so far…

Just had a search on the Intel site. Found this link:

Intel Motherboard

This could be the problem (well, should be the problem).

Gonna go play with this workaround, see what I can do…

Well, gave that Intel workaround a shot. I think that’s how I used to have it set up: Primary master was the HDD, and primary slave was the DVD-ROM. Switched to that setting now though, and the HDD wasn’t recognized. Neither was the DVD-ROM.

Any ideas about this one? I’m pretty sure I had the jumpers set right (at least according to the stickers on the drives).

Your drive can be recognized and the electronics be perfectly operational but if the optics are out of sync if will not be able to read anything. I have never been able to truly fix or recover a misbehaving CD-ROM and I have tried several times. I now consider them to be essentially disposable when they start flaking out. - You can get them for $ 20.00 with a rebate at Staples or Officemax. Just get new one.

You should have tried a cd lens cleaner. Chances are your lens was just dirty & needed cleaning. Also, I have to buy a new cdrom drive every couple of years anyway. But if they are made by like HP or TDK, they last a long time.

Also, most Bioses have a memory of what the computer has in it so it can boot quicker (NVram). So if you put in another item, it won’t recognize it cause its looking for only the old setup. You have to get into the bios & set it to a safe boot or whatever setting it has to reset itself to recognize new things.

You’ve established that the drive works since you were able to boot off a CD. The problem is being caused by a Windows issue with the secondary IDE controller. I’m still thinking you don’t have all the motherboard drivers loaded.

Appreciate all your help… I’m going to try a lens cleaner tomorrow. Seems the most likely culprit, at least for the problems with the DVD-ROM. I may have been hasty when I said I could boot off CD. It can boot to the command prompt off CD, and gets part of the way to going to the Windows setup. So probably lens problem.

Anyway, appreciate the help, I’ll try cleaning it up and let you all know how I fare…