Computer problem – no power

I appear to be mildly screwed. My desktop died. Kaput. New problem that I’ve never had to deal with yet – complete lack of power. This, in some respects, may be a good thing (as far as problems go) because of the potential to find the solution. There’s not much that can go wrong on a power supply other than complete death.

I’ve never dealt with this before so I’m not sure of the diagnostics. The ONLY change I made (I promise!) between the last time it was working and now was that I shutdown the system. I typically leave it on all the time and restart occasionally, but for whatever reason I shut it all the way down before heading to bed a couple nights ago. That’s it. It worked fine the night before, shut it down, and nothing worked in the morning. Bah. No power at all when I hit the button. Fan, LEDs, nothing goes on – it is as if it is completely unplugged. WTF?

All power cables are completely plugged in and even placed in different outlets. Other things plugged into the same outlet too, just to be sure it is not that. Checked the master switches on both the powerstrip (and its breaker) and the back of the power supply – both are on. Swapped chords too, no change. Only thing I haven’t done yet is pop off the cover (yeah, simple but haven’t had time) and check to see if the hot-board LED is on. If it is, I’ll know the problem lies in the case switch, a three-dollar fix at Radio Shack. If it isn’t and the power leads are still firmly in place (box was not moved, so no reason for them to be loose) than it has to (as far as I can think of) be the power supply. Unless, of course, I am missing a diagnostic step. Any suggestions?

On the plus side (if there is a plus side to having to shell out cash for a mundane piece of equipment) is that if things are as they appear, it should only run me between thirty and fifty bucks to replace it. Also, so far this case has been a dream to work on so replacing it should be no exception. Could take ten minutes, tops. In theory, that is.

Of course, if it is something more…
Thoughts? Diagnostic suggestions? Power supply/ vendor recommendations?


One thing I would do is unplug the power cord from the back of the power supply (also flipping the PS power switch to OFF), then slide the voltage switch (usually an orange switch inset into the PS casing) to 220 then back to 110.

I’ve rescued more “dead” systems doing this. How does it work? my WAG: After a system has been used for a long time the various vibrations (fans spinning, drives spinning, ankle-biters tugging at cords, kicking the case, etc) eventually, ever-so-slightly, starts unseating that voltage switch, until it becomes unseated from the 110v position - resulting in the PS not working at all. Sliding the switch to 220 and back just ensures that the switch is firmly reseated to the 110v position.


Thanks… easy enough and the first thing I’ll do when I get home. Hope it is that simple!

First thing you should try is to use some other power supply unit with your motherboard. It’s probably either an SMPS problem, or a motherboard problem. If an SMPS from another PC solves the problem, replace the SMPS. If not, it’s probably something with the motherboard.

If you don’t have access to another SMPS, try getting a multimeter from somewhere and test the output voltages from the SMPS to the board.

disclaimer: I’m assuming you take neccessary precautions before you proceed.

[ignorance] What does SMPS stand for?[/ignorance]

I built this machine so I have a basic knowledge of putting things together. Have a litte insight into the whole smoke thing too (don’t know where the page that describes that is, but it is funny if you know what I’m talking about.)

I ahve a friend who just bought a new system and shoudl be able to sacrafice his power supply for testing. Since I get NOTHING, not even a running fan, doesn’t that point to a problem before the motherboard?

What you described in the OP was exactly what happend to my puter two weeks ago. Exactly.
It was the power supply allright, and easy enough to replace, thank goodness.

I would test it with another power supply. Just open the case & plug it in to the board. You dont even have to take out the old one.

I agree that it’s mostly likely the power supply. I lost mine just a few weeks ago and it did exactly what you described. If you can reset to 110V, try that first. If you can’t, yank it and put in another power supply. If it works with the replacement, go to your friendly neighborhood computer dealer (NOT Best Buy or CompUSA), have them test the supply for you (or you can do it yourself if you have a voltmeter) and, if needed, order a new one. If you want, you can also open it up (standard warnings about electricity apply) and look for burned circuit boards. If the board’s burned and you’re not getting anything on the voltmeter, replace it. You said it’s a homebrew, so at least you won’t have my problem of having to order a properiatary supply.

A point no one has suggested yet…

Almost every PS I’ve ever opened has a fuse on the circuit board. Just a simple (5 amp, maybe?) glass “Buss” type fuse, like they used to put in cars.

If you open the PS and there are no other obvious problems, e.g. burned spots, smoky smell, molten lava, etc., check for a fuse.