Computer question: Keys self-rearranging in Word

On Friday I was working in a file in Word XP, and suddenly the keys rearranged themselves… the “A” keystroke was rendered as “Z” onscreen, the “S” came out as “9”, the “D” appeared as “Z”, etc.

All other programs were normal, including text windows in MSIE, Notepad, etc. After closing and restarting Word, it started happening about 5 minutes into my session. After 5 or 6 tries it started normally and didn’t fall into the odd mode again. Then today it started again, with different keychar assignments but still the same overall problem.

I always have AVG and Windows Defender running and don’t visit “risky” sites that I know of.

Have any of you come across this anomaly in XP before? Any idea what might be causing it?

Many thanks…

I have sometimes had a problem with laptop computers, where the numeric keypad is embedded within the alpha keys, and having the numlock key toggled on will cause those specific letters to generate their numeric assignment, but this does not seem to be the problem you are experiencing.

A couple of our Dell laptops had a similar problem, where nearby keys swapped with or duplicated each other. Fixed by opening up the case and detaching and reattaching the keyboard’s ribbon connector. The instructions were on their website.

Am I reading correctly, that both A and D showed up as Z? That would rule out it being an alternate keyboard mapping.

Thanks for the replies so far. Chronos, the keys seemed to move around in the different iterations of the problem, but I think the same key always produced the same wrong character each time Word was run.

Is there a “map to Dvorak keyboard” or somesuch in Office now?

No te puedo ayudar, but I’ve had this problem too, 2 or 3 times. I haven’t tried to intentionally reproduce it. The change only affects Word. My impression was that I caused it by clumsily striking some odd key combination. I’m working on XP pro on a recent Sony laptop

Hmmm. Not Dvorak, I checked, and none of the Dvorak layouts out there put Z on the key normally used for A on standard layouts.

  1. Turn off the Numlock - usually the blue function key, and an F8 on most Dells. Its usually the culprit.

  2. If the numlock doesn’t work, then sadly, your keyboard is dying. You can get one for about $80, and replacing them is fairly easy.

You can also take a can of air, and use it to blow out the crap usually found in the keyboard. You might have gotten a crumb of something stuck in just the wrong spot, messing up your keyboard.

But I’ll bet you a quarter your keyboard’s going bad.

I think I’ve found the culprit, after seeing Mr. Slant’s note about Dvorak I went into the regional/language facility and found that there was something like Dvorak U.S. English left hand, Dvorak U.S. English right hand, U.S. English international, etc., which I have never used or added to the language sets. I eliminated them from the list and the problem hasn’t occurred today. Maybe it’s possible that some odd key combo adds keyboard sets and I inadvertently toggled to it? Or that some third-party document I opened contained a command/macro/thingie that added new sets? In any case, thanks again for the help.

I suspected it was that, I used to have a similar problem where the regional/language facility thing would make it impossible to type vowels without accents appearing on them (due to French Canadian language settings).

I believe there’s a shortcut key combo that’s astonishingly easy to hit accidentally, which is why it keeps happening when you don’t want it to. Can you disable it?