Dell computer can't see flash drive

I bought an 8 gig Sandisk USB flash drive and my Dell Dimension 8300 running XP Home sp3 can’t see it. Any help would be appreciated.

Thanks in advance.

Do you have access to another computer to try this? And do other flash drives work on this system, in the same port? It’s possible that the new flash drive is defective.

How old is the Dell? Any chance its USB port is USB 1.0, and your flash drive is USB 2.0?

A USB 2.0 drive should work in a USB 1.0 port. It just won’t be as fast and Windows will pop up an annoying box telling you what you’ve done, but generally it will work.

Does the drive work in another machine? Does anything else work in the Dell’s USB port? If you right click on my computer, then click on hardware, then device manager, does your USB port show up with a yellow question mark?

Another idea which might be a stupid idea, but do you already have something mapped to the letter drive that you would expect your flash drive to use? I ran into a problem with one flash drive that would only mount as F:, and I could only see it if I disconnected the network drive that was mapped to F:.

I have an older laptop at home that frequently can’t see some of our flash drives. If I download the driver and install it starts working again.

I don’t have access to another machine with USB ports, so I can’t test the flash drive. My USB port doen’t show as having any problems in device manager.

I guess I’ll go back to the store and exchange the drive.

Try going to Control Panel -> Administrative Tools, choose the Computer Management utility, and go to the Storage -> Disk Management item. See if the drive shows up there. If it shows up there but with no drive letter, you can initialize it, format it and/or assign a different drive letter from there.

No, it doesn’t show up there.

While the Device Manager may not show conflicts, that isn’t always an indicator.

Have you used any other USB storage devices on this PC before? Have you tried all USB ports, front and back?

Sometimes front USB ports may have problems - maybe the connector is damaged, maybe the front ports are “passive” or unpowered ports (although this shouldn’t matter with a flash drive - this would be more of a USB hdd problem).

Good luck.

That strongly suggests a hardware problem. Do you have other USB devices that work on this machine?


Bingo. Tried it on one of the rear ports and it works. Thank you.

Suggest you plug in a short length of USB cable and bring the free end to the front where you can get at it more conveniently.