Direct X 9.0

I recently bought Civilization 5. After installing it and starting the game up, I found all the text messed up. Looking online, I found a few workarounds, none of which worked. A little more research, though, showed that there are 2 ways to run the game: With Direct X 11 or with Direct X 9. Because of my laptop’s graphics card, the game won’t run in 11 and has to use 9. I’ve looked around, but can’t find anywhere to download it that seems safe/malware free. (I searched at Microsoft for “Direct X 9”, but it was pretty confusing and seemed like it wasn’t there. However, I admit I couldn’t really decipher the hits it gave me.)

So here are the questions: Is there anywhere I can download DirectX 9 safely (Ideally from Microsoft)? And are there any special instructions I need to follow to make my computer use it instead of 11?

Toshiba Satellite running Windows Vista, I can provide more details if necessary.

You can get the latest version of the runtime here.

Civ V should provide you with a choice of DirectX 11 or DirectX 9 mode when you start it up. It does for me, anyway. Also, you don’t need to download anything; the game should have installed it for you.

It installed something, but I think it was DirectX 11. I read that I should be given the option, but my best guess is that since I don’t have 9, the game just assumes it should run in 11.

Palooka: Thanks for the link. I’ll download it when I get home and see how things work out.

Welcome to Microsoft World, where despite what you might think DirectX 11 is not a replacement for DirectX 9 and they can run perfectly happily alongside each other.

And where DirectX 9.0c still has new versions released every now and then without incrementing the version string in any way. Palooka’s link will sort you out, I’m sure.

Thanks for the help, I finally got things working. I had to download a workaround (PM if you need the link), but that and getting Direct X 9 worked.