E-mail server IP address not matching sender IP address? WTF?

I have about zero idea as to what this means.

Obviously, I changed some things - shouldn’t matter. Namely, the blah and the ABC.DEF.etc.etc.

The only thing I can figure out is that it thinks my IP address is not jiving with my mail server. Odd, since my IP address (checking through ipconfig) is not ABC.DEF.GHI.JKL. Although… my DNS servers are all the same up to the .JKL part. Anyway, is there a way to fix this? It wasn’t a problem until I switched to RoadRunner. If you can read Korean, there’s a help that was included in the little e-mail that was sent back to me.

The IP address that the world sees and the IP address you see for your computer are not the same. There is address translation going on at your provider. There are several reasons for this, security being one and avoiding conflicting addresses being another.

What they saw was the publicly routeable address. Whatever you send from your computer has the intranetwork address (say Your ISP receives that traffic and translates the address to another (say and passes the traffic on to it’s destination. Replies go to which is caught by the ISP and translated to and passed back to you.

Now, about the mail. Mail and printing, as common as they are, suck to understand. They are strange beasts. There are several ways to implement email.

From your description, it sounds like what is happening is you create an email message and send it. Your mail tool (outlook, netscape messenger, opera mail, kmail, evolution, mailx, whatever) is configured to pass emails on to a mail server.

Your mail server is ms-smtp-01-eri0.blah.rr.com. The mail is actually sent from that server. It’s like mail here in the US (can’t vouch for other places). You write a letter. You put your address on the envelope as a return address. A postman picks it up or you drop it in a mailbox. The letter is actually sent from the post office. It’s like the recipient is seeing the post office’s address as the point of origin, but your address for the return.

I don’t know why they pinged this as possibly bogus. This is common. Because mail is such a pain, and can take up so much space, it is common for several client machines to pass all email through a central mail server. One host to configure, maintain and protect.

I’ll stop rambling now.

And I don’t care if is a valid routeable address or not. I was making it up.
leenmi - eagerly awaiting the wide acceptance of IPv6 and the end to the tyranny of network queens everywhere

So hanmail.com’s problem is that my post office’s address isn’t the same as my home address? Any ideas on why this wasn’t a problem before? Better yet, any ideas on how to “move in” to my post office so that I don’t get this error message? I’ve heard about things called IP spoofers, mainly in connection to illegal hacking activities. Is there a way to (legally) use one of those to do it?

----- Transcript of session follows -----
… while talking to mx1.hanmail.net.:
>>> DATA
<<< 553 5.5.4 Host name(ms-smtp-01-eri0.blah.rr.com) is not match with your ip(ABC.DEF.GHI.JKL), maybe it’s bogus.

Is this reply in response to an email you sent to hanmail?

What were you doing when you got this message? It occurs to me that the last line could also suggest that, for some reason, it has your hostname as ms-smtp-01-eri0.blah.rr.com but is seeing an IP address of ABC.DEF.GHI.JKL. If hanmail does a dns lookup up ABC.DEF.GHI.JKL or ms-smtp-01-eri0.blah.rr.com, they won’t match.

IP spoofing can be done and it’s not illegal. But it won’t help you here.

It’s probably a misconfigured mail server at rr.com. Try sending the bounce message to support and see if they’ll do anything. Good luck.

Here’s what is probably happening.

First, a bit about addresses. There are IP addresses (i.e., and there are names (foo.bar.com). A name represents one (or more - not typical but possible) IP address, and to figure out what IP address it represents, a DNS (domain name service) lookup is done.

When one mail server (ms-smtp-01-eri0.blah.rr.com) talks to another mail server (mx1.hanmail.net), the first thing it does (or is supposed to do) is open a connection to the other mail server, and then introduce itself by saying “hello”. In fact, it’ll probably look like this:

HELO ms-smtp-01-eri0.blah.rr.com

mx1.hanmail.net will read this introduction, and it can use this information to decide what to do. For instance, it can lookup the name and see if the IP address corresponding to the name matches the IP address of the connection.

I’d guess the problem is one of 3 things:

  1. The mail server at roadrunner is not ms-smtp-01-eri0.blah.rr.com. The likely cause is misconfiguration of the mail server software.

  2. The mail server at roadrunner is ms-smtp-01-eri0.blah.rr.com, but the IP address has recently changed, and the DNS records haven’t propogated yet.

  3. Roadrunner’s DNS is misconfigured, so the rest of the world isn’t aware of the correct IP address of ms-smtp-01-eri0.blah.rr.com.

Post the real name of the mail server and the IP address, and I’ll be better able to figure out which is the case. If it is #1 or #3, only RR can fix it. If it is #2, time (typically a day or two) will fix it. There are other possibilities, but these are the main ones.

Hey, thanks guys. I completely forgot to mention that I got the error message as a result of attempting to send an e-mail to hanmail.com. I think I’m going to call the RoadRunner guys and see what’s up on their end. Thanks again!

I get that kind of bounce message occasionally when sending from my own self as SMTP server. I’m on a PowerBook and I most certainly don’t have a genuine domain associated with my lowly self, but I’ve got sendmail configured to refrain from bitching about it. But some recipients’ POP servers get persnickety about it. (I generally only use self-as-SMTP when our company’s own SMTP server is having the electronic hiccups or I want a trace more privacy). Some ISPs won’t even let you operate as your own SMTP (e.g., Verizon DSL).

If your corporate server is starting to land you some replies when you send outbound emails, it could be because they changed the box’s actual IP without changing the typed-in identification settings to match. That would cause them to be doing the equivalent of what I do when using my own sendmail capabilities to send my outbound email with a phony non-resolving domain name, hence the bounce messages.

I would not think the IP of your own local end-user box would be a factor here, although I’m not netgeek enough to swear to that.

Uh, in other words, what 5cents said.

(gotta hit that “submit reply” button faster)