Electric range not working

My range is a Kenmore like this one

Yesterday the power went out in the kitchen. Seemed to be a loose fuse or something. Power is back, but the range coils and the oven are in-op. I replaced the 220 v fuses. The 110 v things on the oven went off, and came back on when I plugged the two-fuse block back in. So the range is getting power; the heating elements just aren’t working.

I tried to find a manual on the Sears site, but the ‘Model number’ isn’t actually the model number. The chat guy was completely unhelpful.

Is there a ‘secret reset button’ on the range somewhere? Is there something else that needs to be done to make it work?
EDIT since my original attempt to post this: I called Sears. Turns out its under warranty until September. The woman on the line was the ‘technical service’ person – only she is not a ‘technician’. She asked if the range had knobs. I said yes. She immediately said she had to order an ‘infinite knob’ and get a technician scheduled to fix it. :dubious: The oven wasn’t on when the power went out. I don’t see how a power outage could ruin a part. And I don’t see how she could come to that conclusion.

We’re without a stove until at least next Wednesday. In the meantime, I have the MSR WhisperLite set up.

Dumb question, but did you reset the clock? I don’t mean to the exact time, I mean did you reset the clock at all. My oven won’t work after a power outage unless the clock is set to at least something.

Yes. The oven doesn’t work unless the clock is set.

The manual (which I found on the page I linked :smack: ) doesn’t really say anything about why the ‘burners’ aren’t working.

Are there any fuses in the oven, like at the top, in the usual oveny spot?

I just searched the owners’ manual pdf and the only fuse reference was for the main.

I have no idea where they might be, if any.

I had the opposite happen with my oven/range once. The 220 powered burners worked fine, but the 110 powered electronics did not work. It turned out to be an electrical problem in that (I think) the neutral line became disconnected, so there was no 110 path from either of the hot lines. Seeing as it was an electrical problem to start with for you, is it possible one of the hot lines is not working?

It’s possible. Unfortunately, anything more advanced than a 110 v outlet or a light switch is beyond me. I guess I’ll find out next week.

You can test the continuity of the burner elements (removed) with a multi-tester to confirm they are all working. If they are all not working likely to be stove mechanism issue.

Go look at your fuses again. Range is 220V which is two 110V circuits. I suspect that one of the 110 legs has a blown fuse.

Fuses? Really? put a panel upgrade on your things to do list.

You can also use a multi-tester to check that it is getting power. Unplug the stove, and test the voltage in the plug. Between the neutral (the center slot) or the ground (the center roundish hole) and either of the hot slpts on the sides there should be 110V. Between the 2 hots on the sides there should be 220V. Between the neutral & the ground there should be 0V.

I suspect you may get 110V between one hot side and the neutral, but 0V between the neutral and the other hot side. And 0V rather than 220V between the 2 hots. That means no power in one of your hot lines – probably a bad fuse*. You can replace that yourself quickly, and save the cost & delay of waiting for a serviceperson.

*You can also use the multi-tester to see which fuse is bad – take them out of the holder, put the probes on the ends and check for continuity or resistance – they should show continuity or near-0 ohms resistance. The one that doesn’t is bad.

I replaced the two shotgun shell-like fuses in the block labeled ‘Kitchen’. I’ll check the other one.

I had an electrician out a few years ago. He said that in order to put in circuit breakers, I’d need a new meter (something about a modern square box with the dome on it instead of the round one there now). He said he couldn’t really put in a new box because he didn’t like where it was in relation to the chimney. Also, a breaker box won’t fit where the fusebox is. Oh, and I should replace the knob-and-tube wiring.

The old chimney is gone, so there should be no problem with a new meter. (The SO would prefer it to be somewhere more attractive than next to the front door.) We could find a wall somewhere to put the breaker box. Re-wiring the house will have to wait. The Jeep and the Prius have all needed expensive work, and the Seca is in the shop now.

checking the cartridge style fuses in their holder is important (remove the holder from the fuse box and with an ohm meter/multimeter/continuity tester find continuity between the end of the blades of the fuse holder). those fuses can look OK on the outside and be bad internally.

also plugging the fuse holder in and out a couple times might help remove corrosion.

other than replacing fuses (screw in or cartridge holder) or flipping circuit breakers, don’t do anything inside the fuse/breaker box. there is lots of deadly electricity in there and messing up could cause your house to burn down even years later.

if something is under warranty it is best to leave the servicing to the authorized repair people.

Sounds like one side of the 220 is out. The two sides are connected to the two ends of the heating elements, there is no neutral in that scenario (if that’s the proper way to phrase it). You can pull one of the burners and test both sides in the socket using a multimeter or even a simple AC test light. The fuse is a likely culprit, but it could be the connection on the back of the stove.

I’ll check the other block, and replace the fuses. I’ll wait until my lunch break, since that’s going to kill the power to my computer.

The other block is probably the ‘main’ – the fuses for all the power to everything in the box. If one of them was out, half your house would be without power, which you’d probably notice.

When I pulled the second (of the two) blocks out, everything turned off – except the clock on the stove. The block holds two of the red, shotgun shell-like fuses. I had one replacement one. (The other ones I have are green and say ‘NON-60A’ on them.) I was going to replace one at a time, but you turn the block on or off by inserting in one way or another. When I turned it, one of the fuses fell out. Not sure which one, as I neglected to mark which ones were in there already.

After some experimentation – and cleaning the ends of one of the fuses with steel wool – the stove and oven are now working.

I knew it wasn’t the new (-ish) stove that was faulty! Thanks for all of the advice, everyone.

Hah! I did hear about a guy who only lost the 220 power because his dryer and range were the only things connected to the second line. Electricians are probably supposed to balance the load in the box, but there’s no guarantee if it’s sparsely populated.

those cartridge fuses can deteriorate and need to be tested with a meter.

if you found the fuse not tight in the holder, then you need to clean up the metal contact point of the fuse holder. with a good condition fuse in the holder you want the fuse holder to hold the fuse tight, it should not wiggle or turn (you might need to bend the contact points very gently and very slightly). any fuses put in (or back in) should have the ends gently cleaned to bright metal. test the straight blades of the holder with a meter for good conductivity before placing back in.

with old fuse boxes if they aren’t replaced then it isn’t a bad idea to have an electrician clean it up every 3 or 4 decades. wires can loosen and will tarnish in that time, this could produce poor performance and hazards. this is a job for an electrician.

It’s comforting to know that you can make a fast getaway when your house burns down.