Ethernet Printer Odd Behavior With Iffy Cable

Our office printer, a Konica Minolta Bizhub multifunction, is connected to our network via an old Cat 5 (not Cat 5e) Ethernet run, so it only auto-negotiates to 100mbit rather than gigabit. No real problem there and it’s worked fine for months. The other day while fishing around for another network jack behind some bookshelves, I yanked around the wire to the printer jack (which is just in a plastic box sitting on the floor, not in a proper wall box or anything). After that the printer would still print, but I couldn’t access its web interface and scan-to-email would timeout. It’s like it was dropping upstream packets but downstream was still ok.

So I opened up the box with the jack and all the wires seemed fine, and I traced the run through the basement to our Ubiquiti switch, and it all looked ok there too, if a bit tightly secured in places. Swapping the patch cable did nothing, changing ports on our switch did nothing, unplugging the printer from power for a hard reboot did nothing. So I got a long patch cable and plugged it into another known good jack and it worked fine. Ok so the wiring is definitely suspect. However, after plugging it back into the old jack with the iffy wiring it now works fine again. What? I can’t come up with an explanation for that. We do have a DHCP network but the printer has a static IP in a different address range so it shouldn’t be an addressing issue. Maybe something related to the auto-negotiation in the printer’s Ethernet card that was kicked in the pants by giving it a good connection? Any ideas?

Gigabit works fine on Cat5 for shorter runs. If it only auto-negotiated to 100 Mbps, the run was already marginal.

There are lots of things that can make any given run more marginal, and thus less likely to work at gigabit. That includes:

  • Length
  • Cable rating (5, 5e, 6, etc.)
  • Wire gauge
  • Number of jacks
  • Kinks/sharp turns in the cable
  • Corrosion on the contacts
  • Incorrect cable pairing
  • And so on

If you yanked the cable, you may have kinked it in just such a way to put over its error threshold (and as you speculated, maybe just in one direction [100 base-T has separate transmit and receive pairs, while gigabit multiplexes them). And after messing around enough, maybe you scraped enough corrosion off a jack’s connectors or just plain wiggled things around enough that it started working again.

Is there a way to force it to 10 Mbps? That might make it more reliable. Ethernet over clothes hangers works at 10 Mbps…

I think a dodgy cable will give bad throughput, not bad negotiation… The printer may only go to 100mbit rather than gigabit (I didn’t look it up). Which leads to another random thought:

I got odd results like this on our 100mbit network because it was connected to a gigabit network, connected to a forwarding internet connection. The open internet connection was spewing packets harmlessly into the gigabit network, where they were all being correctly refused by a harmless device. But the traffic was so heavy that the 100Mb network switch, subsection, and devices couldn’t keep up, couldn’t break in, and kept loosing connection.

I got the same problems when I upgraded a hardware control server to a new box: the system puts out connection broadcasts looking for clients: that didn’t cause any problems using the old hardware, but when the processor was upgraded, it spun so fast that it flooded the 100Mb network subsection and caused other devices to drop out. Meanwhile, stuff on the connected Gb segments weren’t seeing any problems at all (makes trouble shooting less obvious)