Examples of voodoo tech?(bizarre errors etc)

I have a PSP memory card(whatever the name is) that reads fine in the PSP, yet the only OS that can read the card is linux, and even then you have to use an adaptor in the built in card reader. External card readers don’t even work, it doesn’t work under any variant of windows. The card has no visible damage or worn off traces, its magic!

One of my best friends and I are practically voodoo tech houngans. Unfortunately, he’s apparently Petro–stuff he touches is cursed and exhibits bizarrely broken behavior until I look at it and make it work again.

A notable example is a desktop PC he used at work some years ago. It started out fine, then over the course of a couple of months, it gradually lost the ability to communicate. At first, it was just a specific failure–sometimes he couldn’t connect to customer sites with our remote desktop setup. That eventually became effectively unusable, at which point his local network connection started dying at random (but increasingly frequent) moments. We had him try LAN jacks at other desks, where other people were using the same software without a hiccup, but it made no difference.

He finally prevailed on the IT department to swap his motherboard and network card and reroll the OS, and it started working again…for a while. Then the progression of symptoms started over again. That time, they swapped the hard drive. At this point, he effectively had a new machine–the only original components were the case, power supply, and a floppy drive. (Why they didn’t just issue him a new machine involves large dollops of bureaucratic stupidity.)

Yep, same symptoms.

I finally prevailed on IT to give me a copy of their install disks, so I could just reroll the machine for him whenever it started to get out of hand. I installed it once…and the machine was still working smoothly when he transferred to another department, and they issued him a laptop…about which, the less said, the better.

I had an SD card that was like this, except that the criterion was simply '‘not windows’ (or not windows XP, didn’t really try any other version,) as opposed to ‘only Linux’. As well as Linux, this card would read and write fine in any palm device, pocket PC or windows mobile - I’m pretty sure it worked in my camera, mp3 players, etcetera.

Windows wouldn’t even admit that there was a card there to format. Formatting with any other device didn’t see to affect the voodoo.

I ended up sticking it in a drawer, because I couldn’t see anything I could do with a 512 meg card that would be worth the trouble, considering how much I use windows card readers for nearly any device using an SD card. (And now, as I type this, I’m wondering if I could load it with a few hours worth of my favorite music via the Linux netbook and keep it plugged into the MP3 boombox in the bathroom…)

One of the laptops in the shop at work has some commercially sensitive software installed on it and we need to use it to perform adjustments to equipment. It uses a USB Alladin HASP anti-duplication security dongle for authentication. One day, this dongle stopped working and was quite stubborn about revealing why. It worked fine on other PCs and other USB devices worked fine on the laptop. The laptop would make the Windows new hardware noise and but it just showed something like ‘unknown USB device’ in the Device Manager on any of the USB ports.

The solution: Plug the dongle into a small four-port USB hub and plug the hub into the laptop. No Problem!

On principle, I spent far more time trying to find out why the fix worked than it deserved. I still can’t figure it out.

For what it’s worth, the two scenarios I’ve had success with a hub instead of a direct connection:
Power droops on the internal hub can be hidden by a powered external hub
Minor signal integrity issues (and USB spec violations, for that matter) can be hidden by an external hub.