Firefox and Netflix Not Getting Along

Of late, Netflix is crashing my Firefox.

This is what happens:

  1. Open Netflix.
  2. Screen flashes blue, twice - not blue-screen-of-death blue, but like a blue cloud - you can see through it.
  3. The crash happens any time from immediately to five minutes into the movie.
  4. Crash reporter pops up, I restore my tabs, lather rinse repeat.

I have “sent the crash report” every time, but I have little faith that it actually goes anywhere useful. Is anyone else having this problem, or does anyone have ideas on how I can reunite Firefox and Netflix in holy technological matrimony?



best course of action to resolve firefox Flash issues is to delete cookies and history, it usually helps, but can be painful if you have no other password management tool.

What version of Firefox are you running? Do you have the latest version of Silverlight?

Netflix uses Microsoft’s Siliverlight softtware, at least on PCs. This post from Firefox’s help pages suggests running Firefox in 32-bit mode. If you’re not already doing that, you might try it.

Thank you for the suggestions! Unfortunately:

*I started opening Firefox in 32-bit and
*Updated Silverlight and Java and Firefox (version 13.0.1, up to date)

And at first things were better! But then it crashed again, and now it won’t open - I can open Firefox, and I can go on other websites, but if I try to open Netflix, the little spinning-round-rainbow-of-doom comes up, and just stays there, loading indefinitely, until I have to force quit all of Firefox.

Is this something that would really be fixed by deleting cookies and history (something I am loathe to do because it is a pain in the butt) or is there anything else I can do?

Thank you!

Well, you can try just deleting Netflix cookies–there’s an option to “remove individual cookies” in the Privacy tab of the Firefox Options (Firefox > Options or Tools > Options). Just search for netflix in the box and delete all those.

Java should be irrelevant, BTW. In fact, unless you have something you know you use it for, I usually tell people to disable it, then, if nothing goes wrong, uninstall it–that way you don’t have to worry about malware from it.

You could also just always open Netflix in Internet Explorer.

EDIT: Also try disabling any addons or plugins you don’t really use. Heck, you could just disable them all, try it, and, if it works, add them back one at a time until you find the one that causes problems.

Do you actually have a Mac? Prolly best to remove Silverloght and install a fresh copy from microsoft.

Huh, I don’t see anywhere that mentions it’s a Mac, although “starting in 32-bit mode” would imply that, as the other OSes don’t have a 64-bit mode yet.

Silverlight has been notorious for problems on the Mac. I would at least suggest uninstalling it, get a fresh copy, and install it as an administrator.

Well, the “Force Quit” and “Spinning Rainbow” are Mac terminologies…

It is a Mac!

Which, fortunately, is fixed now - I ended up uninstalling and reinstalling everything I could think of (Silverlight, Adobe Flash, Firefox itself) but to no avail. I even tried deleting all my caches and cookies and pies in Firefox, but it had gotten to the point that even trying to do that would bring on the spinning rainbow of internet incompetence. The problem also spread out and was affecting websites other than Netflix (in particular, a website I need for school would bring on the freeze). I tried opening things in Safari, but quickly encountered the same problem, just with slightly different websites (the school website would work, but Netflix and the school’s library website did not). I ended up calling Apple, and the solution turned out to be deleting my caches from the hard drive. Now it is working like a peach.

Thank you everybody for your help! It gave me hope when I thought my most sensible option was chucking the whole thing out the window, running over it with my car, then setting the crunched remains on fire (I have a low tolerance for computer problems).