Getting Rid of Auto-Complete on Searches

Using google image search, I’ve searched for some, uhhh, entertainment that I would be embarassed about if Mrs. Homie were to find out about it. Yet when I enter search terms into just about any search bar, my browser brings up search terms I’ve used.

For example, looking for “Hot apple cider,” when typing in the h-o-t-a I get a reminder that I have, in fact, searched for “Hot Asian babes” as well.

Is there a way to put a stop to this?

In google image search, to the right of the box where you would type in ‘hot asian babes’, click on preferences. At the bottom of the page is query suggestions which you can turn on, or off.

Use a different user account, dude!

Also, you can delete history, and I believe one of the things you can delete is “completed fields.” It may be worded differently, but the effect is the same.

However, the absence of anything is just as incriminating as the presence of anything, unless you have a handy excuse. Such as “The computer was running slow so I deleted cookies and their ilk to try to make it go a little faster.”

Not that I’d know.