Gimp is driving me CRAZY

I’m going nuts, here. I’m trying to edit an image one pixel at a time. I have the pencil set to the right setting, 1 pixel. It works fine for a minute. Then, I’ll click and the pixel I clicked turns the right color – and three other pixels near it change back or get erased! Then I hit undo, and it changes but it doesn’t go back to the way it was! ARGH!

I have also tried selecting a row of pixels and doing a fill, but it doesn’t work. Just now, I selected about 6 pixels, and only five of them changed colors!

I don’t think that this is a problem with my computer, because I sent my husband the image and he had the same problem on his work computer. I also have the most recent version of Gimp.

Can you help me???

Bring out the gimp!


      • You didn’t say what OS you were running on… or what OS/program your husband uses…
  • When I tried to use WinGIMP on Win98SE, aside from the fact that WinGIMP had no instructions, it crashed a lot–particularly when I attempted to perform any technically inappropriate function on something, which was often, because there were no instructions telling you what not to do. I accidentally closed one of the tool palettes and couldn’t figure out how to get it back again, over the next two weeks I never did see it again. After about two weeks GIMP disappeared from my HD permanently, “as good as Photoshop” my foot.
  • Get yerself Photoshop or something cheaper, PS Elements, Paint Shop Pro or whatever if you’re poor. Many have 30-day trial versions free online.

I’ll highly recommend PaintShop Pro 7.0. It’s truly awesome, and blows away Photoshop, as far as I’m concerned.

It’s the *nix Gimp that is called as good as Photoshop, while the Windows version is notoriously buggy. Don’t interpret your experience with WinGimp as a failure of Gimp in general.


Sorry, I am using Linux. AFAIK, Photoshop et al don’t have Linux versions, do they?

Other than this one problem, Gimp is great. I’ve been using it for more than a year. This is just driving me crazy.