Google Maps satellite view working for anyone?

I’m having an odd problem where I can use Google Maps, but I can’t see the satellite view. At all zoom levels, it gives me the “We’re sorry, but we don’t have imagery at this zoom level for this region” squares. Maps and terrain view work just fine, and the satellite view has worked from here before. Is it just me?

I just tried it, and I can get satellite views for many different US areas.

I’m assuming Windows, either 2000 or XP. Windows is notorious for leaving processes running after you kill the application. So run ‘task manager’, go to the ‘processes’ tab, and see if u can identify any ‘orphans’ - processes still running for applications you quit. Adobe Acrobat is notorious for this; I was having this very problem, and killing orphans [don’t mean to make this sound cruel, but there u go] will release whatever memory is needed for Googlemaps to work rite. Else, save your work, reboot, and try the Googlemaps before starting any other app.