Google redirection?

When ever I start up the internet, my homesite takes me to, .ca I was told indicates a canadian site. Whenever I try and go to it redirects me to

That’s two different issues. The home page thing is probably because Google.CA set it that way on your machine. Stealing home page settings is a vile, but pervasive, abuse of trust by website operators. You can change it back to whatever you want in your browser settings, but that doesn’t make it less obnoxious. As for the redirection, it’s probably Google trying to build traffic on its Canadian site and reduce traffic on the US site.

What Davebear said. It is the same Google engine, with two extra options: search in French and restrict search to Canada. Since Google Canada has its own advertising income, they probably hope to increase use (and Google’s revenues) by directing Canadian users to the Canadian engine.

It may be a cookie. Check if you have cookie with an obvious Google-related name and delete it.

It happens with cookies disabled too. Many sites provide content based on your IP address, which (depending on your ISP) can be mapped to a physical region. If your ISP is a known Canadian provider, Google will redirect you to their Canadian site. If not, there could be some misconfiguration on Google’s part.

The redirection may have something to do with the sticky legal ground in Canada of both official languages being required in certain places such as cereal boxes and business signage. Wasn’t there a case a while back of a website being sued for not providing content conforming to the laws of the viewer’s country? It’s a difficult and complex issue.

Incidentally, your homepage is probably also being redirected; I don’t think Google diddles your settings that way.

I don’t know why it redirects you, but here’s how to get it to stop:

On the main page, there’s a link to on the lower right, next to “Jobs, Press & Help”. If you click the link, it’ll change your cookies so that you always to to instead of being redirected to

“…so that you always go to”, that is.