Hard drive not detected

Finally got the money to build the second computer… everything went swimmingly well, installed a cute little 10 gig drive for winxp pro, and the huge 250 [factory refurbish] maxtor hdd. No problem with the cute little drive, but the system absolutely refuses to recognize the maxtor 250 gig hdd … is there some quick and dirty way to see if it is actually powering up and functioning? Is it dead in the water and I have to convince an online computer place to let me returnand replace it coughtigerdirectcough? Am I fucked out of the ± $90 for the drive and have to get a different drive and suck up the cost?


Why is it so fucking difficult in the world of Microshit rulez all to have components that are designed to just slam in and they actually work without lots of fucking around with bios/cmos/crap I shouldnt have to fuck with because the world of PC is microshit [theoretically] compatible?

Hard to read the questions in the middle of the rant.

Let the Pitizens share with you.

samclem GQ moderator

You’ve got it jumpered correctly, yes? How old is the PC? Older PCs may have trouble with such a large HDD.

Until an expert comes along, having just gone through the self same thing, I needed some drivers for XP to recognise the drive. This was a SATA hard drive though which possibly makes a difference.
I do know though that the drive had been recognised in BIOS, so you could check there. I also had no external indication the drive was running.

  1. Are the jumpers on the drive set correctly? If it’s on the same IDE port as the 10 gig it needs to be set to slave.

  2. Is it a SATA hard drive? If so, you need to install drivers for it from your motherboard manufactorer.

  3. Finally, go to control panel-> administrative tools->computer manangement->disk management (it’s one of the options on the left hand menu)

What drives are listed ther? You need to format a drive before Windows can recognize it. Until you do format it, this is the only place you’ll see it listed. You have to click on the drive and select format (i think it’s under the ‘Action’ item in the top menu.)

First of all, is this an SATA drive, or an IDE drive? Also, follow the above advice about using the physical disk manager in XP to see if the drive is installed and simply needs to be formatted, named, partitioned or assigned a drive letter.

My new motherboard supports SATA drives, but I couldn’t get the drive recognized. I finally needed to go to the disk manager to ensure it was assigned a drive letter.

And really, “the world of Microshit rulez”? Give me a fucking break. I put money at 10 to 1 odds that it’s user error. If not user error, it’s an issue with the physical drive itself(being a refurb and all), and I’m sure Tigerdirect(being a reputable dealer), won’t have a problem returning or exchanging.


If its a Maxtor, it should have come with a Maxblast CD. The CD has some good diagnostics to tell you if its functioning correctly. If the CD didn’t come with the drive, you can download the files from the Maxtor website. Good luck!

Well, the “quick and dirty” way is to check the POST information on boot and see if the drive is listed there. Knowing that (plus the other information everyone else posted) is a start.

And why do I have to read some book to figure out how where to put the oil in my car? I just should be able to dump it in any hole and have the car figure it out! Stupid Ford – they’ve been making cars for long enough to have solved this problem by now.

You don’t generally have to rtfm to put oil into a car, on the last 3 cars i have had [a vw, a subaru and a chevy] have actually had the oil fill cap labled oil … though i am somewhat bemused by why ford made it so annoying to change the oil filter on my old 75 mustang.

Is a brand new build. Got a soyo barebones[ok, stop laughing now] last christmas from my parents, and just finally got the money this christmas to get the rest of the bits to actually build it.

tigerdirect sku #THD-250M8 factory refurbished maxtor 250 g hdd. Jumpered per the little diagram on the hdd itself. Followed the book that came with the MB itself, made sure that all the inner bits matched up with the required specs as to types of thingys like cpu/ram/vid sound & network cards. All tucked in per directions and turn it on for the smoke test and get into cmos. It detected the cd just fine, refused to recognize the hdd. I had figured there might be some sort of need to format hdd, although last time i did a virgin install of winxp it asked me if i wanted to format the hdd so i had figured it would do the same this time. Not that big a deal, I had a tiny ancient 10g h dd on hand that had previously had xp on it so that got tucked in as primary master, and the 250 gg hdd rejumpered as slave.

Had no problem, it recognized tiny immediately and still refuses to recognize the new 250 gg. much frustration ensues.

Jumpers all set, drivers all installed, only drives listed in management are the cd rom and the baby drive.

Forget XP until you can get your drive listed at POST. It absotivly has be there before anything else will happen.

As I understand it, the drive isn’t recognized as either master or slave on boot… at that point I’d be trying it in another machine, but assuming you don’t have one, in order I’d look at:
-Making sure you have an 80 wire IDE cable, and not the older 40 wire style
-Sticking it on the other IDE controller with your CDROM
-Updating your BIOS.

Next time buy an Alfa Romeo. You can simply pour the oil into the gas tank. Either way it ends up getting burned.

I agree that this is a prime suspect, particularly since the system seems to be using two drives of radically different age. If not, what happens if you remove the 10GB and re-jumper the 250GB as the master? Does it recognise it then? As Nanoda says, Windows is a complete red herring at this point, as it doesn’t sound like you can even get the BIOS to spot the device at present.

Also, for what it’s worth, if the 10GB drive really is that old it’s very likely to be slower than the 250GB and slow down the whole system as a result, as an IDE channel can only run at the speed of the slowest device on it. Is the extra complexity and loss of performance really worth the extra 10GB of space?

Allow me to throw in my $0.02 worth

that 10GB is pointless, you probably aren’t going to put a dent in that 250G for a while.

it started out with the 250 gig as the master, i only slapped in the spare baby drive to get winxp on something so i could perhaps manage to get the 250 formatted. I am planning on taking out the baby drive as soon as I can get the 250 up and running. And Nanoda is correct, my new computer absolutely refuses to recognize the 250 gig drive as anything other than perhaps an interesting lump of metal and plastic cluttering up a bay=)

I have a brand new rather funky looking shielded cable [only thing that staples had. We discovered the original ribbon cable had a exceedingly tiny nick in it exposing a microscopic amount of copper, but we decided to replace just because.

by updating the bios you mean doing the jumper short thingy? is there a new bios available somewhere?

sigh and the 250 gig didnt come with any driver/utility disc at all, so I have to dissassemble to get the exact specifics so I can be certain to get the right drivers and utiulities from the maxtor site.

As I ranted about before, PCs have to be some of the most annoying products out there. I wish things were a bit more standardized, so that stuff really is plug and play, not plug and pray. I wonder if sacrificing a few chickens would help/.

Let’s review the bidding:

We have a PATA 250Gb drive that is not being seen by the MB, said mothervoard being slightly over a year old

Mb does see the CD and the other drive.

The cable is somewhat new, and for all intents and purposes should work the new drive.
The only other test I would try is move the cable from the working 10Gb drive to the 250 and see what happens, but I think that we are looking at a out-of-the-box failure on the 250.
Last shot in the dark----Does the drive spin up at boot? Have you tried another power plug? Stranger things have failed…

Remember, refurbished means “broke once”.

Is there another computer around where you can pop the 250 in?