Help needed from Mac users

Okay, so my boss bought me a nice new 27" Imac a few weeks ago. Great. Love it. Awesome screen, nice sound, fast, almost perfect.

Of course, I can’t seem to drag files from the desktop to a floppy disc on an external (duh) drive plugged into a USB port. Any ideas on why and what I can do to fix that?

And yes, I know there’s really no reason why I should even need to use a floppy. Believe me, if I had my preferences I wouldn’t. Unfortunately, at the moment it’s kind of necessary.

Broken arm? Clinical paranoia of magnetic media? Gremlins? You’ll need to at least give us a hint as to why you can’t drag the files, or what happen when you try…

Without that, my best guess is that your floppies are formatted with some file system that the Mac can read but can’t write, and it therefore has mounted as a read-only disk and will “bounce” your files back when you attempt to drag them there. In which case…reformat. It’s also just a good chance the floppy itself is damaged; the last ones made are probably nearing the end of their useful life at this point.

And let’s not forget that the floppies themselves have a read-only mode set with that button on the back that slides back and forth.

I’d go with TimeWinder’s suggestion. I’ve had the same problems swapping files between my PC and Macbook. If it isn’t formatted with a filesystem Mac can write to, you can read from it but can’t write to it. FAT32 is usable on both Mac and PC for read and write, so if you’re swapping files between the two, that’s the format you want to use.

I don’t think it’s possible to format a floppy as FAT32 - believe they’re FAT16 or even FAT12.

It used to be that you needed extra software such as DOS Mounter or PC Exchange on the Mac to properly recognize and be able to write to PC-formatted floppies. Not sure if that’s the case now.

Over the years, there have been a handful of different types of floppy drives for Macs, just as there have for PCs, so it’s also possible that the drive you’re using is incompatible.

At least as far back as 2000, Macs have been able to read and write to PC-formatted disks with no additional software needed.

If you formatted a floppy disk or a Zip disk or a CD-ROM or a hard drive with the Mac in its native format (HFS+), a PC could not read it, but Macs could and still can read and write to PC-formatted (FAT) disks.

I haven’t had to use PC Exchange since my Mac IIsi running under System 7, which I used from 1991-1999.

I recently had an issue attempting to copy something from my wife’s Mac onto a PC-formatted external hard drive. It regarded it as read-only.

As mentioned, MacOS X will read and write to Microsoft’s FAT file systems — but it can only read NTFS, not write. To see the file system your external disk is using, do a “Get Info” on the drive, and in the info window look for the “Format:” field in the “General” sub-section.

If NTFS turns out to be the issue, there are third-party drivers you can install that might work for you. A helpful article on the whole subject is here.

Can you open the files and save to the USB drive that way? That will tell you if it’s a drag-and-drop issue or if that USB drive simply won’t accept files from this Mac.

If this is an old Mac disk (pre HFS+, for use with Systems 6 and 7), know that Apple dropped support for writing to HFS volumes with Snow Leopard (10.6). I ran into this problem when trying to get downloaded files onto an HFS disk image for use in an emulator - I can see inside them, but I can’t write to them.

Thanks for the tips. No luck so far.

Cat Whisperer I tried that too, and nothing happened.

The reason I’m trying to do this is we run primarily on Macs but use PCs for operating CNC milling machines. I was trying to put an eps file on the disc so I could pass it over to one of the programmers. I ended up putting it on a thumb drive, which worked fine.

Of course, the simplest solution is to network all the computers so I can just move a file from one to another. We’re getting there, but aren’t quite up to speed yet. Damn it Jim, I’m a photographer, not a computer diagnostician.

I’m having other issues with software transfer and apps that I moved from my G5 to this computer not starting up, so I expect to have a few weeks of fun sorting everything out.

Glad you found something that worked. It sounds like you got a little ahead of the rest of the tech in your office.

If you were using a G5 before with specialized software, it’s probably a good idea to see if the apps you’re having problems with have been upgraded to Universal Binarys. It’s also possible that you were using Classic apps on your G5, and those aren’t supported at all on Intel Macs (pretty much every Mac made since 2006).

I’m not using any Classic Apps, but I forgot about the PPC to Intel change. That might be part of the problem.