help with an Access form?

Anyone know what’s going on with this form in Access? Up until this morning, the form was working just fine. And it still is—as long as I’m the only one in the database.
But today, as soon as someone else opens the database, I get the “You do not have exclusive access to the database at this time. If you proceed to make changes, you may not be able to save them later.”

That’s the same error I’d get if I were trying to open the form in design view—but I’m not. Uses can enter through that error and to the form, entering data with no problem, but it is an annoyance. Anyone know what would cause this? The people using this database don’t need exclusive access to do their data entry, but the form seems to think they do for some reason. There are about 10 forms in the database, and they all work fine except this one.

I’ve seen this type of weirdness in all versions of Access.

Some things to try:

  • ensure Users do not have the “Open database in exclusive mode” option
  • compact and repair db
  • rename form to .old, then copy back to original name. The copy might work differently
  • in similar manner, copy the db file and start using the copy

All my problems went away after I:

  • split the db into front-end (forms, reports, modules) and back-end (tables only) The FE has linked tables to the real tables in the BE. Access has a utility to do this for you.
  • the users run individual copies of the FE on their C: drive. The BE stays on a network drive.
  • the users are instructed to launch the application using a script on the network that robocopies the master version of the FE to their C: and then opens that copy. That way they always get an up-to-date version of the FE if you make changes to the master.

I’d love to split the db as you said, but managerial decisions above my head are tying my hands in that regard.
I know the users aren’t opening the db in exclusive mode, because it only happens on this one form.

Compact and repair did nothing for me as well, and the problem still exists in the copy. I’m completely stumped.

I stopped buying Microsoft products because everything stops working every time you upgrade to a newer version. You can spend months designing forms, macros, etc., then none of them work after an upgrade.

They also like to change the user interface without asking any of their customers if they like what is currently there! (More wasted time having to learn a NEW user interface with each upgrade.)

Might want to switch to Open Office…
https://www.openoffice.org/

Not really an option for me, because it’s at work and I can pretty much guarantee the Very Large Corporation I work for isn’t going to ditch Microsoft anytime soon.

Have you tried creating a brand-new database, then importing all of the data, forms, reports, etc., into it? You’ll need to do this while nobody else is using the database, of course. Sometimes I’ve had success with this approach.

I’ve done this as a last resort and it usually works

Close the database and Access and make sure no one else is in there, then look in the folder containing the database files for something with a .laccdb extension. It’s a lock file that should be automatically deleted when the database is closed, but sometimes the DB gets messed up and they hang out. If you see one, delete it.

But no matter how you resolve this, I think you’ll continue to have issues as long as you have the front-end forms and back-end tables in the same file. What’s the managerial reason for not splitting the tables out? It’s typically the #1 recommendation for any multi-user Access database.

One of the best forums for Access is here:

http://www.utteraccess.com/

it’s not the lock file–that would affect all of the forms. As for the managerial decision—it’s complicated and political, but essentially boils down to certain parties not grasping how these things work and being too stubborn to admit anyone knows better. As I said, I work for a Very Big Company, and decisions like this get made several levels above me and my immediate boss is too timid to question any orders from above.

Locks are also for design elements like forms, not just data rows. So there could be a bad lock on that particular form. It doesn’t sound like what’s happening, but it’s an easy thing to eliminate by deleting the file.

Is the form being opened and closed from code? What commands are used for opening and closing? I’m wondering if it’s not the form but the way it’s being opened and/or closed. For example, using DoCmd.Close acForm, “MyForm”, acSaveYes to close it would save the form itself (not the data), causing issues if anyone else had it open.

THE best