Help with text mode in Cygwin

I run win98 but have downloaded Cygwin to have a unix-like environment. I’ve read the help section at the cygwin page, but it doesn’t answer this question.

All the mount points are in the default binary mode. I want to change one of them to text mode. The help pages don’t say how to do this, except maybe to modify the system registry. I’d rather avoid doing that, as I suspect it may screw things up. It’s not that I’ve never modfied the registry, but it seems to me there should be a way of changing the mode without doing that.

I tried making a new mount point for the directory I’m using, but I must be doing something wrong, as I keep getting errors. I’m not very familiar with the mount command, so obviously there’s something I don’t understand about it.

Can anyone help?

Hmmm, when I installed it, the default was text mode and it was a nightmare. Just an awful mess. I edited the mount info the registry and changed that. Surprisingly, the “mount” command didn’t change default settings at the time. (Which would have been The Right Way.) But try that and see if they fixed it.

You can also do a reinstall and when it asks for default mount type, tell it. (There are shortcuts you can take to bypass a lot of reinstall so it doesn’t take that long.)

I have had no problem whatsoever using binary mounts, myself.

Binary files are a problem if you are creating a file that will be used by a Windows application.

If the file comes out of a program I’ve written, it’s no problem. I can always write out both the carriage return and new line. But if it comes from a Cygwin utility, then it’ll be missing the carriage return and Windows app (in my case, just Notepad) gets it screwed up.

There’s another fix I thought of and that’s just to write a simple program that rewrites a file with the carriage return. That’s probably what I’ll do.

Well, it’s nice to know that just changing the registry will not break things.

Well, if you just want to convert eol formats, use the commands “dos2unix” and “unix2dos”.

But be warned: a lot of truly binary files will get munged automagically behind your back.