How can I tell what codec I'm missing?

I have a bunch of avi files that only play audio but a black screen for video, and I have a few others that won’t play at all, saying that “The format is not supported.” I downloaded the ACEMCP, a codec pack that supposedly contains every codec I’ll ever need. The avi files still don’t work, though. Is there some way I can analyze the file to tell which codec is needed? Or alternately, is there a program that will convert all codec types into the same one, so only one codec is needed? Thanks in advance.

More than likely what you have are DiVX-encoded avi files. Do a Google search on “DiVX encoded avi” and you’ll find all the info you need.

Well, I already have a bunch of DivX codecs installed. I’ll make a list here of all the codec I have.

ASUS Video Decoder V1
ASUS Video Decoder V2
ATI VCR1 Codec [VCR1]
ATI VCR2 Codec [VCR2]
avimszh.dll
avizlib.dll
Cinepack CoDec
DivX :wink: MPEG-4 (Fast-Motion)
DivX :wink: MPEG-4 (Low-Motion)
DivX 5.01 Codec
DivX Codec 4.12
FullMotionVideo Decoder
Huffyuv lossless codec [HFYU]
Indeo® video 5.10
Intel I.263 CoDec
Intel Indeo 3.2 CoDec
Intel Indeo Video Raw 1.2 CoDec
ir41_32.ax
iyuv_32.dll
Microsoft 420 CoDec
Microsoft H.261 CoDec
Microsoft RLE CoDec
Microsoft YVYU CoDec
Morgan Multimedia MJPEG 32-bits CoDec
MS-MOEG-4 MPEG-4 Video CoDec
Pegasus Wavelet 2000 CoDec
PICVideo Lossless JPEG CoDec
PICVideo MJPEG CoDec
TechSmith Screen Capture CoDec
VFAPI Reader CoDec 1.01
XviD MPEG-4 Video Codec

Thanks again

Or, you could just scroll to the bottom of the Porn site you are trying to use and see which codec they recommend.

Or, get your porn from CDs.

If things are only slightly screwed up, you can find the avi file, right click on it, select properties and you might be told what codec it is. Then re-install that codec, etc.

But if the system tells you “unknown codec” or some such, then the way I determine the codec is to dump the head of the file as text and there is usually a human readable codec name & number. (I use cygwin unix-type tools like “head”, I don’t know what “normal” people would use.) Hmm, just did a dump using “more” in a MS-DOS window on some avis. Kinda hard to tell what the codec is if you’re not familiar with them.

Assuming you’re using Windows, try right-clicking on the avi file and looking at Properties/Summary (sometimes takes a while to appear). It should name the codec under “Video compression”. But that’s a pretty comprehensive list you’ve got there, I’d be surprised if you didn’t already have the codec.

There’s something called the “Nimo Codec Pack” that has solved some similar problems for me. I’d give you link but Google seems to not working now. When it’s up, search for “Nimo Codec Pack”. Or use another search engine.

The method ftg refers to works great sometimes, but can be a little confusing, as he says.

A better way would be to download this small command-line program which gives you results in a more readable format. The same site also has a list of codecs that you can check your results against.

Hey, there is a divx 5.03 codec out now. I needed to install it to view the latest episodes of Buffy the Vampire Slayer. With 5.02 installed I only got a blank screen with sound.

Bookmark that site so you’ll be up to date.

Cool, neutron star. Thanks.

Codec?

Stands for “code-decode” right? Lets a machine translate between an analog and digital signal.

Isn’t that what a modem (modulate-demodulate) does?

Check out this website, which has a nifty program for figuring out which codec you need:

Which Codec Does this Avi File Require?

I use a little app called G-Spot, which gives all sorts of info on the video and audio codecs for your files. It doesn’t provide codecs for you, but it identifies what’s there and what (if anything) you need.

You can find it here.

Wow, that G-Spot program really hit the…nevermind. It worked and all, and I got the codec I needed installed. I couldn’t get that other thing to work, though. I guess I’m not that good with DOS. G-Spot has a nice interface, so I would suggest using that for the people using Richard’s prog. Also, one of the avi s still didn’t play, so I attempted to rebuild it. That worked, but it turns out the file was missing 135mb of data. Another file i attempted to rebuild turned out to not even be an avi. Thanks for all the help guys.

Another “oh, cool”. But do they have to name it that? My Better Half uses the machine and …