How to horizontally flip an iPhone video?

Long story short(ish): I was holding my iPhone flat and slightly portrait aligned when I hit the video record button, then I lifted it up an moved it landscape as it was recording. For what ever reasons the iPhone decided that it was ‘upside-down’ relative to its starting position and recorded the video that way. I didn’t notice because, of course, the picture looked right-side up, only the small graphics on the recording screen were upside-down. And, also of course, I can’t just hold the camera upside-down to play it because the phone detects that and flips the picture back upside-down again thinking that’s right side up. Locking it in portrait mode obviously doesn’t help either (it will still flip the now smaller portrait image upside-down whenever you turn the phone around).

Strange thing is when I copy the file to my Windows 7 PC it plays right-side up in VLC (or anything other than QuickTime). I’ve tried converting the file to a different iPhone format (.MP4 or a slightly modified .mov) but iTunes won’t copy it back to the phone, always saying it’s no longer a playable file for an iPhone.

I assume it’s simply a case of the original video file’s ‘orientation bit’ metadata telling QuickTime to play it (essentially) upside-down (although I don’t know why VLC knows to play it correctly). Is there a way to modify just this bit on a PC, so that iTunes will just copy it back onto the phone and play it correctly? Or is there an iPhone app that will flip videos over?

You can strip the rotation metadata using ffmpeg:

VLC is playing it the right side up probably because it’s ignoring the rotation metadata

You can flip it within Quicktime itself, no need to do any conversion. Open the file in Quicktime and go to Window>Show Movie Properties> click on the Video Track and select the Visual Settings tab and there are options to flip or rotate the image.

Unfortunately I only have the free version of QuickTime and that function requires QuickTime Pro.

Thanks, that did it! Wasn’t exactly simply, had to download both ffmpeg and 7-Zip Manager (why can’t everyone just use WinZip aka PKZip!) and get all the files in the right place and copy & paste your command line, but it’s fixed. Thanks again. :smiley: