How to make trackpad "wake up" faster on laptop

On my Dell Latitude E6430 laptop running Win7, the trackpad doesn’t start responding for the first couple of seconds of use even though I’ve been typing. It’s dead when I start moving my finger on it, then suddenly starts responding. Since typical computer use often requires a great many brief uses of the pointer, and it starts working suddenly and shoots off somewhere so that I have to find it, this is pretty disruptive. Is there some way to keep it always on and ready?


It’s an anti-accidental palming feature. Check your trackpad drivers settings. It’s usually called something like PalmCheck or SmartSense or “Disable touchpad while typing” or such.

On Dell, it seems to be called TouchCheck – bottom of the settings screen.

I recommend that you set it lower instead of turning it off altogether because the touchpad is pretty annoying without it – while you’re typing, a stray palm touch or finger brush will suddenly move your cursor and click somewhere. I find that a setting of about 1 second is usually a good balance.